No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the MLD Snooping Querier

Example for Configuring the MLD Snooping Querier

Networking Requirements

In Figure 11-9, Source1 and Source2 on a Layer 2 network send multicast data to multicast groups FF16::1 and FF16::2. HostA and HostC need to receive data from multicast group FF16::1, and HostB and HostD need to receive data from multicast group FF16::2.

Figure 11-9 Network diagram for configuring the MLD snooping querier

Configuration Roadmap

To meet the requirement, enable MLD snooping on each Switch on the network and configure one Switch as the MLD snooping querier. To prevent the Switch from broadcasting multicast packets in a VLAN when there is no corresponding Layer 2 forwarding entry, configure each Switch to discard unknown multicast packets. The configuration roadmap is as follows:

  1. According to Figure 11-9, create a VLAN on the switches and add interfaces to the VLAN.
  2. Enable MLD snooping globally and in a VLAN on all the switches.
  3. Configure SwitchA, which is closest to the multicast source, as the MLD snooping querier.
  4. Configure all the switches to discard unknown multicast packets.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 2/0/2
    [*SwitchA-10GE2/0/2] port link-type trunk
    [*SwitchA-10GE2/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE2/0/2] quit
    [*SwitchA] interface 10ge 3/0/3
    [*SwitchA-10GE3/0/3] port default vlan 10
    [*SwitchA-10GE3/0/3] commit
    [~SwitchA-10GE3/0/3] quit

  2. Enable MLD snooping.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] mld snooping enable
    [*SwitchA] vlan 10
    [*SwitchA-vlan10] mld snooping enable
    [*SwitchA-vlan10] commit

  3. Configure the MLD snooping querier.

    [~SwitchA-vlan10] mld snooping querier enable
    [*SwitchA-vlan10] commit

  4. Configure the switches to discard unknown unicast packets.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA-vlan10] multicast drop-unknown
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit
    

  5. Verify the configuration.

    # After the MLD snooping querier is started, all devices except the MLD snooping querier can receive MLD General Query messages. You can use the following command to check MLD message statistics. For example, you can check statistics of received MLD messages on SwitchB.

    [~SwitchB] display mld snooping statistics vlan 10
     MLD Snooping Packets Counter:
       Statistics for VLAN 10
         Receive V1 Report:          0
         Receive V2 Report:          32
         Receive V1 Query:           0
         Receive V2 Query:           30
         Receive Done:               0
         Receive Pim Hello:          0
         Send Query (S=0):           0
         Send Query (S!=0):          0
         Proxy Send General Query:               0
         Proxy Send Group-Specific Query:        0
         Proxy Send Group-Source-Specific Query: 0
         Recv Invalid Packet:                    0
         Recv Ignore Packet:                     0
    

    The preceding command output shows that SwitchB receives MLD General Query messages and SwitchA functions as the MLD snooping querier.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     mld snooping querier enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE3/0/3
     port default vlan 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE3/0/3
     port default vlan 10
    #
    interface 10GE4/0/4
     port default vlan 10
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE3/0/3
     port default vlan 10
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 37939

Downloads: 13

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next