No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MLD SSM Mapping

Example for Configuring MLD SSM Mapping

Networking Requirements

The IPv6 multicast network shown in Figure 3-15 is running IPv6 Protocol Independent Multicast - Sparse Mode (PIM-SM) and uses the Source-Specific Multicast (SSM) model to provide IPv6 multicast services. The switch interface connected to the receiver is running MLDv2, while the receiver is running MLDv1 and does not support MLDv2.

On this network, the SSM group address range is FF3E::/64. Source1, Source2, and Source3 all send multicast data to IPv6 groups in this range, but the receiver only wants to receive IPv6 multicast data from Source1 and Source3.

Figure 3-15 Network diagram for MLD SSM mapping configuration

Table 3-10 Networking information

Switch

Interface

VLANIF Interface

IP Address

SwitchA

10GE1/0/0

VLANIF10

FC00:0:0:1::1/64

10GE2/0/0

VLANIF20

FC00:0:0:2::1/64

10GE3/0/0

VLANIF30

FC00:0:0:3::1/64

SwitchB

10GE1/0/0

VLANIF11

FC00:0:0:4::1/64

10GE2/0/0

VLANIF20

FC00:0:0:2::2/64

10GE3/0/0

VLANIF31

FC00:0:0:5::1/64

SwitchC

10GE1/0/0

VLANIF12

FC00:0:0:6::1/64

10GE2/0/0

VLANIF21

FC00:0:0:7::1/64

10GE3/0/0

VLANIF31

FC00:0:0:5::2/64

SwitchD

10GE1/0/0

VLANIF13

FC00:0:0:8::1/64

10GE2/0/0

VLANIF21

FC00:0:0:7::2/64

10GE3/0/0

VLANIF30

FC00:0:0:3::2/64

Configuration Roadmap

To meet the preceding requirements, configure MLD SSM mapping on SwitchD connected to Receiver to provide SSM services to receiver running MLDv1.

  1. Configure an IPv6 unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.

  2. Configure basic multicast functions on the switches to provide multicast data forwarding.

  3. Enable MLD SSM mapping on SwitchD and configure the mapping rules.

Procedure

  1. Configure IPv6 addresses for interfaces and configure a unicast routing protocol on the switches.

    # Create VLANs and add physical interfaces to VLANs on the switches. Configure IPv6 addresses for the VLANIF interfaces. Configure Open Shortest Path First Version 3 (OSPFv3) on the switches to implement IP interworking. The configurations on SwitchB, SwitchC, and SwitchD are similar to those on SwitchA and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10GE 1/0/0
    [*SwitchA-10GE1/0/0] port link-type access
    [*SwitchA-10GE1/0/0] port default vlan 10
    [*SwitchA-10GE1/0/0] quit
    [*SwitchA] interface 10GE 2/0/0
    [*SwitchA-10GE2/0/0] port link-type trunk
    [*SwitchA-10GE2/0/0] port trunk allow-pass vlan 20
    [*SwitchA-10GE2/0/0] quit
    [*SwitchA] interface 10GE 3/0/0
    [*SwitchA-10GE3/0/0] port link-type trunk
    [*SwitchA-10GE3/0/0] port trunk allow-pass vlan 30
    [*SwitchA-10GE3/0/0] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:2::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:3::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  2. Configure the basic IPv6 multicast functions on each switch.

    # On SwitchA, enable multicast routing globally and enable IPv6 PIM-SM on the VLANIF interfaces. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit
    

    # On SwitchD, enable MLD and set the MLD version to v2 on VLANIF 13 (the interface connected to the receiver).

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] mld enable
    [*SwitchD-Vlanif13] mld version 2
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

  3. Enable MLD SSM mapping on SwitchD and configure mapping rules.

    # Enable MLD SSM mapping on VLANIF 13 of SwitchD.

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] mld ssm-mapping enable
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

    # Set the SSM group address range to FF3E::/64 on all the switches. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] acl ipv6 number 2000
    [*SwitchA-acl6-basic-2000] rule permit source ff3e::/64
    [*SwitchA-acl6-basic-2000] quit
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] ssm-policy 2000
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

    # On SwitchD, map the multicast groups in the range of FF3E::/64 to Source 1 and Source 3.

    [~SwitchD] mld
    [*SwitchD-mld] ssm-mapping ff3e:: 64 fc00:0:0:1::2
    [*SwitchD-mld] ssm-mapping ff3e:: 64 fc00:0:0:6::2
    [*SwitchD-mld] commit
    [~SwitchD-mld] quit
    

  4. Verify the configuration.

    # Run the display mld ssm-mapping group command on SwitchD to check mapping between multicast sources and multicast group addresses.

    [~SwitchD] display mld ssm-mapping group
    MLD SSM-Mapping conversion table of VPN-Instance: public net 
     Total 2 entries    2 entries matched  
    
     00001. (FC00:0:0:1::2, FF3E::) 
    
     00002. (FC00:0:0:6::2, FF3E::) 
    
     Total 2 entries matched    
    
    

    The command output shows that multicast groups within the range of FF3E::/64 are mapped to Source1 and Source3.

    # After the receiver joins group FF3E::1, run the display mld group ssm-mapping verbose command to view information about group memberships established with SSM mapping on the switches. The following group membership information is displayed on SwitchD:

    [~SwitchD] display mld group ssm-mapping verbose
    Interface group report information of VPN-Instance: public net
     Vlanif13(FE80::225:9EFF:FE95:7C27):
      Total entry on this interface: 1
      Total 1 MLD SSM-Mapping Group reported
       Group: FF3E::1
         Uptime: 00:00:13
         Expires: 00:04:07
         Last reporter: FC00:0:0:8::2 
         Last-listener-query-counter: 0
         Last-listener-query-timer-expiry: off
         Group mode: exclude
         Version1-host-present-timer-expiry: 00:04:07
         Source list:
           Source: FC00:0:0:1::2
           Uptime: 00:00:21
           Source: FC00:0:0:6::2
           Uptime: 00:00:21
    

    The command output shows that Receiver has joined multicast group with the address of FF3E::1.

    # Run the display pim ipv6 routing-table command to view the IPv6 PIM-SM multicast routing table on the switches. The IPv6 PIM-SM multicast routing table on SwitchD is as follows:

    [~SwitchD] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
     (FC00:0:0:1::2, FF3E::1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::225:9EFF:FE01:20E
             RPF prime neighbor: FE80::225:9EFF:FE01:20E
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif13
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
    
     (FC00:0:0:6::2, FF3E::1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: Vlanif21
             Upstream neighbor: FE80::225:9EFF:FE95:7C2B
             RPF prime neighbor: FE80::225:9EFF:FE95:7C2B
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif13
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
    

    The command output shows that (FC00:0:0:1::2, FF3E::1) and (FC00:0:0:6::2, FF3E::1) entries exist on SwitchD and the protocol type is ssm-map, indicating that VLANIF 13 has joined the multicast group with the address of FF3E::1 using SSM mapping. After multicast sources FC00:0:0:1::2 and FC00:0:0:6::2 send multicast data to FF3E::1, SwitchD receives the multicast data from the two multicast sources through VLANIF 30 and VLANIF 21 respectively.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/0
     port default vlan 10
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE3/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 11 20 31
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address FC00:0:0:4::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:5::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/0
     port default vlan 11
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE3/0/0
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 12 21 31
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif12
     ipv6 enable
     ipv6 address FC00:0:0:6::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:7::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:5::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/0
     port default vlan 12
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE3/0/0
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 13 21 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif13
     ipv6 enable
     ipv6 address FC00:0:0:8::1/64
     pim ipv6 sm
     mld enable
     mld ssm-mapping enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:7::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/0
     port default vlan 13
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE3/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    mld
     ssm-mapping FF3E:: 64 FC00:0:0:1::2
     ssm-mapping FF3E:: 64 FC00:0:0:6::2
    #
    pim ipv6
     ssm-policy 2000
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 37992

Downloads: 13

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next