No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast VPN Extranet in Local Crossing Scenario (Multicast Source on the Public Network)

Example for Configuring Multicast VPN Extranet in Local Crossing Scenario (Multicast Source on the Public Network)

Networking Requirements

As shown in Figure 7-21, PE1, PE2, and P are devices on the carrier's backbone network. CE2 belongs to VPN instance vpnb. The receiver in vpnb wants to receive the multicast data sent from the source in on the public network.

Figure 7-21 Networking diagram for multicast VPN extranet configuration in local crossing scenario (multicast source on the public network)

Configuration Roadmap

The multicast VPN extranet function for the local crossing scenario (multicast source on the public network) can be configured to meet the service requirement. The configuration roadmap is as follows:

  1. Configure the carrier's backbone network and the VPN networks to ensure normal running of the unicast routing protocol. In this scenario, you need to configure static routes on PE2 and CE2, to enable the receiver on the private network to receive data from the multicast source on the public network.
  2. Enable multicast routing on the entire network. Configure the multicast function on the public network between the PE and P devices and on the private network between PE2 and CE2. In addition, configure a private network RP to serve the multicast VPN extranet group. The static RP address must belong to the public network instance.

Procedure

  1. Configure the carrier's backbone network and the VPN networks.
    1. Configure Open Shortest Path First (OSPF) on the backbone network to allow communication between the PE and P devices. The configurations of P and PE2 are similar to the configuration of PE1, and are not mentioned here. See Configuration Files.

      # Configure PE1.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface loopback 0
      [*PE1-LoopBack0] ip address 1.1.1.1 32
      [*PE1-LoopBack0] quit
      [*PE1] vlan batch 100 300
      [*PE1] interface 10ge 2/0/2
      [*PE1-10GE2/0/2] port link-type trunk
      [*PE1-10GE2/0/2] port trunk allow-pass vlan 100
      [*PE1-10GE2/0/2] quit
      [*PE1] interface 10ge 1/0/1
      [*PE1-10GE1/0/1] port link-type trunk
      [*PE1-10GE1/0/1] port trunk allow-pass vlan 300
      [*PE1-10GE1/0/1] quit
      [*PE1] interface vlanif 100
      [*PE1-Vlanif100] ip address 172.1.1.1 24
      [*PE1-Vlanif100] quit
      [*PE1] interface vlanif 300
      [*PE1-Vlanif300] ip address 172.3.1.1 24
      [*PE1-Vlanif300] quit
      [*PE1] router id 1.1.1.1
      [*PE1] ospf
      [*PE1-ospf-1] area 0
      [*PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
      [*PE1-ospf-1-area-0.0.0.0] network 172.3.1.0 0.0.0.255
      [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
      [*PE1-ospf-1-area-0.0.0.0] quit
      [*PE1-ospf-1] quit
      [*PE1] commit
      

      After the configuration is complete, OSPF neighbor relationships can be set up between PE1, P, and PE2. Run the display ospf peer command on PE1, P, and PE2, and you can see that the neighbor status is Full. Run the display ip routing-table command, and you can see that PE1 and PE2 have learned the routes to Loopback0 of each other.

    2. Configure VPN instances on PE2 to enable CE2 to access PE2.

      # Configure PE2.

      [~PE2] ip vpn-instance vpnb
      [*PE2-vpn-instance-vpnb] ipv4-family
      [*PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 200:1
      [*PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:1 both
      [*PE2-vpn-instance-vpnb-af-ipv4] quit
      [*PE2-vpn-instance-vpnb] quit
      [*PE2] vlan batch 22
      [*PE2] interface 10ge 1/0/1
      [*PE2-10GE1/0/1] port link-type trunk
      [*PE2-10GE1/0/1] port trunk allow-pass vlan 22
      [*PE2-10GE1/0/1] quit
      [*PE2] interface vlanif 22
      [*PE2-Vlanif22] ip binding vpn-instance vpnb 
      [*PE2-Vlanif22] ip address 10.1.2.1 24
      [*PE2-Vlanif22] quit
      [*PE2] commit
      

      # Assign IP addresses to interfaces on CE2 according to Figure 7-21. The configuration procedure is not provided here. See Configuration Files.

      After the configuration is complete, PE2 can successfully ping CE2 attached to it using the ping -vpn-instance command.

    3. Configure a routing protocol between PE2 and CE2 to import the VPN routes.

      This example uses the OSPF protocol to advertise routes between PE2 and CE2.

      # Configure PE2.

      [~PE2] ospf 2 vpn-instance vpnb
      [*PE2-ospf-2] import-route static
      [*PE2-ospf-2] area 0
      [*PE2-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*PE2-ospf-2-area-0.0.0.0] quit
      [*PE2-ospf-2] quit
      [*PE2] commit
      

      # Configure CE2.

      [~CE2] ospf 2
      [*CE2-ospf-2] area 0
      [*CE2-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] network 10.138.2.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] quit
      [*CE2-ospf-2] quit
      [*CE2] commit

    4. Configure static routes from the private network to the multicast source and public network RP.

      # Configure PE2.

      [~PE2] ip route-static vpn-instance vpnb 172.3.1.0 255.255.255.0 172.2.1.2 public
      [*PE2] ip route-static vpn-instance vpnb 1.1.1.1 255.255.255.255 172.2.1.2 public
      [*PE2] commit
      

      # Configure CE2.

      [~CE2] ip route-static 1.1.1.1 255.255.255.255 vlanif 22 10.1.2.1
      [*CE2] ip route-static 172.3.1.0 255.255.255.0 vlanif 22 10.1.2.1
      [*CE2] commit

  2. Configure the multicast function on the public and private networks.
    1. Configure the multicast function on the public network.

      Enable PIM-SM on the public network. Set the static RP address for the public to the IP address of Loopback 0 on PE1.

      # Configure PE1.

      [~PE1] multicast routing-enable
      [*PE1] interface vlanif 100
      [*PE1-Vlanif100] pim sm
      [*PE1-Vlanif100] quit
      [*PE1] interface vlanif 300
      [*PE1-Vlanif300] pim sm
      [*PE1-Vlanif300] quit
      [*PE1] interface loopback 0
      [*PE1-LoopBack0] pim sm
      [*PE1-LoopBack0] quit
      [*PE1] pim
      [*PE1-pim] static-rp 1.1.1.1 
      [*PE1-pim] quit
      [*PE1] commit

      # Configure PE2.

      [~PE2] multicast routing-enable
      [*PE2] interface vlanif 200
      [*PE2-Vlanif200] pim sm
      [*PE2-Vlanif200] quit
      [*PE2] pim
      [*PE2-pim] static-rp 1.1.1.1 
      [*PE2-pim] quit
      [*PE2] commit

      # Configure P.

      [~P] multicast routing-enable
      [*P] interface vlanif 200
      [*P-Vlanif200] pim sm
      [*P-Vlanif200] quit
      [*P] interface vlanif 100
      [*P-Vlanif100] pim sm
      [*P-Vlanif100] quit
      [*P] pim
      [*P-pim] static-rp 1.1.1.1 
      [*P-pim] quit
      [*P] commit

    2. Configure the multicast function on the private network.

      Enable PIM-SM on the private network. Set the static RP address for the private network to the IP address of Loopback 0 on PE1.

      NOTE:

      VPN instances of receivers only support a static RP, and the static RP address must belong to the public network instance.

      # Configure PE2.

      [~PE2] ip vpn-instance vpnb
      [~PE2-vpn-instance-vpnb] ipv4-family
      [~PE2-vpn-instance-vpnb-af-ipv4] multicast routing-enable
      [*PE2-vpn-instance-vpnb-af-ipv4] quit
      [*PE2-vpn-instance-vpnb] quit
      [*PE2] interface vlanif 22
      [~PE2-Vlanif22] pim sm
      [*PE2-Vlanif22] quit
      [*PE2] pim vpn-instance vpnb
      [*PE2-pim-vpnb] static-rp 1.1.1.1
      [*PE2-pim-vpnb] quit
      [*PE2] commit

      # Configure CE2.

      [~CE2] multicast routing-enable
      [*CE2] interface vlanif 22
      [*CE2-Vlanif22] pim sm
      [*CE2-Vlanif22] quit
      [*CE2] interface vlanif 20
      [*CE2-Vlanif20] pim sm
      [*CE2-Vlanif20] igmp enable
      [*CE2-Vlanif20] quit
      [*CE2] pim
      [*CE2-pim] static-rp 1.1.1.1
      [*CE2] commit

  3. Verify the configuration.

    Check the PIM routing table on PE2. The following command output shows that the public network instance is the RPF upstream interface in the PIM routing entry for group 225.1.1.1, and vpnb is the receiver of the multicast extranet group in the public network instance.

    [~PE2] display pim vpn-instance vpnb routing-table extranet source-vpn-instance public
     VPN-Instance: vpnb
     Total 1 (*, G) entry; 1 (S, G) entry 
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 1.1.1.1 
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:00:20
         Upstream interface: MCAST_Extranet(public net)
             Upstream neighbor: 172.2.1.2
             RPF prime neighbor: 172.2.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif22
                 Protocol: pim-sm, UpTime: 00:00:20, Expires: 00:03:10
     
     (172.3.1.2, 225.1.1.1)
         RP: 1.1.1.1 
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:00:20
         Upstream interface: MCAST_Extranet(public net)
             Upstream neighbor: 172.2.1.2
             RPF prime neighbor: 172.2.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif22
                 Protocol: pim-sm, UpTime: 00:00:21, Expires: -
    [~PE2] display pim routing-table extranet receive-vpn-instance vpnb
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry 
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 1.1.1.1 
         Protocol: pim-sm, Flag: WC EXTRANET 
         UpTime: 00:01:36
         Upstream interface: Vlanif200
             Upstream neighbor: 172.2.1.2
             RPF prime neighbor: 172.2.1.2
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: vpnb
     
     (172.3.1.2, 225.1.1.1)
         RP: 1.1.1.1 
         Protocol: pim-sm, Flag: SPT ACT EXTRANET 
         UpTime: 00:01:36
         Upstream interface: Vlanif200
             Upstream neighbor: 172.2.1.2
             RPF prime neighbor: 172.2.1.2
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: vpnb

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 100 300
    #
    router id 1.1.1.1
    #
    multicast routing-enable 
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1 
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0 
      network 172.1.1.0 0.0.0.255 
      network 172.3.1.0 0.0.0.255 
    #
    pim
     static-rp 1.1.1.1  
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 22 200
    #
    router id 2.2.2.2
    # 
    multicast routing-enable
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      multicast routing-enable
    #
    interface Vlanif22
     ip binding vpn-instance vpnb
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 22
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1 
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0 
      network 172.2.1.0 0.0.0.255 
    #
    ospf 2 vpn-instance vpnb
     import-route static
     area 0.0.0.0 
      network 10.1.2.0 0.0.0.255
    #
    pim
     static-rp 1.1.1.1
    #
    pim vpn-instance vpnb
     static-rp 1.1.1.1
    #
    ip route-static vpn-instance vpnb 1.1.1.1 255.255.255.255 172.2.1.2 public
    ip route-static vpn-instance vpnb 172.3.1.0 255.255.255.0 172.2.1.2 public
    #
    return
  • P configuration file

    #
    sysname P
    #
    vlan batch 100 200
    #
    router id 3.3.3.3
    # 
    multicast routing-enable
    #
    interface Vlanif100 
     ip address 172.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1 
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0 
      network 172.1.1.0 0.0.0.255 
      network 172.2.1.0 0.0.0.255 
    #
    pim
     static-rp 1.1.1.1
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 20 22
    # 
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.138.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif22
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 22
    #
    interface 10GE2/0/2
     port default vlan 20
    #
    ospf 2 
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255 
      network 10.138.2.0 0.0.0.255 
    #
    pim
     static-rp 1.1.1.1 
    #
    ip route-static 1.1.1.1 255.255.255.255 Vlanif22 10.1.2.1
    ip route-static 172.3.1.0 255.255.255.0 Vlanif22 10.1.2.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 44507

Downloads: 13

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next