No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 Multicast Load Splitting

Example for Configuring IPv6 Multicast Load Splitting

Networking Requirements

On an IPv6 multicast network as shown in Figure 9-8, SwitchE connects to HostA and has three equal-cost routes to the multicast source (Source). According to the default reverse path forwarding (RPF) check policy, SwitchE will select one of these equal-cost routes to transmit multicast data. When the rate of multicast traffic is high, the network may become congested, lowering the quality of multicast services. To ensure the quality of multicast services, IPv6 multicast load splitting needs to be configured so that multicast data can be transmitted through multiple equal-cost routes.

Figure 9-8 Networking diagram of multicast load splitting

Table 9-10 Networking information

Switch

Interface

VLANIF Interface

IP Address

SwitchA

10GE2/0/1 VLANIF 20

FC00:0:0:2::1/64

10GE2/0/2 VLANIF 30

FC00:0:0:3::1/64

10GE2/0/3 VLANIF 40

FC00:0:0:4::1/64

10GE4/0/0 VLANIF 10

FC00:0:0:1::1/64

Loopback0

FC00:1:1:1::1/128

SwitchB

10GE1/0/0

VLANIF 20

FC00:0:0:2::2/64

10GE2/0/0

VLANIF 60

FC00:0:0:5::1/64

SwitchC

10GE1/0/0

VLANIF 30

FC00:0:0:3::2/64

10GE2/0/0

VLANIF 80

FC00:0:0:6::1/64

SwitchD

10GE1/0/0

VLANIF 40

FC00:0:0:4::2/64

10GE2/0/0

VLANIF 100

FC00:0:0:7::1/64

SwitchE

10GE1/0/1

VLANIF 60

FC00:0:0:5::2/64

10GE1/0/2

VLANIF 80

FC00:0:0:6::2/64

10GE1/0/3

VLANIF 100

FC00:0:0:7::2/64

10GE4/0/0

VLANIF 140

FC00:0:0:8::1/64

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IPv6 addresses for interfaces on the switches.

  2. Configure an IPv6 unicast routing protocol, IPv6 Intermediate System-Intermediate System (IS-IS) in this example, to implement interworking among all switches and ensure that route costs are the same.

  3. Enable IPv6 multicast routing on all switches and enable IPv6 Protocol Independent Multicast - Sparse Mode (PIM-SM) on all Layer 3 interfaces. Configure the loopback interface on SwitchA as a candidate bootstrap router (C-BSR) and candidate rendezvous point (C-RP).

  4. On SwitchE, configure stable-preferred IPv6 multicast load splitting to ensure stable transmission of multicast services.

  5. On SwitchE, configure static multicast groups on the interface connected to the network segment of HostA, because HostA needs to receive data of these groups for a long time.

Procedure

  1. Configure IPv6 addresses for interfaces on the switches. SwitchA is used as an example in the following steps. Configurations of the other switches are similar.

    # Create VLANs and add Layer 2 physical interfaces to the VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30 40
    [*SwitchA] interface 10ge 4/0/0
    [*SwitchA-10GE4/0/0] port link-type access
    [*SwitchA-10GE4/0/0] port default vlan 10
    [*SwitchA-10GE4/0/0] quit
    [*SwitchA] interface 10ge 2/0/1
    [*SwitchA-10GE2/0/1] port link-type trunk
    [*SwitchA-10GE2/0/1] port trunk allow-pass vlan 20
    [*SwitchA-10GE2/0/1] quit
    [*SwitchA] interface 10ge 2/0/2
    [*SwitchA-10GE2/0/2] port link-type trunk
    [*SwitchA-10GE2/0/2] port trunk allow-pass vlan 30
    [*SwitchA-10GE2/0/2] quit
    [*SwitchA] interface 10ge 2/0/3
    [*SwitchA-10GE2/0/3] port link-type trunk
    [*SwitchA-10GE2/0/3] port trunk allow-pass vlan 40
    [*SwitchA-10GE2/0/3] quit
    [*SwitchA] commit

    # Configure IPv6 addresses and masks for Layer 3 interfaces.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1 64
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:2::1 64
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:3::1 64
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] ipv6 enable
    [*SwitchA-Vlanif40] ipv6 address fc00:0:0:4::1 64
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ipv6 enable
    [*SwitchA-LoopBack0] ipv6 address fc00:1:1:1::1 128
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  2. Configure Intermediate System to Intermediate System for IPv6 (IS-IS IPv6) to implement interworking among all the switches and ensure that route costs are the same (SwitchA as an example).

    [~SwitchA] isis
    [*SwitchA-isis-1] ipv6 enable topology standard
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis ipv6 enable
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] isis ipv6 enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] isis ipv6 enable
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] isis ipv6 enable
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] isis ipv6 enable
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  3. Enable IPv6 multicast routing on all the switches and enable IPv6 PIM-SM on all Layer 3 interfaces (SwitchA as an example).

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim ipv6 sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback 0
    [*SwitchA-LoopBack0] pim ipv6 sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. Configure a C-BSR and C-RP on SwitchA.

    # Configure Loopback0 on SwitchA as a C-BSR and C-RP.

    [~SwitchA] pim ipv6
    [*SwitchA-pim6] c-bsr fc00:1:1:1::1
    [*SwitchA-pim6] c-rp fc00:1:1:1::1
    [*SwitchA-pim6] quit
    [*SwitchA] commit

  5. Configure stable-preferred multicast load splitting on SwitchE.

    [~SwitchE] multicast ipv6 load-splitting stable-preferred
    [*SwitchE] commit

  6. Configure static multicast groups on the interface of SwitchE connected to the network segment of HostA.

    # Configure static multicast groups FF13::1 to FF13::3 on VLANIF 140.

    [~SwitchE] interface vlanif 140
    [~SwitchE-Vlanif140] mld static-group ff13::1 inc-step-mask 128 number 3
    [*SwitchE-Vlanif140] quit
    [*SwitchE] commit

  7. Verify the configuration of stable-preferred multicast load splitting.

    # Source (FC00:0:0:1::2/64) sends multicast data to multicast groups FF13::1 to FF13::3. HostA can receive multicast data from Source. Check brief information about the IPv6 PIM routing table on SwitchE.

    [~SwitchE] display pim ipv6 routing-table brief
     VPN-Instance: public net
     Total 3 (*, G) entries; 3 (S, G) entries
    
      00001.(*, FF13::1)
           Upstream interface:Vlanif60
           Number of downstream:1
      00002.(FC00:0:0:1::2, FF13::1)
           Upstream interface:Vlanif60
           Number of downstream:1
      00003.(*, FF13::2)
           Upstream interface:Vlanif80
           Number of downstream:1
      00004.(FC00:0:0:1::2, FF13::2)
           Upstream interface:Vlanif80
           Number of downstream:1
      00005.(*, FF13::3)
           Upstream interface:Vlanif100
           Number of downstream:1
      00006.(FC00:0:0:1::2, FF13::3)
           Upstream interface:Vlanif100
           Number of downstream:1

    (*, G) and (S, G) entries are evenly distributed on the three equal-cost routes. The upstream interfaces of the routes are VLANIF 100, VLANIF 80, and VLANIF 60, respectively.

    NOTE:

    The load splitting algorithm processes (*, G) and (S, G) entries separately using the same rule.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 30 40
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE2/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE2/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE4/0/0
     port default vlan 10
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:1:1:1::1/128
     pim ipv6 sm
     isis ipv6 enable 1
    #
    pim ipv6
     c-bsr FC00:1:1:1::1
     c-rp FC00:1:1:1::1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:5::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    return 
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 30 80
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0003.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:6::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 40 100
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0004.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:7::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 60 80 100 140
    #
    multicast ipv6 routing-enable
    multicast ipv6 load-splitting stable-preferred
    #
    isis 1
     network-entity 10.0000.0000.0005.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:5::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:6::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:7::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif140
     ipv6 enable
     ipv6 address FC00:0:0:8::1/64
     pim ipv6 sm
     mld static-group FF13::1 inc-step-mask 128 number 3
     isis ipv6 enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE4/0/0
     port default vlan 140
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 44664

Downloads: 13

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next