No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Bidir-PIM and IPv4 PIM-SM on the Same Network

Example for Configuring IPv4 Bidir-PIM and IPv4 PIM-SM on the Same Network

Networking Requirements

On the network shown in Figure 4-30, HostA needs to receive data for multicast group 225.1.1.1 through Bidir-PIM, and HostB needs to receive for multicast group 226.1.1.1 through Protocol Independent Multicast Sparse Mode (PIM-SM).

Figure 4-30 Bidir-PIM and PIM-SM on the same network

Configuration Roadmap

Configure dynamic RPs to serve Bidir-PIM and PIM-SM on SwitchA and configure ACL rules to define the range of multicast groups served by dynamic RPs. In this way, both Bidir-PIM and PIM-SM can function on the network. The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on each switch.

  2. Enable multicast routing on all the switches that provide multicast services.

  3. Enable Bidir-PIM on all the switches that provide multicast services.

  4. Enable PIM-SM on all interfaces of the switches that provide multicast services.

  5. Enable Internet Group Management Protocol (IGMP) on switch interfaces directly connected to hosts.

  6. Configure the dynamic RP function. On SwitchA, configure dynamic RPs on different interfaces to serve Bidir-PIM and PIM-SM respectively, and configure ACL rules to define the range of multicast groups served by dynamic rendezvous points (RPs).

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on each switch.

    Configure IP addresses and masks for switch interfaces according to Figure 4-30. Configure OSPF on the switches to implement IP interworking between the switches and enable the switches to dynamically update routes. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    # Add interfaces of SwitchA to VLANs. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 30 100 200
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 30
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 200
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # Assign IP addresses to interfaces of SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 10.110.3.1 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 192.168.2.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ip address 192.168.3.1 24
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ip address 10.1.1.1 32
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

    # Configure unicast routing protocol OSPF on SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] router id 10.1.1.1
    [*SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Enable multicast routing and Bidir-PIM on the switches.

    # Enable multicast routing and Bidir-PIM on SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] multicast routing-enable
    [*SwitchA] pim
    [*SwitchA-pim] bidir-pim
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit
    

  3. Enable PIM-SM on all the switch interfaces.

    # Enable PIM-SM on all the interfaces of SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 30
    [~SwitchA-Vlanif30] pim sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] pim sm
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] pim sm
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] pim sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit
    

  4. Enable IGMP on interfaces directly connected to network segments of hosts.

    # Configure SwitchB.

    [~SwitchB] interface vlanif 10
    [~SwitchB-Vlanif10] igmp enable
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit
    

    # Configure SwitchC.

    [~SwitchC] interface vlanif 20
    [~SwitchC-Vlanif20] igmp enable
    [*SwitchC-Vlanif20] commit
    [~SwitchC-Vlanif20] quit
    

  5. Configure the dynamic RP function.

    # Configure different C-RP interfaces to serve Bidir-PIM and PIM-SM on SwitchA.

    [~SwitchA] acl number 2000
    [*SwitchA-acl4-basic-2000] rule permit source 225.1.1.0 0.0.0.255
    [*SwitchA-acl4-basic-2000] quit
    [*SwitchA] acl number 2001
    [*SwitchA-acl4-basic-2001] rule permit source 226.1.1.0 0.0.0.255
    [*SwitchA-acl4-basic-2001] quit
    [*SwitchA] pim
    [*SwitchA-pim] c-bsr vlanif30
    [*SwitchA-pim] c-rp loopback0 group-policy 2000 bidir
    [*SwitchA-pim] c-rp vlanif30 group-policy 2001
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit
    

  6. Verify the configuration.

    # Run the display pim routing-table command to view the PIM routing table on each switch. You can see from the routing tables that multicast source 10.110.3.100/24 sends data to multicast groups 225.1.1.1/24 and 226.1.1.1/24, HostA joined group 225.1.1.1/24, and HostB joined group 226.1.1.1/24. For example, the PIM routing tables on SwitchA and SwitchB are as follows:

    [~SwitchA] display pim routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 1 (S, G) entry
    
     (*, 226.1.1.1)
         RP: 10.110.3.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 03:05:41
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 03:05:41, Expires: 00:02:50
    
     (10.110.3.100, 226.1.1.1)
         RP: 10.110.3.1 (local)
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:06:27
         Upstream interface: Vlanif30
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:06:27, Expires: 00:03:04
    
     (*, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 03:00:42
         Rpf interface: LoopBack0
             Upstream neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif100
                 Protocol: bidir-pim, UpTime: 03:00:42, Expires: 00:02:48
            2: LoopBack0(RPF)
                 Protocol: bidir-pim, UpTime: 03:00:42, Expires: -
    [~SwitchB] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:01:08
         Rpf interface: Vlanif100
             Upstream neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: igmp, UpTime: 00:01:07, Expires: -
            2: Vlanif100(RPF)
                 Protocol: bidir-pim, UpTime: 00:01:08, Expires: - 

    According to the command output, HostA can receive data for group 225.1.1.1 through Bidir-PIM, and HostB can receive data for group 226.1.1.1 through PIM-SM.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 30 100 200
    #
    router id 10.1.1.1
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 225.1.1.0 0.0.0.255
    #
    acl number 2001
     rule 5 permit source 226.1.1.0 0.0.0.255
    #
    interface Vlanif30
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif100
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr Vlanif30
     bidir-pim
     c-rp Vlanif30 group-policy 2001 
     c-rp LoopBack0 group-policy 2000 bidir
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 100
    #
    router id 10.2.2.2
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif100
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 200
    #
    router id 10.3.3.3
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif200
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 46430

Downloads: 13

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next