No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an IGMP Snooping Querier

Example for Configuring an IGMP Snooping Querier

Networking Requirements

As shown in Figure 10-9, on a pure Layer 2 network, multicast sources Source1 and Source2 send multicast data to multicast groups 224.1.1.1 and 225.1.1.1. HostA and HostC join multicast group 224.1.1.1, while HostB and HostD join multicast group 225.1.1.1. All the hosts run IGMPv2. Multicast data is expected to be transmitted on the Layer 2 network through IGMP snooping.

Figure 10-9 Networking diagram for IGMP snooping querier configuration

Configuration Roadmap

To meet the preceding requirements, enable IGMP snooping on the four Switches and configure an IGMP snooping querier. Enable all the Switches to discard unknown multicast packets to prevent the Switches from broadcasting multicast data in the VLAN when there are no Layer 2 multicast forwarding entries on the Switches. The configuration roadmap is as follows:

  1. On all the Switches, create a VLAN and add interfaces to the VLAN according to Figure 10-9.
  2. Enable IGMP snooping globally and in the VLAN on all the Switches.
  3. Configure SwitchA as an IGMP snooping querier.
  4. Enable all the Switches to discard unknown multicast packets.

Procedure

  1. On all the Switches, create a VLAN and add interfaces to the VLAN.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 2/0/2
    [*SwitchA-10GE2/0/2] port link-type trunk
    [*SwitchA-10GE2/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE2/0/2] quit
    [*SwitchA] interface 10ge 3/0/3
    [*SwitchA-10GE3/0/3] port default vlan 10
    [*SwitchA-10GE3/0/3] commit
    [~SwitchA-10GE3/0/3] quit

    # The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

  2. Enable IGMP snooping globally and in the VLAN on all the Switches.

    # Configure SwitchA.

    [~SwitchA] igmp snooping enable
    [*SwitchA] vlan 10
    [*SwitchA-vlan10] igmp snooping enable
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

    # The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

  3. Configure SwitchA as an IGMP snooping querier.

    [~SwitchA] vlan 10
    [~SwitchA-vlan10] igmp snooping querier enable
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

  4. Enable all the Switches to discard unknown multicast packets.

    # Configure SwitchA.

    [~SwitchA] vlan 10
    [~SwitchA-vlan10] multicast drop-unknown
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit
    

    # The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

  5. Verify the configuration.

    # When the IGMP snooping querier begins to work, all the Switches except the IGMP snooping querier receive IGMP General Query messages. Run the display igmp snooping statistics vlan 10 command on SwitchB to view IGMP message statistics. The command output is as follows:

    [~SwitchB] display igmp snooping statistics vlan 10
     IGMP Snooping Packets Counter:                                                  
       Statistics for VLAN 10                                                       
         Receive V1 Report:          0                                                  
         Receive V2 Report:          32                                                 
         Receive V3 Report:          0                                                  
         Receive V1 Query:           0                                                  
         Receive V2 Query:         30                              
         Receive V3 Query:           0                                                  
         Receive Leave:              0                                                  
         Receive Pim Hello:          0                                                  
         Send Query (S=0):           0                                                  
         Send Query (S!=0):          -                                                  
         Proxy Send General Query:                0                                   
         Proxy Send Group-Specific Query:         0                                   
         Proxy Send Group-Source-Specific Query:  0                                   
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     igmp snooping querier enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE3/0/3
     port default vlan 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE3/0/3
     port default vlan 10
    #
    interface 10GE4/0/4
     port default vlan 10
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE3/0/3
     port default vlan 10
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 37374

Downloads: 13

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next