No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast VPN Extranet in Local Crossing Scenario (VPN Instances of the Receiver and Source on the Same PE)

Example for Configuring Multicast VPN Extranet in Local Crossing Scenario (VPN Instances of the Receiver and Source on the Same PE)

Networking Requirements

As shown in Figure 7-20, PE2 is a device on the carrier's backbone network. CE1 and CE2 belong to VPN instances vpna and vpnb, respectively. The receiver in vpnb wants to receive the multicast data sent from the source in vpna.

Figure 7-20 Networking diagram for multicast VPN extranet configuration in local crossing scenario (VPN instances of the receiver and source on the same PE)

Configuration Roadmap

The multicast VPN extranet function for the local crossing scenario (VPN instances of the receiver and source on the same PE) can be configured to meet the service requirement. The configuration roadmap is as follows:

  1. Configure the carrier's backbone network and the VPN networks to ensure normal running of the unicast routing protocol.
  2. Enable multicast routing on the entire network, and configure multicast in VPN instances on the PE and CE devices. In this scenario, you need to configure a private network RP to serve the multicast VPN extranet group. It must be a static RP.

Procedure

  1. Configure the carrier's backbone network and the VPN networks.
    1. Configure VPN instances on PE2 to enable the CE devices to access PE2.

      # Configure PE2.

      Configure VPN instances vpna and vpnb on PE2.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE2
      [*HUAWEI] commit
      [~PE2] ip vpn-instance vpnb
      [*PE2-vpn-instance-vpnb] ipv4-family
      [*PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 200:1
      [*PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:1 both
      [*PE2-vpn-instance-vpnb-af-ipv4] vpn-target 111:1 import-extcommunity
      [*PE2-vpn-instance-vpnb-af-ipv4] quit
      [*PE2-vpn-instance-vpnb] quit
      [*PE2] ip vpn-instance vpna
      [*PE2-vpn-instance-vpna] ipv4-family
      [*PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
      [*PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
      [*PE2-vpn-instance-vpna-af-ipv4] quit
      [*PE2-vpn-instance-vpna] quit
      [*PE2] vlan batch 11
      [*PE2] interface 10ge 3/0/1
      [*PE2-10GE3/0/1] port link-type trunk
      [*PE2-10GE3/0/1] port trunk allow-pass vlan 11
      [*PE2-10GE3/0/1] quit
      [*PE2] interface vlanif 11
      [*PE2-Vlanif11] ip binding vpn-instance vpna 
      [*PE2-Vlanif11] ip address 10.1.1.1 24
      [*PE2-Vlanif11] quit
      [*PE2] vlan batch 22
      [*PE2] interface 10ge 1/0/1
      [*PE2-10GE1/0/1] port link-type trunk
      [*PE2-10GE1/0/1] port trunk allow-pass vlan 22
      [*PE2-10GE1/0/1] quit
      [*PE2] interface vlanif 22
      [*PE2-Vlanif22] ip binding vpn-instance vpnb 
      [*PE2-Vlanif22] ip address 10.1.2.1 24
      [*PE2-Vlanif22] quit
      [*PE2] commit
      

      # Assign IP addresses to interfaces on PE2 and CE devices according to Figure 7-20. The configuration procedure is not provided here. See Configuration Files.

      After the configuration is complete, PE2 can successfully ping the CE devices attached to it using the ping -vpn-instance command.

    2. Configure a routing protocol between PE2 and the CE devices to import the VPN routes.

      This example uses the OSPF protocol to advertise routes between PE2 and the CE devices.

      # Configure PE2.

      [~PE2] ospf 3 vpn-instance vpna
      [*PE2-ospf-3] area 0
      [*PE2-ospf-3-area-0.0.0.0] network 10.1.1.0 0.0.0.255
      [*PE2-ospf-3-area-0.0.0.0] quit
      [*PE2-ospf-3] quit
      [*PE2] ospf 2 vpn-instance vpnb
      [*PE2-ospf-2] import-route bgp
      [*PE2-ospf-2] area 0
      [*PE2-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*PE2-ospf-2-area-0.0.0.0] quit
      [*PE2-ospf-2] quit
      [*PE2] bgp 100
      [*PE2-bgp] ipv4-family vpn-instance vpnb
      [*PE2-bgp-vpnb] quit
      [*PE2-bgp] ipv4-family vpn-instance vpna
      [*PE2-bgp-vpna] import-route ospf 3
      [*PE2-bgp-vpna] quit
      [*PE2-bgp] quit
      [*PE2] commit
      

      # Configure CE1.

      [~CE1] ospf 3
      [*CE1-ospf-3] area 0
      [*CE1-ospf-3-area-0.0.0.0] network 10.1.1.0 0.0.0.255
      [*CE1-ospf-3-area-0.0.0.0] network 10.138.1.0 0.0.0.255
      [*CE1-ospf-3-area-0.0.0.0] quit
      [*CE1-ospf-3] quit
      [*CE1] commit
      

      # Configure CE2.

      [~CE2] ospf 2
      [*CE2-ospf-2] area 0
      [*CE2-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] network 10.138.2.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] quit
      [*CE2-ospf-2] quit
      [*CE2] commit

  2. Configure the multicast function on the private network.

    NOTE:

    The source and receiver VPN instances support only static RP configuration, and the static RP address must belong to the source VPN instance.

    # Configure PE2.

    [~PE2] ip vpn-instance vpnb
    [~PE2-vpn-instance-vpnb] ipv4-family
    [~PE2-vpn-instance-vpnb-af-ipv4] multicast routing-enable
    [*PE2-vpn-instance-vpnb-af-ipv4] quit
    [*PE2-vpn-instance-vpnb] quit
    [*PE2] ip vpn-instance vpna
    [*PE2-vpn-instance-vpna] ipv4-family
    [*PE2-vpn-instance-vpna-af-ipv4] multicast routing-enable
    [*PE2-vpn-instance-vpna-af-ipv4] quit
    [*PE2-vpn-instance-vpna] quit
    [*PE2] interface vlanif 22
    [*PE2-Vlanif22] pim sm
    [*PE2-Vlanif22] quit
    [*PE2] interface vlanif 11
    [*PE2-Vlanif11] pim sm
    [*PE2-Vlanif11] quit
    [*PE2] pim vpn-instance vpnb
    [*PE2-pim-vpnb] static-rp 4.4.4.4
    [*PE2-pim-vpnb] quit
    [*PE2] pim vpn-instance vpna
    [*PE2-pim-vpna] static-rp 4.4.4.4
    [*PE2-pim-vpna] quit
    [*PE2] commit

    # Configure CE1.

    [~CE1] multicast routing-enable
    [*CE1] interface loopback 0
    [*CE1-LoopBack0] pim sm
    [*CE1-LoopBack0] quit
    [*CE1] interface vlanif 10
    [*CE1-Vlanif10] pim sm
    [*CE1-Vlanif10] quit
    [*CE1] interface vlanif 11
    [*CE1-Vlanif11] pim sm
    [*CE1-Vlanif11] quit
    [*CE1] pim
    [*CE1-pim] static-rp 4.4.4.4
    [*CE1-pim] quit
    [*CE1] commit

    # Configure CE2.

    [~CE2] multicast routing-enable
    [*CE2] interface vlanif 22
    [*CE2-Vlanif22] pim sm
    [*CE2-Vlanif22] quit
    [*CE2] interface vlanif 20
    [*CE2-Vlanif20] pim sm
    [*CE2-Vlanif20] igmp enable
    [*CE2-Vlanif20] quit
    [*CE2] pim
    [*CE2-pim] static-rp 4.4.4.4
    [*CE2] commit

  3. Verify the configuration.

    Check the PIM routing table on PE2. The following command output shows that vpna is the RPF upstream interface in the PIM routing entry for group 225.1.1.1, and vpnb is the receiver of the multicast extranet group in vpna.

    [~PE2] display pim vpn-instance vpnb routing-table extranet source-vpn-instance vpna
     VPN-Instance: vpnb
     Total 1 (*, G) entry; 1 (S, G) entry 
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:00:20
         Upstream interface: MCAST_Extranet(vpna)
             Upstream neighbor: 10.1.1.2
             RPF prime neighbor: 10.1.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif22
                 Protocol: pim-sm, UpTime: 00:00:20, Expires: 00:03:10
     
     (10.138.1.1, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:00:20
         Upstream interface: MCAST_Extranet(vpna)
             Upstream neighbor: 10.1.1.2
             RPF prime neighbor: 10.1.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif22
                 Protocol: pim-sm, UpTime: 00:00:21, Expires: -
    [~PE2] display pim vpn-instance vpna routing-table extranet receive-vpn-instance vpnb
     VPN-Instance: vpna
     Total 1 (*, G) entry; 1 (S, G) entry 
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC EXTRANET 
         UpTime: 00:01:36
         Upstream interface: Vlanif11
             Upstream neighbor: 10.1.1.2
             RPF prime neighbor: 10.1.1.2
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: vpnb
     
     (10.138.1.1, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT EXTRANET 
         UpTime: 00:01:36
         Upstream interface: Vlanif11
             Upstream neighbor: 10.1.1.2
             RPF prime neighbor: 10.1.1.2
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: vpnb

Configuration Files

  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 11 22
    #
    router id 2.2.2.2
    # 
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      vpn-target 111:1 import-extcommunity  
      multicast routing-enable
    #
    interface Vlanif11 
     ip binding vpn-instance vpna
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif22
     ip binding vpn-instance vpnb
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 22
    #
    interface 10GE3/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 100
     #
     ipv4-family unicast
     #
     ipv4-family vpnv4
      policy vpn-target
     #
     ipv4-family vpn-instance vpna
       import-route ospf 3
     #
     ipv4-family vpn-instance vpnb
    #
    ospf 2 vpn-instance vpnb
     import-route bgp
     area 0.0.0.0 
      network 10.1.2.0 0.0.0.255
    #
    ospf 3 vpn-instance vpna
     area 0.0.0.0 
      network 10.1.1.0 0.0.0.255
    #
    pim vpn-instance vpna
     static-rp 4.4.4.4
    #
    pim vpn-instance vpnb
     static-rp 4.4.4.4
    #
    return
  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 10 to 11
    # 
    multicast routing-enable
    #
    interface Vlanif10 
     ip address 10.138.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif11
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE2/0/2
     port default vlan 10
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #
    ospf 3 
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255 
      network 10.138.1.0 0.0.0.255 
    #
    pim
     static-rp 4.4.4.4 
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 20 22
    # 
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.138.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif22
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 22
    #
    interface 10GE2/0/2
     port default vlan 20
    #
    ospf 2 
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255 
      network 10.138.2.0 0.0.0.255 
    #
    pim
     static-rp 4.4.4.4 
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 38682

Downloads: 13

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next