No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 FRR on the Public Network

Example for Configuring IPv4 FRR on the Public Network

Networking Requirements

As shown in Figure 1-10, OSPF is configured on SwitchT, SwitchA, and SwitchC, and IS-IS is configured on SwitchT, SwitchB, and SwitchC. The default priority of OSPF routes is higher than that of IS-IS routes. Therefore, the backup outbound interface and backup next hop can be configured on SwitchT to ensure that Link B functions as a backup of Link A. Traffic must be rapidly switched from link A to link B when a fault occurs on link A.

Figure 1-10 Networking diagram of configuring IPv4 FRR on the public network



Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure basic OSPF functions on SwitchT, SwitchA and SwitchC.
  2. Configure basic IS-IS functions on SwitchT, SwitchB and SwitchC.
  3. Check routing information on SwitchT.
  4. Enable public network IPv4 FRR on SwitchT, and check the backup outbound interface and backup next hop.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchT
    [*HUAWEI] commit
    [~SwitchT] vlan batch 10 20 30
    [*SwitchT] interface 10ge 1/0/1
    [*SwitchT-10GE1/0/1] port link-type trunk 
    [*SwitchT-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchT-10GE1/0/1] quit
    [*SwitchT] interface 10ge 1/0/2
    [*SwitchT-10GE1/0/2] port link-type trunk 
    [*SwitchT-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchT-10GE1/0/2] quit
    [*SwitchT] interface 10ge 1/0/3
    [*SwitchT-10GE1/0/3] port link-type trunk 
    [*SwitchT-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchT-10GE1/0/3] quit
    [*SwitchT] commit

    The configurations of SwitchA, SwitchB, and SwitchC are similar to the configuration of SwitchT, and are not provided here.

  2. Assign IPv4 addresses to VLANIF interfaces.

    [~SwitchT] interface vlanif 10
    [*SwitchT-Vlanif10] ip address 172.16.1.1 24
    [*SwitchT-Vlanif10] quit
    [*SwitchT] interface vlanif 20
    [*SwitchT-Vlanif20] ip address 1.1.2.1 24
    [*SwitchT-Vlanif20] quit
    [*SwitchT] interface vlanif 30
    [*SwitchT-Vlanif30] ip address 1.1.3.1 24
    [*SwitchT-Vlanif30] quit
    [*SwitchT] commit

    The configurations of SwitchA, SwitchB, and SwitchC are similar to the configuration of SwitchT, and are not provided here.

  3. Configure OSPF on SwitchT, SwitchA, and SwitchC.

    # Configure SwitchT.

    [~SwitchT] ospf
    [*SwitchT-ospf-1] area 0
    [*SwitchT-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [*SwitchT-ospf-1-area-0.0.0.0] network 1.1.2.0 0.0.0.255
    [*SwitchT-ospf-1-area-0.0.0.0] commit
    [~SwitchT-ospf-1-area-0.0.0.0] quit
    [~SwitchT-ospf-1] quit

    # Configure SwitchA.

    [~SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 1.1.2.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 1.1.4.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

    # Configure SwitchC.

    [~SwitchC] ospf
    [*SwitchC-ospf-1] area 0
    [*SwitchC-ospf-1-area-0.0.0.0] network 172.17.1.0 0.0.0.255
    [*SwitchC-ospf-1-area-0.0.0.0] network 1.1.4.0 0.0.0.255
    [*SwitchC-ospf-1-area-0.0.0.0] commit
    [~SwitchC-ospf-1-area-0.0.0.0] quit
    [~SwitchC-ospf-1] quit

  4. Configure IS-IS on SwitchT, SwitchB, and SwitchC.

    # Configure SwitchT.

    [~SwitchT] isis
    [*SwitchT-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchT-isis-1] quit
    [*SwitchT] interface vlanif 10
    [*SwitchT-Vlanif10] isis enable 1
    [*SwitchT-Vlanif10] quit
    [*SwitchT] interface vlanif 30
    [*SwitchT-Vlanif30] isis enable 1
    [*SwitchT-Vlanif30] commit
    [~SwitchT-Vlanif30] return

    # Configure SwitchB.

    [~SwitchB] isis
    [*SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [*SwitchB-isis-1] quit
    [*SwitchB] interface vlanif 30
    [*SwitchB-Vlanif30] isis enable 1
    [*SwitchB-Vlanif30] quit
    [*SwitchB] interface vlanif 50
    [*SwitchB-Vlanif50] isis enable 1
    [*SwitchB-Vlanif50] commit
    [~SwitchB-Vlanif50] quit

    # Configure SwitchC.

    [~SwitchC] isis
    [*SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [*SwitchC-isis-1] quit
    [*SwitchC] interface vlanif 50
    [*SwitchC-Vlanif50] isis enable 1
    [*SwitchC-Vlanif50] quit
    [*SwitchC] interface vlanif 60
    [*SwitchC-Vlanif60] isis enable 1
    [*SwitchC-Vlanif60] commit
    [~SwitchC-Vlanif60] quit

  5. Check routing information.

    # Check the routes to destination 172.17.1.0 on SwitchT.

    <SwitchT> display ip routing-table 172.17.1.0 verbose
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 2 
    
    Destination: 172.17.1.0/24
         Protocol: OSPF             Process ID: 1
      Preference: 10                      Cost: 3
          NextHop: 1.1.2.2           Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h10m25s
               Tag: 0                   Priority: medium
             Label: NULL                 QoSInfo: 0x0
        IndirectID: 0xEF0000A2           Instance: 
      RelayNextHop: 0.0.0.0            Interface: Vlanif20
          TunnelID: 0x0                     Flags: D
    
       Destination: 172.17.1.0/24
        Protocol: ISIS-L1           Process ID: 1
      Preference: 15                      Cost: 30
         NextHop: 1.1.3.2            Neighbour: 0.0.0.0
            State: Inactive Adv           Age: 00h09m05s
               Tag: 0                   Priority: medium
             Label: NULL                 QoSInfo: 0x0
        IndirectID: 0xEF000117
      RelayNextHop: 0.0.0.0           Interface: Vlanif30
          TunnelID: 0x0                     Flags: 

    The routing table contains two routes to 172.17.1.0/24. The default priority of OSPF routes is higher than that of IS-IS routes. Therefore, the route with next hop 1.1.2.2 is the optimal route.

  6. Enable IPv4 FRR on the public network.

    # Enable IPv4 FRR on the public network on SwitchT.

    <SwitchT> system-view
    [~SwitchT] ip frr
    [*SwitchT] commit

    # Check information about the backup outbound interface and backup next hop on SwitchT.

    [SwitchT] display ip routing-table 172.17.1.0 verbose
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 2 
    
    Destination: 172.17.1.0/24
          Protocol: OSPF            Process ID: 1
        Preference: 10                    Cost: 3
           NextHop: 1.1.2.2          Neighbour: 0.0.0.0
             State: Active Adv             Age: 00h11m39s
               Tag: 0                 Priority: medium
             Label: NULL               QoSInfo: 0x0
        IndirectID: 0xEF0000A2         Instance: 
      RelayNextHop: 0.0.0.0          Interface: Vlanif20
          TunnelID: 0x0                  Flags: D
       BkNextHop: 1.1.3.2     BkInterface: Vlanif30
           BkLabel: NULL           SecTunnelID: 0x0
      BkPETunnelID: 0x0        BkPESecTunnelID: 0x0
      BkIndirectID: 0xEF000117
    
       Destination: 172.17.1.0/24
          Protocol: ISIS-L1         Process ID: 1
        Preference: 15                    Cost: 30
           NextHop: 1.1.3.2          Neighbour: 0.0.0.0
             State: Inactive Adv           Age: 00h10m19s
               Tag: 0                 Priority: medium
             Label: NULL               QoSInfo: 0x0
        IndirectID: 0xEF000117
      RelayNextHop: 0.0.0.0          Interface: Vlanif30
          TunnelID: 0x0                  Flags: 

    The routing table contains the backup outbound interface and backup next hop of the route to 172.17.1.0/24. The IS-IS route becomes the backup route.

Configuration Files

  • Configuration file of SwitchT

    #
    sysname SwitchT
    #
    vlan batch 10 20 30
    #
    ip frr
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0 
     isis enable 1
    #
    interface Vlanif20
     ip address 1.1.2.1 255.255.255.0
    #
    interface Vlanif30
     ip address 1.1.3.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1 
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3 
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 1.1.2.0 0.0.0.255
    #
    return
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 20 40
    #
    interface Vlanif20
     ip address 1.1.2.2 255.255.255.0
    #
    interface Vlanif40
     ip address 1.1.4.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 1.1.2.0 0.0.0.255
      network 1.1.4.0 0.0.0.255
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 30 50
    #
    isis 1
     network-entity 10.0000.0000.0002.00 
    #
    interface Vlanif30
     ip address 1.1.3.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 1.1.5.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 40 50 60
    #
    isis 1
     network-entity 10.0000.0000.0003.00 
    #
    interface Vlanif40
     ip address 1.1.4.1 255.255.255.0
    #
    interface Vlanif50
     ip address 1.1.5.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif60
     ip address 172.17.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 172.17.1.0 0.0.0.255
      network 1.1.4.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074760

Views: 44297

Downloads: 58

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next