No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Static BFD for IS-IS

Example for Configuring Static BFD for IS-IS

Networking Requirements

As shown in Figure 7-30, three routers are interconnected using IS-IS, and RouterA and RouterB communicate with each other through a Layer 2 switch. When a link between RouterA and RouterB fails, the two routers can respond to the fault rapidly.

Figure 7-30 Networking diagram of configuring static BFD for IS-IS

NOTE:

BFD for IS-IS cannot be used to detect the multi-hop link between RouterA and RouterC, because the IS-IS neighbor relationship cannot be established between RouterA and RouterC.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and enable IS-IS on each router to ensure reachable routes between the routers.

  2. Enable static BFD for IS-IS on RouterA and RouterB so that routers can rapidly detect link faults.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not provided here.

  2. Assign IP addresses for VLANIF interfaces.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 172.16.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] commit

    The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not provided here.

  3. Configure basic IS-IS functions.

    # Configure SwitchA.

    [~SwitchA] isis 1
    [*SwitchA-isis-1] is-level level-2
    [*SwitchA-isis-1] network-entity aa.1111.1111.1111.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis enable 1
    [*SwitchA-Vlanif10] quit
    [*SwitchA] commit

    # Configure SwitchB.

    [~SwitchB] isis 1
    [*SwitchB-isis-1] is-level level-2
    [*SwitchB-isis-1] network-entity aa.2222.2222.2222.00
    [*SwitchB-isis-1] quit
    [*SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] isis enable 1
    [*SwitchB-Vlanif10] quit
    [*SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] isis enable 1
    [*SwitchB-Vlanif20] quit
    [*SwitchB] commit

    # Configure SwitchC.

    [~SwitchC] isis 1
    [*SwitchC-isis-1] is-level level-2
    [*SwitchC-isis-1] network-entity aa.3333.3333.3333.00
    [*SwitchC-isis-1] quit
    [*SwitchC] interface vlanif 20
    [*SwitchC-Vlanif20] isis enable 1
    [*SwitchC-Vlanif20] quit
    [*SwitchC] commit

    # After the preceding configurations, you can see that the neighbor relationship is established between SwitchA and SwitchB.

    [~SwitchA] display isis peer
                              Peer information for ISIS(1)
                              ----------------------------
      System Id    Interface         Circuit Id       State HoldTime Type     PRI
    2222.2222.2222 Vlanif10           0000000001        Up   23s      L2       64

    The IS-IS routing table of SwitchA contains the routes to SwitchB and SwitchC.

    [~SwitchA] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-2 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination    IntCost   ExtCost ExitInterface   NextHop        Flags
    -------------------------------------------------------------------------
     172.16.1.0/24       10        NULL    Vlanif10         Direct       D/-/L/-
     172.16.2.0/24       20        NULL    Vlanif10         172.16.1.2   A/-/L/-

  4. Configure BFD.

    # Enable BFD on SwitchA and configure a BFD session.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] bfd atob bind peer-ip 172.16.1.2 interface vlanif 10
    [*SwitchA-bfd-session-atob] discriminator local 1
    [*SwitchA-bfd-session-atob] discriminator remote 2
    [*SwitchA-bfd-session-atob] commit
    [*SwitchA-bfd-session-atob] quit
    [*SwitchA] commit

    # Enable BFD on SwitchA and configure a BFD session.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit
    [*SwitchB] bfd btoa bind peer-ip 172.16.1.1 interface vlanif 10
    [*SwitchB-bfd-session-btoa] discriminator local 2
    [*SwitchB-bfd-session-btoa] discriminator remote 1
    [*SwitchB-bfd-session-btoa] quit
    [*SwitchB] commit

    After the preceding configurations, run the display bfd session command on SwitchA or SwitchB, and you can see that the status of the BFD session is Up.

    The following uses the display on SwitchA as an example.

    [~SwitchA] display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    AUTO: Automatically negotiated session
    Total UP/DOWN Session Number : 1/0
    ------------------------------------------------------------------------
    Local Remote PeerIpAddr      State     Type        InterfaceName
    ------------------------------------------------------------------------
    1     2      172.16.1.2       Up      S/IP-IF      Vlanif10          
    ------------------------------------------------------------------------

  5. Enable IS-IS fast detect.

    # Configure SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis bfd static
    [*SwitchA-Vlanif10] quit
    [*SwitchA] return

    # Configure SwitchB.

    [~SwitchB] interface Vlanif 10
    [*SwitchB-Vlanif10] isis bfd static
    [*SwitchB-Vlanif10] quit
    [*SwitchB] commit

  6. Verify the configuration.

    # Enable debugging on SwitchA.

    <SwitchA> debugging isis adjacency
    <SwitchA> debugging isis circuit-information
    <SwitchA> terminal debugging

    # Run the shutdown command on 10GE1/0/1 of SwitchB to simulate a link fault.

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] shutdown
    [*SwitchB-10GE1/0/1] commit

    # On SwitchA, you can view the following log information, which indicates that IS-IS deletes the neighbor relationship with SwitchB after being notified by BFD of the fault.

    #80/active/IsisAdjacencyChange/Major/occurredTime:2011-03-09 04:17:07/-/-/alarmI
    D:0x0001009e/CID=0x80e703ff:ISIS adjacency state change. (SysInstance=1, SysLevel=1, CircI
    ndex=2, CircIfIndex=20, LspId=2222.2222.2222.00.00, AdjState=1, IfIndex=20, IfNa
    me=Vlanif10, Reason=BFD detected that the neighbor went Down, SubReason=14)

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    bfd
    #
    isis 1
     is-level level-2
     network-entity aa.1111.1111.1111.00
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
     isis bfd static
    #
    bfd atob bind peer-ip 172.16.1.2 interface Vlanif10
     discriminator local 1
     discriminator remote 2
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    bfd
    #
    isis 1
     is-level level-2
     network-entity aa.2222.2222.2222.00
    #
    interface Vlanif10
     ip address 172.16.1.2 255.255.255.0
     isis enable 1
     isis bfd static
    #
    interface Vlanif20
     ip address 172.16.2.1 255.255.255.0
     isis enable 1
    #
    bfd btoa bind peer-ip 172.16.1.1 interface Vlanif10
     discriminator local 2
     discriminator remote 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    isis 1
     is-level level-2
     network-entity aa.3333.3333.3333.00
    #
    interface Vlanif20
     ip address 172.16.2.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074760

Views: 58382

Downloads: 63

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next