No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IS-IS Functions

Example for Configuring Basic IS-IS Functions

Networking Requirements

As shown in Figure 7-26, there are four devices (SwitchA, SwitchB, SwitchC, and SwitchD) on the network. The four devices need to communicate with each other. SwitchA and SwitchB can only process a small amount of data because they have lower performance than the other two devices.

Figure 7-26 Networking diagram of configuring basic IS-IS functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IS-IS on each device so that the devices can be interconnected. Configure SwitchA and SwitchB as Level-1 devices to enable them to maintain less data.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not provided here.

  2. Assign the IP addresses for VLANIF interfaces.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.1.1.2 24
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

    The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not provided here.

  3. Configure basic IS-IS functions.

    # Configure SwitchA.

    [~SwitchA] isis 1
    [*SwitchA-isis-1] is-level level-1
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis enable 1
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [~SwitchB] isis 1
    [*SwitchB-isis-1] is-level level-1
    [*SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [*SwitchB-isis-1] quit
    [*SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] isis enable 1
    [*SwitchA-Vlanif20] commit
    [~SwitchB-Vlanif20] quit

    # Configure SwitchC.

    [~SwitchC] isis 1
    [*SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [*SwitchC-isis-1] quit
    [*SwitchC] interface vlanif 10
    [*SwitchC-Vlanif10] isis enable 1
    [*SwitchC-Vlanif10] quit
    [*SwitchC] interface vlanif 20
    [*SwitchC-Vlanif20] isis enable 1
    [*SwitchC-Vlanif20] quit
    [*SwitchC] interface vlanif 30
    [*SwitchC-Vlanif30] isis enable 1
    [*SwitchC-Vlanif30] commit
    [~SwitchC-Vlanif30] quit

    # Configure SwitchD.

    [~SwitchD] isis 1
    [*SwitchD-isis-1] is-level level-2
    [*SwitchD-isis-1] network-entity 20.0000.0000.0004.00
    [*SwitchD-isis-1] quit
    [*SwitchD] interface vlanif 30
    [*SwitchD-Vlanif30] isis enable 1
    [*SwitchD-Vlanif30] quit
    [*SwitchD] interface vlanif 40
    [*SwitchD-Vlanif40] isis enable 1
    [*SwitchD-Vlanif40] commit
    [~SwitchD-Vlanif40] quit

  4. Verify the configuration.

    # View the IS-IS LSDB information of each switch.

    [~SwitchA] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-1 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00* 0x00000006   0xbf7d        649           68      0/0/0
    0000.0000.0002.00-00  0x00000003   0xef4d        545           68      0/0/0
    0000.0000.0003.00-00  0x00000008   0x3340        582           111     1/0/0
     
    
    Total LSP(s): 3 
    [~SwitchB] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-1 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000006   0xbf7d        642           68      0/0/0
    0000.0000.0002.00-00* 0x00000003   0xef4d        538           68      0/0/0
    0000.0000.0003.00-00  0x00000008   0x3340        574           111     1/0/0
     
    
    Total LSP(s): 3 
    [~SwitchC] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-1 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000006   0xbf7d        638           68      0/0/0
    0000.0000.0002.00-00  0x00000003   0xef4d        533           68      0/0/0
    0000.0000.0003.00-00* 0x00000008   0x3340        569           111     1/0/0
     
    
    Total LSP(s): 3 
                                                                                    
                                                                                    
                                                                                    
    Level-2 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
                              Level-2 Link State Database
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00* 0x00000008   0x55bb        650           100     0/0/0
    0000.0000.0004.00-00  0x00000005   0x651         629           84      0/0/0
     
    
    Total LSP(s): 2 
    [~SwitchD] display isis lsdb
                                                                                    
    Database Information for ISIS(1)                                                
    --------------------------------------------------------------------------------
                                                                                    
    Level-2 Link State Database                                                     
                                                                                    
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),            
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
    
    LSPID                 Seq Num      Checksum      HoldTime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00  0x00000008   0x55bb        644           100     0/0/0
    0000.0000.0004.00-00* 0x00000005   0x651         624           84      0/0/0
     
    
    Total LSP(s): 2 

    # View the IS-IS routing information of each switch. The routing table of a Level-1 device contains a default route with the next hop as a Level-1-2 device. The routing table of a Level-2 device contains all Level-1 and Level-2 routes.

    [~SwitchA] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    --------------------------------------------------------------------------
     0.0.0.0/0          10        NULL    Vlanif10        10.1.1.1        A/-/-/-
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-
     10.1.2.0/24        20        NULL    Vlanif10        10.1.1.1        A/-/-/-
     192.168.0.0/24     20        NULL    Vlanif10        10.1.1.1        A/-/-/-
    [~SwitchC] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-
     10.1.2.0/24        10        NULL    -               Direct          D/-/L/-
     192.168.0.0/24     10        NULL    -               Direct          D/-/L/-
                                                                                    
                                                                                    
    ISIS(1) Level-2 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-
     10.1.2.0/24        10        NULL    -               Direct          D/-/L/-
     172.16.0.0/16      20        NULL    Vlanif30        192.168.0.2     A/-/-/-
     192.168.0.0/24     10        NULL    -               Direct          D/-/L/-
    
    
    [~SwitchD] display isis route
                                                                                    
    Route Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
    Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,          
                                   U-Up/Down Bit Set                                
                                                                                    
    ISIS(1) Level-1 Forwarding Table                                                
    --------------------------------------------------------------------------------
                                                                                    
    
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop          Flags
    --------------------------------------------------------------------------
     10.1.1.0/24        20        NULL    Vlanif30          192.168.0.1      A/-/-/-
     10.1.2.0/24        20        NULL    Vlanif30          192.168.0.1      A/-/-/-
     172.16.0.0/16      10        NULL    -                 Direct           D/-/L/-
     192.168.0.0/24     10        NULL    -                 Direct           D/-/L/-

Configuration Files

  • Configuration file of SwitchA
    #
    sysname SwitchA
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of SwitchB
    #
    sysname SwitchB
    #
    vlan batch 20
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of SwitchC
    #
    sysname SwitchC
    #
    vlan batch 10 20 30
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 192.168.0.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • Configuration file of SwitchD
    #
    sysname SwitchD
    #
    vlan batch 30 40
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0004.00
    #
    interface Vlanif30
     ip address 192.168.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074760

Views: 50749

Downloads: 60

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next