No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a BGP4+ Route Reflection

Example for Configuring a BGP4+ Route Reflection

Networking Requirements

As shown in Figure 9-24, four devices belong to two ASs. You are required to perform simplified configuration to ensure that the two ASs communicate with each other.

Figure 9-24 Networking diagram of configuring the BGP4+ route reflectors

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic BGP4+ functions to allow BGP neighbors to communicate.

  2. Configure SwitchC as a route reflector so that no IBGP connection needs to be established between SwitchB and SwitchD. This simplifies the configuration.

Procedure

  1. Add interfaces to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA]interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit

    The configurations of SwitchB, SwitchC, SwitchD are similar to the configuration of SwitchA, and are not provided here.

  2. Enable the IPv6 forwarding capability, and assign an IPv6 address for each interface. The following is the configuration of SwitchA. The configurations of other Switches are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1/64
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:100::1/64
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  3. Configure the basic BGP4+ functions.

    # Configure SwitchA.

    [~SwitchA] bgp 100
    [*SwitchA-bgp] router-id 172.16.1.1
    [*SwitchA-bgp] peer fc00:0:0:100::2 as-number 200
    [*SwitchA-bgp] ipv6-family unicast
    [*SwitchA-bgp-af-ipv6] peer fc00:0:0:100::2 enable
    [*SwitchA-bgp-af-ipv6] network fc00:0:0:1:: 64
    [*SwitchA-bgp-af-ipv6] network fc00:0:0:100:: 64
    [*SwitchA-bgp-af-ipv6] quit
    [*SwitchA-bgp] quit
    [*SwitchA] commit

    # Configure SwitchB.

    [~SwitchB] bgp 200
    [*SwitchB-bgp] router-id 172.16.2.2
    [*SwitchB-bgp] peer fc00:0:0:100::1 as-number 100
    [*SwitchB-bgp] peer fc00:0:0:101::1 as-number 200
    [*SwitchB-bgp] ipv6-family unicast
    [*SwitchB-bgp-af-ipv6] peer fc00:0:0:100::1 enable
    [*SwitchB-bgp-af-ipv6] peer fc00:0:0:101::1 enable
    [*SwitchB-bgp-af-ipv6] network fc00:0:0:100:: 64
    [*SwitchB-bgp-af-ipv6] network fc00:0:0:101:: 64
    [*SwitchB-bgp-af-ipv6] quit
    [*SwitchB-bgp] quit
    [*SwitchB] commit

    # Configure SwitchC.

    [~SwitchC] bgp 200
    [*SwitchC-bgp] router-id 172.16.3.3
    [*SwitchC-bgp] peer fc00:0:0:101::2 as-number 200
    [*SwitchC-bgp] peer fc00:0:0:102::2 as-number 200
    [*SwitchC-bgp] ipv6-family unicast
    [*SwitchC-bgp-af-ipv6] peer fc00:0:0:101::2 enable
    [*SwitchC-bgp-af-ipv6] peer fc00:0:0:102::2 enable
    [*SwitchC-bgp-af-ipv6] network fc00:0:0:101:: 64
    [*SwitchC-bgp-af-ipv6] network fc00:0:0:102:: 64
    [*SwitchC-bgp-af-ipv6] quit
    [*SwitchC-bgp] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] bgp 200
    [*SwitchD-bgp] router-id 172.16.4.4
    [*SwitchD-bgp] peer fc00:0:0:102::1 as-number 200
    [*SwitchD-bgp] ipv6-family unicast
    [*SwitchD-bgp-af-ipv6] peer fc00:0:0:102::1 enable
    [*SwitchD-bgp-af-ipv6] network fc00:0:0:102:: 64
    [*SwitchD-bgp-af-ipv6] quit
    [*SwitchD-bgp] quit
    [*SwitchD] commit

  4. Configure the route reflector.

    # Configure SwitchC as the route reflector and SwitchB and SwitchD as the clients.

    [~SwitchC] bgp 200
    [~SwitchC-bgp] ipv6-family unicast
    [~SwitchC-bgp-af-ipv6] peer fc00:0:0:101::2 reflect-client
    [*SwitchC-bgp-af-ipv6] peer fc00:0:0:102::2 reflect-client
    [*SwitchC-bgp-af-ipv6] commit

    # View the routing table of SwitchB.

    [~SwitchB] display bgp ipv6 routing-table
     BGP Local router ID is 172.16.2.2
     Status codes: * - valid, > - best, x - best external, h - history,
                   i - internal, s - suppressed, S - Stale
     Origin      : i - IGP, e - EGP, ? - incomplete
     Total Number of Routes: 6
     *>  Network  : FC00:0:0:1::                             PrefixLen : 64     
         NextHop  : FC00:0:0:100::1                          LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : 100  i
     *>  Network  : FC00:0:0:100::                           PrefixLen : 64     
         NextHop  : ::                                       LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
        
         NextHop  : FC00:0:0:100::1                          LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : 100  i
     *>  Network  : FC00:0:0:101::                           PrefixLen : 64     
         NextHop  : ::                                       LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
       i
         NextHop  : FC00:0:0:101::1                          LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
     *>i Network  : FC00:0:0:102::                           PrefixLen : 64     
         NextHop  : FC00:0:0:101::1                          LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i

    # View the routing table of SwitchD.

    [~SwitchD] display bgp ipv6 routing-table
     BGP Local router ID is 172.16.4.4
     Status codes: * - valid, > - best, x - best external, h - history,
                   i - internal, s - suppressed, S - Stale
     Origin      : i - IGP, e - EGP, ? - incomplete
    
     Total Number of Routes: 5
     *>i Network  : FC00:0:0:1::                             PrefixLen : 64     
         NextHop  : FC00:0:0:100::1                          LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : 100  i
     *>i Network  : FC00:0:0:100::                           PrefixLen : 64     
         NextHop  : FC00:0:0:101::2                          LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
     *>i Network  : FC00:0:0:101::                           PrefixLen : 64     
         NextHop  : FC00:0:0:102::1                          LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
     *>  Network  : FC00:0:0:102::                           PrefixLen : 64     
         NextHop  : ::                                       LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
       i
         NextHop  : FC00:0:0:102::1                          LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i

    The routing tables show that SwitchD and SwitchB have learned the routing information advertised by SwitchA from SwitchC.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:100::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 100
     router-id 172.16.1.1
     peer FC00:0:0:100::2 as-number 200
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:1:: 64
      network FC00:0:0:100:: 64
      peer FC00:0:0:100::2 enable
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:100::2/64
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:101::2/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 200
     router-id 172.16.2.2
     peer FC00:0:0:100::1 as-number 100
     peer FC00:0:0:101::1 as-number 200
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:100:: 64
      network FC00:0:0:101:: 64
      peer FC00:0:0:100::1 enable
      peer FC00:0:0:101::1 enable
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:101::1/64
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:102::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 200
     router-id 172.16.3.3
     peer FC00:0:0:101::2 as-number 200
     peer FC00:0:0:102::2 as-number 200
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:101:: 64
      network FC00:0:0:102:: 64
      peer FC00:0:0:101::2 enable
      peer FC00:0:0:101::2 reflect-client
      peer FC00:0:0:102::2 enable
      peer FC00:0:0:102::2 reflect-client
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 40
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:102::2/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    bgp 200
     router-id 172.16.4.4
     peer FC00:0:0:102::1 as-number 200
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:102:: 64
      peer FC00:0:0:102::1 enable
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074760

Views: 45044

Downloads: 58

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next