No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic BGP4+ Functions

Example for Configuring Basic BGP4+ Functions

Networking Requirements

As shown in Figure 9-20, there are two ASs: 65008 and 65009. SwitchA belongs to AS 65008, and SwitchB, SwitchC, and SwitchD belong to AS 65009. A routing Protocol is required to exchange the routing information between the two ASs.

Figure 9-20 Networking diagram of configuring basic BGP4+ functions

Table 9-8

Switch

Interface

IPv6 Address

SwitchA

VLANIF10

FC00:0:0:80::1/64

VLANIF20

FC00:0:0:100::2/64

SwitchB

VLANIF20

FC00:0:0:100::1/64

VLANIF30

FC00:0:0:93::1/64

VLANIF40

FC00:0:0:91::1/64

SwitchC

VLANIF30

FC00:0:0:93::2/64

VLANIF50

FC00:0:0:92::1/64

SwitchD

VLANIF40

FC00:0:0:91::2/64

VLANIF50

FC00:0:0:92::2/64

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IBGP connections between SwitchB, SwitchC, and SwitchD.

  2. Configure an EBGP connection between SwitchA and SwitchB.

Procedure

  1. Add interfaces to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA]interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit

    The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not provided here.

  2. Enable the IPv6 forwarding capability, and assign an IPv6 address for each interface. The following is the configuration of SwitchA. The configurations of other Switches are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:80::1/64
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:100::2/64
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  3. Configure IBGP.

    # Configure SwitchB.

    [~SwitchB] bgp 65009
    [*SwitchB-bgp] router-id 172.16.2.2
    [*SwitchB-bgp] peer fc00:0:0:91::2 as-number 65009
    [*SwitchB-bgp] peer fc00:0:0:93::2 as-number 65009
    [*SwitchB-bgp] ipv6-family unicast
    [*SwitchB-bgp-af-ipv6] peer fc00:0:0:91::2 enable
    [*SwitchB-bgp-af-ipv6] peer fc00:0:0:93::2 enable
    [*SwitchB-bgp-af-ipv6] network fc00:0:0:91:: 64
    [*SwitchB-bgp-af-ipv6] network fc00:0:0:93:: 64
    [*SwitchB-bgp-af-ipv6] quit
    [*SwitchB-bgp] quit
    [*SwitchB] commit

    # Configure SwitchC.

    [~SwitchC] bgp 65009
    [*SwitchC-bgp] router-id 172.16.3.3
    [*SwitchC-bgp] peer fc00:0:0:93::1 as-number 65009
    [*SwitchC-bgp] peer fc00:0:0:92::2 as-number 65009
    [*SwitchC-bgp] ipv6-family unicast
    [*SwitchC-bgp-af-ipv6] peer fc00:0:0:93::1 enable
    [*SwitchC-bgp-af-ipv6] peer fc00:0:0:92::2 enable
    [*SwitchC-bgp-af-ipv6] network fc00:0:0:93:: 64
    [*SwitchC-bgp-af-ipv6] network fc00:0:0:92:: 64
    [*SwitchC-bgp-af-ipv6] quit
    [*SwitchC-bgp] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] bgp 65009
    [*SwitchD-bgp] router-id 172.16.4.4
    [*SwitchD-bgp] peer fc00:0:0:91::1 as-number 65009
    [*SwitchD-bgp] peer fc00:0:0:92::1 as-number 65009
    [*SwitchD-bgp] ipv6-family unicast
    [*SwitchD-bgp-af-ipv6] peer fc00:0:0:91::1 enable
    [*SwitchD-bgp-af-ipv6] peer fc00:0:0:92::1 enable
    [*SwitchD-bgp-af-ipv6] network fc00:0:0:92:: 64
    [*SwitchD-bgp-af-ipv6] network fc00:0:0:91:: 64
    [*SwitchD-bgp-af-ipv6] quit
    [*SwitchD-bgp] quit
    [*SwitchD] commit

  4. Configure the EBGP connection.

    # Configure SwitchA.

    [~SwitchA] bgp 65008
    [*SwitchA-bgp] router-id 172.16.1.1
    [*SwitchA-bgp] peer fc00:0:0:100::1 as-number 65009
    [*SwitchA-bgp] ipv6-family unicast
    [*SwitchA-bgp-af-ipv6] peer fc00:0:0:100::1 enable
    [*SwitchA-bgp-af-ipv6] network fc00:0:0:100:: 64
    [*SwitchA-bgp-af-ipv6] network fc00:0:0:80:: 64
    [*SwitchA-bgp-af-ipv6] quit
    [*SwitchA-bgp] quit
    [*SwitchA] commit

    # Configure SwitchB.

    [~SwitchB] bgp 65009
    [~SwitchB-bgp] peer fc00:0:0:100::2 as-number 65008
    [*SwitchB-bgp] ipv6-family unicast
    [*SwitchB-bgp-af-ipv6] peer fc00:0:0:100::2 enable
    [*SwitchB-bgp-af-ipv6] network fc00:0:0:100:: 64
    [*SwitchB-bgp-af-ipv6] quit
    [*SwitchB-bgp] quit
    [*SwitchB] commit

    # View the status of the BGP4+ peers.

    [~SwitchB] display bgp ipv6 peer
     BGP local router ID        : 172.16.2.2
     Local AS number            : 65009
     Total number of peers      : 3
     Peers in established state : 3
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      FC00:0:0:91::2  4       65009       10       12     0 00:05:59 Established        2
      FC00:0:0:93::2  4       65009        4        4     0 00:00:11 Established        2
      FC00:0:0:100::2 4       65008        8       10     0 00:03:57 Established        1

    The preceding information shows that the BGP4+ connections between SwitchB and other Switches are set up.

    # Display the routing table of SwitchA.

    [~SwitchA] display bgp ipv6 routing-table
     BGP Local router ID is 172.16.1.1
     Status codes: * - valid, > - best, d - damped, h - history,
                   i - internal, s - suppressed, S - Stale
     Origin      : i - IGP, e - EGP, ? - incomplete
                                                                              
                                                                              
     Total Number of Routes: 6                                                
     *>     Network  : FC00:0:0:80::                            PrefixLen : 64
            NextHop  : ::                                       LocPrf    :   
            MED      : 0                                        PrefVal   : 0 
            Label    :                                                        
            Path/Ogn :  i                                                     
     *>     Network  : FC00:0:0:91::                            PrefixLen : 64
            NextHop  : FC00:0:0:100::1                          LocPrf    :   
            MED      : 0                                        PrefVal   : 0 
            Label    :                                                        
            Path/Ogn : 65009i                                                 
     *>     Network  : FC00:0:0:92::                            PrefixLen : 64
            NextHop  : FC00:0:0:100::1                          LocPrf    :   
            MED      :                                          PrefVal   : 0 
            Label    :                                                        
            Path/Ogn : 65009i                                                 
     *>     Network  : FC00:0:0:93::                            PrefixLen : 64
            NextHop  : FC00:0:0:100::1                          LocPrf    :   
            MED      : 0                                        PrefVal   : 0 
            Label    :                                                        
            Path/Ogn : 65009i                                                 
     *>     Network  : FC00:0:0:100::                           PrefixLen : 64
            NextHop  : ::                                       LocPrf    :   
            MED      : 0                                        PrefVal   : 0 
            Label    :                                                        
            Path/Ogn :  i                                                     
     *                                                                        
            NextHop  : FC00:0:0:100::1                          LocPrf    :   
            MED      : 0                                        PrefVal   : 0 
            Label    :                                                        
            Path/Ogn : 65009i

    The routing table shows that SwitchA has learned the route from AS 65009. AS 65008 and AS 65009 can exchange their routing information.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:80::1/64
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:100::2/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 65008
     router-id 172.16.1.1
     peer FC00:0:0:100::1 as-number 65009
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:80:: 64
      network FC00:0:0:100:: 64
      peer FC00:0:0:100::1 enable
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 30 40
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:100::1/64
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:93::1/64
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:91::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 65009
     router-id 172.16.2.2
     peer FC00:0:0:91::2 as-number 65009
     peer FC00:0:0:93::2 as-number 65009
     peer FC00:0:0:100::2 as-number 65008
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:91:: 64
      network FC00:0:0:93:: 64
      network FC00:0:0:100:: 64
      peer FC00:0:0:91::2 enable
      peer FC00:0:0:93::2 enable
      peer FC00:0:0:100::2 enable
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 30 50
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:93::2/64
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:92::1/64
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 65009
     router-id 172.16.3.3
     peer FC00:0:0:92::2 as-number 65009
     peer FC00:0:0:93::1 as-number 65009
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:92:: 64
      network FC00:0:0:93:: 64
      peer FC00:0:0:92::2 enable
      peer FC00:0:0:93::1 enable
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 40 50
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:91::2/64
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:92::2/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    bgp 65009
     router-id 172.16.4.4
     peer FC00:0:0:91::1 as-number 65009
     peer FC00:0:0:92::1 as-number 65009
     #
     ipv4-family unicast
     #
     ipv6-family unicast
      network FC00:0:0:91:: 64
      network FC00:0:0:92:: 64
      peer FC00:0:0:91::1 enable
      peer FC00:0:0:92::1 enable
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074760

Views: 55237

Downloads: 62

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next