No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IS-IS DIS Election

Example for Configuring IS-IS DIS Election

Networking Requirements

In Figure 7-27, four switches on the broadcast network communicate using IS-IS. SwitchA and SwitchB are Level-1-2 devices, SwitchC is a Level-1 device, and SwitchD is a Level-2 device. SwitchA with high performance needs to be configured as a Level-2 DIS.

Figure 7-27 Networking diagram of configuring IS-IS DIS election

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IS-IS to enable network interconnectivity.

  2. Set the DIS priority of SwitchA to 100 so that SwitchA can be elected as a Level-2 DIS.

Procedure

  1. Configure an IPv4 address for each interface. The configuration details are not described here.
  2. View the MAC address of the VLANIF interface on each switch. When each VLANIF interface has the same DIS priority, the switch with a larger interface MAC address is elected as the DIS.

    # View the MAC address of VLANIF10 on SwitchA.

    [~SwitchA] display arp interface vlanif 10
    ARP timeout:1200s
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.1        00e0-fc10-afec        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1  

    # View the MAC address of VLANIF10 on SwitchB.

    [~SwitchB] display arp interface vlanif 10
    ARP timeout:1200s
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.2        00e0-fccd-acdf        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1

    # View the MAC address of VLANIF10 on SwitchC.

    [~SwitchC] display arp interface vlanif 10
    ARP timeout:1200s
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.3        00e0-fc50-25fe        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1

    # View the MAC address of VLANIF10 on SwitchD.

    [~SwitchD] display arp interface vlanif 10
    ARP timeout:1200s
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                         
    EXP: Expire-time                                              
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE
    -------------------------------------------------------------------------
    10.1.1.4        00e0-fcfd-305c        I          Vlanif10
    -------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:0    Interface:1

  3. Configure IS-IS protocol.

    # Configure SwitchA.

    [~SwitchA] isis 1
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis enable 1
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [~SwitchB] isis 1
    [*SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [*SwitchB-isis-1] quit
    [*SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] isis enable 1
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit

    # Configure SwitchC.

    [~SwitchC] isis 1
    [*SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [*SwitchC-isis-1] is-level level-1
    [*SwitchC-isis-1] quit
    [*SwitchC] interface vlanif 10
    [*SwitchC-Vlanif10] isis enable 1
    [*SwitchC-Vlanif10] commit
    [~SwitchC-Vlanif10] quit

    # Configure SwitchD.

    [~SwitchD] isis 1
    [*SwitchD-isis-1] network-entity 10.0000.0000.0004.00
    [*SwitchD-isis-1] is-level level-2
    [*SwitchD-isis-1] quit
    [*SwitchD] interface vlanif 10
    [*SwitchD-Vlanif10] isis enable 1
    [*SwitchD-Vlanif10] commit
    [~SwitchD-Vlanif10] quit

    # Check IS-IS neighbor information on SwitchA.

    [~SwitchA] display isis peer
                                                                                    
    Peer Information for ISIS(80)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0002  Vlanif10        0000.0000.0002.01  Up             8 L1(L1L2)  64
    0000.0000.0003  Vlanif10        0000.0000.0002.01  Up            29 L1        64
    0000.0000.0002  Vlanif10        0000.0000.0002.01  Up             6 L2(L1L2)  64
    0000.0000.0004  Vlanif10        0000.0000.0002.01  Up            27 L2        64
                                                                                    
    Total Peer(s): 4                                                                

    # View IS-IS interface information on SwitchA.

    [~SwitchA] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/No 

    # View IS-IS interface information on SwitchB.

    [~SwitchB] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 Yes/No

    # View IS-IS interface information on SwitchD.

    [~SwitchD] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/Yes 

    As shown in the preceding interface information, when the default DIS priority is used, the IS-IS interface on SwitchB has the largest MAC address among all the interfaces on the Level-1 Switches. Therefore, SwitchB is elected as a Level-1 DIS. The IS-IS interface on SwitchD has the largest MAC address among all the interfaces on the Level-2 Switches. Therefore, SwitchD is elected as a Level-2 DIS. Level-1 and Level-2 pseudonodes are 0000.0000.0002.01 and 0000.0000.0004.01 respectively.

  4. Configure the DIS priority of SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis dis-priority 100
    [*SwitchA-Vlanif10] commit

    # View IS-IS neighbor information on SwitchA.

    [~SwitchA] display isis peer
                                                                                    
    Peer Information for ISIS(80)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0002  Vlanif10        0000.0000.0001.01  Up            23 L1(L1L2)  64
    0000.0000.0003  Vlanif10        0000.0000.0001.01  Up            27 L1        64
    0000.0000.0002  Vlanif10        0000.0000.0001.01  Up            23 L2(L1L2)  64
    0000.0000.0004  Vlanif10        0000.0000.0001.01  Up            23 L2        64
                                                                                    
    Total Peer(s): 4                                                                

  5. Verify the configuration.

    # View IS-IS interface information on SwitchA.

    [~SwitchA] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 Yes/Yes

    As shown in the preceding information, after the DIS priority of the IS-IS interface on Switch is changed, SwitchA becomes a Level-1-2 DIS (DR) immediately and its pseudonode is 0000.0000.0001.01.

    # View IS-IS neighbor and interface information on SwitchB.

    [~SwitchB] display isis peer
                                                                                    
    Peer Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0001  Vlanif10        0000.0000.0001.01  Up             8 L1(L1L2) 100
    0000.0000.0003  Vlanif10        0000.0000.0001.01  Up            22 L1        64
    0000.0000.0001  Vlanif10        0000.0000.0001.01  Up             8 L2(L1L2) 100
    0000.0000.0004  Vlanif10        0000.0000.0001.01  Up            26 L2        64
                                                                                    
    Total Peer(s): 4                                                                
     [~SwitchB] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/No 

    # View IS-IS neighbor and interface information on SwitchD.

    [~SwitchD] display isis peer
                                                                                    
    Peer Information for ISIS(1)                                                   
    --------------------------------------------------------------------------------
                                                                                    
      System ID     Interface       Circuit ID        State HoldTime(s) Type     PRI
    --------------------------------------------------------------------------------
    0000.0000.0001  Vlanif10        0000.0000.0001.01  Up             8 L2       100
    0000.0000.0002  Vlanif10        0000.0000.0001.01  Up            22 L2        64
                                                                                    
    Total Peer(s): 2                                                                
    [~SwitchD] display isis interface
                                                                                    
    Interface Information for ISIS(1)                                              
    --------------------------------------------------------------------------------
     Interface         ID      IPV4 State          IPV6 State      MTU  Type  DIS   
     Vlanif10          001         Up          Mtu:Up/Lnk:Dn/IP:Dn 1497 L1/L2 No/No 

Configuration Files

  • Configuration file of SwitchA
    #
    sysname SwitchA
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis dis-priority 100
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of SwitchB
    #
    sysname SwitchB
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of SwitchC
    #
    sysname SwitchC
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.3 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Configuration file of SwitchD
    #
    sysname SwitchD
    #
    vlan batch 10
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif10
     ip address 10.1.1.4 255.255.255.0
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074760

Views: 47058

Downloads: 58

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next