No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LSP Ping Test for LSP Tunnels

Example for Configuring LSP Ping Test for LSP Tunnels

Networking Requirements

In Figure 7-16,

  • SwitchA, SwitchB, and SwitchC run the OSPF protocol, and has learned the 32-bit host routes of the loopback interface of each other.

  • MPLS and MPLS LDP are enabled on SwitchA, SwitchB, and SwitchC.

  • MPLS and MPLS LDP are enabled on the VLANIF interfaces between SwitchA, SwitchB, and SwitchC to trigger the establishment of an LDP LSP.

The NQA LSP Ping test needs to be performed to check the connectivity of the LSP between SwitchA and SwitchC.

Figure 7-16 Networking diagram of an LSP Ping test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as the NQA client.

  2. Configure SwitchC as the NQA server.

  3. Configure an LSP Ping test instance on SwitchA.

Procedure

  1. Configure the routes and LDP sessions between SwitchA, SwitchB, and SwitchC.

    For the detailed configurations, see the configuration files of SwitchA, SwitchB, and SwitchC.

  2. Configure an LSP Ping test instance.

    # Enable the NQA client and create an LSP Ping test instance for LSP tunnels.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] nqa test-instance admin lspping
    [*SwitchA-nqa-admin-lspping] test-type lspping
    [*SwitchA-nqa-admin-lspping] lsp-type ipv4
    [*SwitchA-nqa-admin-lspping] destination-address ipv4 10.3.3.9 lsp-masklen 32
    [*SwitchA-nqa-admin-lspping] commit

  3. Start the test instance.

    [~SwitchA-nqa-admin-lspping] start now
    [*SwitchA-nqa-admin-lspping] commit

  4. Verify the test result.

    [~SwitchA-nqa-admin-lspping] display nqa results test-instance admin lspping
                                                                                    
    NQA entry(admin, lspping): test flag is inactive, test type is LSPPING          
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3                Receive response times: 3             
       Completion: success                    RTD over thresholds number: 0         
       Attempts number: 1                     Drop operation number: 0              
       Disconnect operation number: 0         Operation timeout number: 0           
       System busy operation number: 0        Connection fail number: 0             
       Operation sequence errors number: 0    RTT Status errors number: 0            
       Destination IP address: 10.3.3.9                                              
       Min/Max/Average completion time: 4/5/4                                       
       Sum/Square-Sum  completion time: 13/57                                       
       Last response packet receiving time: 2013-12-09 08:57:55.6                   
       Lost packet ratio: 0 %    

Configuration File

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    mpls lsr-id 10.3.1.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 10.3.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    nqa test-instance admin lspping
     test-type lspping
     destination-address ipv4 10.3.3.9 lsp-masklen 32
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    # 
    vlan batch 100 110
    #
    mpls lsr-id 10.3.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    mpls lsr-id 10.3.3.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 19564

Downloads: 22

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next