No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring NetStream Top Talkers

Example for Configuring NetStream Top Talkers

Networking Requirements

In the scenario shown in Figure 13-9, departments 1 and 2 of an enterprise connect to the Internet through SwitchA, and no NetStream server is located on the network. To monitor the traffic transmitted between the two departments and the Internet, the network administrator intends to configure NetStream Top Talkers on 10GE3/0/1 of SwitchA. The NetStream Top Talkers function can collect statistics on incoming and outgoing traffic on the interface separately, sort the Top Talkers, and displays results.

Figure 13-9 NetStream Top Talkers networking diagram

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign IP addresses to the interfaces of SwitchA.
  2. Configure a NetStream Top Talkers template.
  3. Configure NetStream sampling.
  4. Apply the NetStream Top Talkers template to an interface.
  5. Start the NetStream Top Talkers function.

Procedure

  1. Assign IP addresses to the interfaces of SwitchA.

    # Assign IP addresses to the interfaces of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 101 102
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 101
    [*SwitchA-Vlanif101] ip address 10.1.2.1 24
    [*SwitchA-Vlanif101] quit
    [*SwitchA] interface vlanif 102
    [*SwitchA-Vlanif102] ip address 10.1.3.1 24
    [*SwitchA-Vlanif102] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 2/0/1
    [*SwitchA-10GE2/0/1] port link-type trunk
    [*SwitchA-10GE2/0/1] port trunk pvid vlan 101
    [*SwitchA-10GE2/0/1] port trunk allow-pass vlan 101
    [*SwitchA-10GE2/0/1] quit
    [*SwitchA] interface 10ge 3/0/1
    [*SwitchA-10GE3/0/1] port link-type trunk
    [*SwitchA-10GE3/0/1] port trunk pvid vlan 102
    [*SwitchA-10GE3/0/1] port trunk allow-pass vlan 102
    [*SwitchA-10GE3/0/1] quit
    [*SwitchA] commit
    

  2. Configure a NetStream Top Talkers template.

    # Create a NetStream Top Talkers template named test, specify the traffic filtering keyword as destination IP address, set the number of Top Talkers that can be recorded in the NetStream Top Talkers template to 200, set the traffic statistics collection period to 1200000 ms (20 minutes), and specify the Top Talker sorting order as number of packets.

    [~SwitchA] netstream top-talkers test ip
    [*SwitchA-netstream-top-talkers-test] match ip destination-address 10.1.3.2 24
    [*SwitchA-netstream-top-talkers-test] top number 200
    [*SwitchA-netstream-top-talkers-test] cache-timeout 1200000
    [*SwitchA-netstream-top-talkers-test] sort-by packets
    [*SwitchA-netstream-top-talkers-test] quit
    [*SwitchA] commit
    

  3. Configure NetStream sampling.

    # Configure NetStream sampling for the incoming and outgoing packets on 10GE3/0/1 and set the sampling interval to 8192.

    [~SwitchA] interface 10ge 3/0/1
    [~SwitchA-10GE3/0/1] netstream sampler random-packets 8192 inbound
    [*SwitchA-10GE3/0/1] netstream sampler random-packets 8192 outbound
    [*SwitchA-10GE3/0/1] quit
    [*SwitchA] commit
    

  4. Apply the NetStream Top Talkers template to an interface.

    # Enable NetStream Top Talkers statistics collection on 10GE3/0/1 for incoming and outgoing traffic.

    [~SwitchA] interface 10ge 3/0/1
    [~SwitchA-10GE3/0/1] netstream top-talkers test ip inbound
    [*SwitchA-10GE3/0/1] netstream top-talkers test ip outbound
    [*SwitchA-10GE3/0/1] quit
    [*SwitchA] commit
    [~SwitchA] quit
    

  5. Start the NetStream Top Talkers function.

    # Start the NetStream Top Talkers function immediately.

    <SwitchA> netstream top-talkers test ip starting

  6. Verify the configuration.

    # After the configurations are complete, view the Top Talkers statistics and sorting results on 10GE3/0/1.

    <SwitchA> display netstream top-talkers test ip interface 10ge 3/0/1 slot 3
    Top-Talkers Name   : test
    Flow Type          : IPv4
    Top Number         : 200
    Sort-By            : PACKETS
    Cache-Timeout      : 1200000
    BeginCache Time    : 2014-12-10 09:59:44
    match DstIP/Mask   : 10.1.3.2/255.255.255.0
     -------------------------------------------------------------------------------
     SrcIP                     SrcPort  Bytes               BPS         BPM
     DstIP                     DstPort  Packets             PPS         PPM
     Interface                 Protocol Direction
     -------------------------------------------------------------------------------
    
     10.1.1.2                   0        62762800            2096200     125777100
     10.1.3.2                   0        729800              24300       1462500
     10GE3/0/1                  114      Inbound
    
     10.1.2.2                   0        61894200            2067200     124036400
     10.1.3.2                   0        719700              24000       1442200
     10GE3/0/1                  114      Inbound
    
     -------------------------------------------------------------------------------
     2 of 200 top talkers shown. 2 flows processed.
     -------------------------------------------------------------------------------

Configuration Files

SwitchA configuration file
#
sysname SwitchA
#
netstream top-talkers test ip
 match ip destination-address 10.1.3.2 255.255.255.0
 top number 200
 sort-by packets
 cache-timeout 1200000
#
vlan batch 100 to 102 
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif101
 ip address 10.1.2.1 255.255.255.0
#
interface Vlanif102
 ip address 10.1.3.1 255.255.255.0 
#
interface 10GE1/0/1
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100
#
interface 10GE2/0/1
 port link-type trunk
 port trunk pvid vlan 101
 port trunk allow-pass vlan 101
#
interface 10GE3/0/1
 port link-type trunk
 port trunk pvid vlan 102
 port trunk allow-pass vlan 102
 netstream sampler random-packets 8192 inbound
 netstream sampler random-packets 8192 outbound
 netstream top-talkers test ip inbound
 netstream top-talkers test ip outbound
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 21078

Downloads: 23

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next