No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Device to Communicate with an NMS Using SNMPv1

Example for Configuring a Device to Communicate with an NMS Using SNMPv1

Networking Requirements

In the network shown in Figure 1-10, NMS1 and NMS2 monitor devices on the network. The network is small and has high security, devices are configured to use SNMPv1 to communicate with the NMSs.

A switch is added on the network for expansion and monitored by the NMSs. Users want to monitor the switch using current network resources and quickly locate and troubleshoot faults on the switch. The NMS needs to manage objects excluding the IS-IS object on the switch.

Figure 1-10 Networking diagram for configuring a device to communicate with an NMS by using SNMPv1

Configuration Roadmap

SNMPv1 can be used after a device is added on the user network. To reduce the load of the NMS, configure NMS2 to monitor the switch and NMS1 not to monitor the switch.

The configuration roadmap is as follows:

  1. Configure the SNMP version of the switch as SNMPv1.

  2. Configure the NMS access right to enable NMS2 to manage MIB objects except IS-IS objects on the switch.

  3. Configure the trap host for the switch to deliver traps generated on the switch to NMS2. Only modules that are enabled by default can deliver traps, which helps locate traps and prevent unwanted traps.

  4. Configure the NMS2.

Procedure

  1. Configure an IP address for an interface of the switch.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 100
    [*Switch] interface vlanif 100
    [*Switch-Vlanif100] ip address 10.1.2.1 24
    [*Switch-Vlanif100] quit
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port link-type trunk
    [*Switch-10GE1/0/1] port trunk allow-pass vlan 100
    [*Switch-10GE1/0/1] quit
    [*Switch] commit

  2. Configure routing function to ensure a reachable route between the switch and NMS2.

    [~Switch] ospf
    [*Switch-ospf-1] area 0
    [*Switch-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*Switch-ospf-1-area-0.0.0.0] quit
    [*Switch-ospf-1] quit
    [*Switch] commit

  3. Configure the switch to run SNMPv1.

    [~Switch] snmp-agent sys-info version v1
    

  4. Configure the access rights.

    # Configure an ACL to allow NMS2 to manage and disable NMS1 from managing the switch.

    [*Switch] acl 2001
    [*Switch-acl4-basic-2001] rule 5 permit source 10.1.1.2 0.0.0.0
    [*Switch-acl4-basic-2001] quit

    # Configure a MIB view and allow NMS2 to manage every MIB object except IS-IS on the switch.

    [*Switch] snmp-agent mib-view excluded allextisis 1.3.6.1.3.37
    

    # Configure the community name and apply the ACL and MIB views.

    [*Switch] snmp-agent community write adminNMS1234 mib-view allextisis acl 2001
    

  5. Configure the trap host.

    [*Switch] snmp-agent target-host host-name NMS2 trap address udp-domain 10.1.1.2 params securityname adminNMS1234
    [*Switch] commit
    [~Switch] quit

  6. Configure NMS2.

    In this example, NMS2 is eSight V300R005C00.

    1. Choose Resource > Add Resource > Add Resource in the toolbar and click Network Device.
    2. Choose SNMP > Edit SNMP parameters. Set the SNMP version to v1, read community name to adminNMS1234, write community name to adminNMS1234, and port number to 161.

      NOTE:

      The community name and port number on the network management side must be the same as those on the device side and the SNMP version used on the NMS must be enabled on the device; otherwise, the NMS cannot connect to the device.

      If only a write community name is configured on the device, the NMS uses this write community name as the read and write community names.

    3. Click OK.
    Figure 1-11 Configuring SNMP on eSight

  7. Verify the configuration.

    After the configurations are complete, the switch sets up a connection with NMS2. You can manage the switch through NMS2 and NMS2 can receive the traps from the switch.

    Check the following configurations.

    # Check information about the SNMP community name.

    <Switch> display snmp-agent community
       Community name: %^%#K[&`Jc~_4H-~.>0:m%dK:*7s,{(3i02`R$>&n}+56Pb'@]rd}NT@o4.7RG'8ScPW0=d%O<1oU+7KHS[I%^%#
           Group name: %^%#K[&`Jc~_4H-~.>0:m%dK:*7s,{(3i02`R$>&n}+56Pb'@]rd}NT@o4.7RG'8ScPW0=d%O<1oU+7KHS[I%^%#
           Acl: 2001
           Storage-type: nonVolatile

    # Check the target host.

    <Switch> display snmp-agent target-host
    Target host NO. 1
    ---------------------------------------------------------------------------
      Host name                        : NMS2
      IP address                       : 10.1.1.2
      Source interface                 : -
      VPN instance                     : -
      Security name                    : %^%#.&h-$,1jCK-Vsk)}iAO'4oHASwPgq<2i^,6m7~IB%^%#
      Port                             : 162
      Type                             : trap
      Version                          : v1
      Level                            : No authentication and privacy
      NMS type                         : NMS
      With ext vb                      : No
      Notification filter profile name : -
      Heart beat required              : No    
    ---------------------------------------------------------------------------

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 100
#
acl number 2001
 rule 5 permit source 10.1.1.2 0
#
interface Vlanif100
 ip address 10.1.2.1 255.255.255.0
#
interface 10GE1/0/1
 port link-type trunk
 port trunk allow-pass vlan 100
#
ospf 1
 area 0.0.0.0
  network 10.1.2.0 0.0.0.255
#
snmp-agent
snmp-agent local-engineid 800007DB03360102101100
snmp-agent community write cipher %^%#K[&`Jc~_4H-~.>0:m%dK:*7s,{(3i02`R$>&n}+56Pb'@]rd}NT@o4.7RG'8ScPW0=d%O<1oU+7KHS[I%^%# mib-view allextisis acl 2001
# 
snmp-agent sys-info version v1 v3
snmp-agent target-host host-name NMS2 trap address udp-domain 10.1.1.2 params securityname cipher %^%#.&h-$,1jCK-Vsk)}iAO'4oHASwPgq<2i^,6m7~IB%^%#
#
snmp-agent mib-view excluded allextisis isisMIB
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 20722

Downloads: 22

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next