No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Device to Communicate with an NMS Through the SNMP Proxy

Example for Configuring a Device to Communicate with an NMS Through the SNMP Proxy

Networking Requirements

The SNMP protocol allows the network management system to manage network elements. When there are a lot of network elements on the network, management cost is high.

To reduce the management cost, configure the SNMP proxy on the middle-point device, as shown in Figure 1-18. The NMS considers the middle-point device and managed devices as an independent network element; therefore, the NMS does not need to manage too many network elements, reducing management cost.
Figure 1-18 Networking diagram for configuring the device to communicate with NMS through SNMP proxy

Configuration Roadmap

The configuration roadmap is as follows:

  • Configure the middle-point device.

    1. Configure the IP addresses of interfaces that connect the middle-point device to the NMS and managed device.
    2. Configure SNMP proxy on the middle-point device using user-defined parameter settings, so that you can use the middle-point device to manage the managed device.
  • Configure the managed device.

    1. Configure the IP address of the interface that connects the managed device to the middle-point device.
    2. Configure SNMP for the managed device to communicate with the NMS.

Procedure

  1. Assign IP addresses to the interfaces on the middle-point device.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] vlan 200
    [*SwitchA-vlan200] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ip address 192.168.1.1 24
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 200
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 200
    [*SwitchA-10GE1/0/2] quit
    

  2. Configure SNMP proxy on the middle-point device.

    [*SwitchA] snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3
    [*SwitchA] snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 authentication-mode sha
    Please configure the authentication password (8-255)                            
    Enter Password:               //Enter the authentication password. It is Authe@1234 in this example.
    Confirm Password:             //Confirm the password. It is Authe@1234 in this example.
    [*SwitchA] snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 privacy-mode aes256
    Please configure the privacy password (8-255)                                   
    Enter Password:              //Enter the encryption password. It is Priva@1234 in this example.
    Confirm Password:            //Confirm the password. It is Priva@1234 in this example.
    [*SwitchA] snmp-agent proxy rule proxy_rule_read read remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy
    [*SwitchA] snmp-agent proxy rule proxy_rule_write write remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy
    [*SwitchA] snmp-agent proxy target-host proxy_host@NMS address udp-domain 10.1.2.1 udp-port 162 params securityname snmpv3 v3 privacy
    [*SwitchA] commit
    [~SwitchA] quit

  3. Configure the managed device.

    To configure SNMPv3, see Example for Configuring a Device to Communicate with an NMS Using SNMPv3 (USM User).

  4. Verify the configuration.

    # View the proxy rules for SNMP packets.

    <SwitchA> display snmp-agent proxy rule
       Proxy rule name : proxy_rule_read
           Type             : read
           Remote engine ID : 800007DB0338EBD9210010
           Host name        : proxy_host
           Security name    : snmpv3
           Version          : v3
           Level            : Privacy
    
       Proxy rule name : proxy_rule_write
           Type             : write
           Remote engine ID : 800007DB0338EBD9210010
           Host name        : proxy_host
           Security name    : snmpv3
           Version          : v3
           Level            : Privacy

    # View the target host information of the SNMP proxy.

    <SwitchA> display snmp-agent proxy target-host
    Proxy target host NO. 1
    -----------------------------------------------------------
      Host name        : proxy_host@NMS
      IP address       : 10.1.2.1
      Port             : 162
      Timeout          : 15
      Source interface : -
      VPN instance     : -
      Security name    : snmpv3
      Version          : v3
      Level            : Privacy
    -----------------------------------------------------------

Configuration File

Configuration file of SwitchA

#
sysname SwitchA
#
vlan batch 100 200
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif200
 ip address 192.168.1.1 255.255.255.0
#
interface 10GE1/0/1
 port link-type trunk                                                           
 port trunk pvid vlan 100                                                       
 port trunk allow-pass vlan 100      
#
interface 10GE1/0/2
 port link-type trunk                                                           
 port trunk pvid vlan 200                                                       
 port trunk allow-pass vlan 200      
#
snmp-agent                                                                      
snmp-agent local-engineid 800007DB03001974593301 
#
snmp-agent sys-info version v3  
#                                                                              
snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3         
snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 authentication-mode sha cipher %^%#>rWG1!T'uGx-eiWUd2o$|YX@W/Pnj9(di:TNF84B%^%#                         
snmp-agent remote-engineid 800007DB0338EBD9210010 usm-user v3 snmpv3 privacy-mode aes256 cipher %^%#2Qkp*gA$D~TXG^J$1/PG0[=57kq~JPj>hS,znsC*%^%#                             
#                                                                               
snmp-agent proxy target-host proxy_host@NMS address udp-domain 10.1.2.1 udp-port 162 params securityname snmpv3 v3 privacy                                
#                                                                               
snmp-agent proxy rule proxy_rule_read read remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy               
snmp-agent proxy rule proxy_rule_write write remote-engineid 800007DB0338EBD9210010 target-host proxy_host params-in securityname snmpv3 v3 privacy             
#                                                    
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 21028

Downloads: 23

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next