No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LSP Trace Test for LSP Tunnels

Example for Configuring LSP Trace Test for LSP Tunnels

Networking Requirements

In Figure 7-17,

  • SwitchA, SwitchB, and SwitchC run the OSPF protocol and has learned the 32-bit host routes of the loopback interfaces of each other.

  • MPLS and MPLS LDP are enabled on SwitchA, SwitchB, and SwitchC.

  • MPLS and MPLS LDP are enabled on the VLANIF interfaces between SwitchA, SwitchB, and SwitchC to trigger the establishment of an LDP LSP.

The NQA LSP Trace test needs to be performed to test the LSP paths.

Figure 7-17 Networking diagram for configuring the LSP Trace test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as the NQA client.

  2. Configure SwitchC as the NQA server.

  3. Configure an LSP Trace test instance on SwitchA.

Procedure

  1. Configure the routes and LDP sessions between SwitchA, SwitchB, and SwitchC.

    For the detailed configurations, see the configuration files of SwitchA, SwitchB, and SwitchC.

  2. Configure an LSP Trace test instance.

    # Enable the NQA client and create an LSP Trace test instance for LSP tunnels.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] nqa test-instance admin lsptrace
    [*SwitchA-nqa-admin-lsptrace] test-type lsptrace
    [*SwitchA-nqa-admin-lsptrace] lsp-type ipv4
    [*SwitchA-nqa-admin-lsptrace] destination-address ipv4 10.3.3.9 lsp-masklen 32
    [*SwitchA-nqa-admin-lsptrace] commit

  3. Start the test instance.

    [~SwitchA-nqa-admin-lsptrace] start now
    [*SwitchA-nqa-admin-lsptrace] commit

  4. Verify the test result.

    [~SwitchA-nqa-admin-lsptrace] display nqa results test-instance admin lsptrace
                                                                                    
    NQA entry(admin, lsptrace): test flag is inactive, test type is LSPTRACE        
      1 . Test 1 result   The test is finished                                      
       Completion:success                     Attempts number:1                     
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT stats errors number:0             
       Drop operation number:0                                                      
       Last good path Time: 2013-12-09 08:58:14.9                                   
       1 . Hop 1                                                                    
        Send operation times: 3              Receive response times: 3              
        Min/Max/Average completion time: 2/7/4                                      
        Sum/Square-Sum  completion time: 12/62                                      
        RTD over thresholds number:0                                                
        Last response packet receive time: 2013-12-09 08:58:14.9                    
        Destination IP address:10.1.1.2                                             
        Lost packet ratio: 0 %                                                      
       2 . Hop 2                                                                    
        Send operation times: 3              Receive response times: 3              
        Min/Max/Average completion time: 2/3/2                                      
        Sum/Square-Sum  completion time: 7/17                                       
        RTD over thresholds number:0                                                
        Last response packet receive time: 2013-12-09 08:58:14.9                    
        Destination IP address:10.3.3.9                                              
        Lost packet ratio: 0 %                                                  

Configuration File

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    mpls lsr-id 10.3.1.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 10.3.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    nqa test-instance admin lsptrace
     test-type lsptrace
     destination-address ipv4 10.3.3.9 lsp-masklen 32
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    # 
    vlan batch 100 110
    #
    mpls lsr-id 10.3.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    mpls lsr-id 10.3.3.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 30094

Downloads: 29

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next