No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the OpenFlow Agent

Example for Configuring the OpenFlow Agent

Networking Requirements

In the example of OpenFlow networking shown in Figure 5-7, the switch is an OpenFlow-compatible switch, and there is a reachable route between the controller and switch. To manage and control the switch through the controller, you can configure OpenFlow connection parameters on the controller and switch so that the controller and switch can establish an OpenFlow connection and exchange information through this connection.

Figure 5-7 OpenFlow networking

Procedure

  1. Configure OpenFlow connection parameters on the controller.

    For instructions on the configuration of OpenFlow connection parameters on the controller, see the configuration guide of the controller.

  2. Configure the OpenFlow Agent.

    # Configure IP addresses for interfaces on the switch.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 20
    [*Switch-vlan20] quit
    [*Switch] interface vlanif 20
    [*Switch-Vlanif20] ip address 10.1.1.2 24
    [*Switch-Vlanif20] quit
    [*Switch] interface 10ge 4/0/1
    [*Switch-10GE4/0/1] port link-type trunk
    [*Switch-10GE4/0/1] port trunk pvid vlan 20
    [*Switch-10GE4/0/1] port trunk allow-pass vlan 20
    [*Switch-10GE4/0/1] quit
    [*Switch] interface loopback 1
    [*Switch-LoopBack1] ip address 10.10.10.10 32
    [*Switch-LoopBack1] commit
    [~Switch-LoopBack1] quit

    # Configure OpenFlow Agent on the switch.

    [~Switch] sdn agent 
    [*Switch-sdn-agent] source-ip 10.10.10.10
    [*Switch-sdn-agent] controller-ip 10.1.2.1
    [*Switch-sdn-agent-ctrl-10.1.2.1] quit
    [*Switch-sdn-agent] quit
    [*Switch] commit
    

  3. Verify the configuration.

    After the configuration is complete, run the display sdn openflow session command on the switch to check the OpenFlow connection status. If the OpenFlow connection status is Registered, the OpenFlow channel has been successfully established.

    [~Switch] display sdn openflow session
    
    --------------------------------------------------------------------------------
    Agent           Controller      UpTime       State      Role      VPN-instance
    --------------------------------------------------------------------------------
    10.10.10.10    10.1.2.1        0d21h09m32s  Registered Master     _public_
    --------------------------------------------------------------------------------

Configuration Files

Switch configuration file

#
vlan batch 20
#
sdn agent
 source-ip 10.10.10.10
 controller-ip 10.1.2.1
#
interface Vlanif20
 ip address 10.1.1.2 255.255.255.0
#
interface 10GE4/0/1
 port link-type trunk
 port trunk pvid vlan 20
 port trunk allow-pass vlan 20
#
interface LoopBack1
 ip address 10.10.10.10 255.255.255.255
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 21022

Downloads: 23

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next