No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Trace Test

Example for Configuring Trace Test

Networking Requirements

In Figure 7-14, the trace test is configured on SwitchA to test the IP address of the VLANIF 110 interface of SwitchC.

Figure 7-14 Networking diagram for configuring the trace test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as the NQA client. Create and perform the trace test on SwitchA to check the statistics on each hop from SwitchA to SwitchC.

Procedure

  1. Configure an IP address for each interface according to Figure 7-14, and configure reachable routes from one Switch to another.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitcA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    [*SwitchA] commit

  2. Create an NQA trace test instance on SwitchA and set the destination IP address to 10.2.1.2.

    [~SwitchA] nqa test-instance admin trace
    [*SwitchA-nqa-admin-trace] test-type trace
    [*SwitchA-nqa-admin-trace] destination-address ipv4 10.2.1.2
    [*SwitchA-nqa-admin-trace] commit

  3. Start NQA test instances.

    [~SwitchA-nqa-admin-trace] start now
    [*SwitchA-nqa-admin-trace] commit

  4. Query test results.

    # View the NQA test result on SwitchA. (V100R005C00)

    [~SwitchA-nqa-admin-trace] display nqa results test-instance admin trace
    
    NQA entry(admin, trace): test flag is inactive, test type is TRACE
      1 . Test 1 result   The test is finished
       Completion:success                     Attempts number:1
       Disconnect operation number:0          Operation timeout number:0
       System busy operation number:0         Connection fail number:0
       Operation sequence errors number:0     RTT Status errors number:0
       Drop operation number:0
       Last good path Time: 2015-03-16 16:29:26.8
       1 . Hop 1
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 3/20/9
        Sum/Square-Sum  Completion Time: 28/434
        RTD OverThresholds number:0
        Last Good Probe Time: 2015-03-16 16:29:26.7
        Destination ip address:10.1.1.2
        Lost packet ratio: 0 %
       2 . Hop 2
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 2/10/5
        Sum/Square-Sum  Completion Time: 15/113
        RTD OverThresholds number:0
        Last Good Probe Time: 2015-03-16 16:29:26.8
        Destination ip address:10.2.1.2
        Lost packet ratio: 0 %

Configuration File

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin trace
     test-type trace
     destination-address ipv4 10.2.1.2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 20400

Downloads: 22

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next