No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Layer 2 NetStream Flow Statistics Export

Example for Configuring Layer 2 NetStream Flow Statistics Export

Networking Requirements

In the scenario shown in Figure 13-8, departments 1 and 2 connect to the Internet through SwitchA. Network administrators want to monitor communication between the two departments and the Internet and to perform accounting for each department.

Figure 13-8 NetStream networking diagram

Configuration Roadmap

You can configure Layer 2 NetStream flow statistics export on 10GE1/0/1 of SwitchA. Configure SwitchA to collect statistics about incoming and outgoing traffic on the interface, and to send the statistics to the NetStream server for further analysis. In this way, you can monitor communication between the two departments and the Internet, and perform accounting for each department.

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on SwitchA.
  2. Configure NetStream sampling.
  3. Configure Layer 2 NetStream flow statistics export.
  4. Configure the version for exported packets.
  5. Enable Layer 2 statistics collection on the interface.

Procedure

  1. Configure IP addresses for interfaces on SwitchA as shown in Figure 13-8.

    # Assign IP addresses to the interfaces of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 110
    [*SwitchA-vlan110] quit
    [*SwitchA] interface vlanif 110
    [*SwitchA-Vlanif110] ip address 10.1.1.1 24
    [*SwitchA-Vlanif110] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 110
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 110
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] vlan 120
    [*SwitchA-vlan120] quit
    [*SwitchA] interface vlanif 120
    [*SwitchA-Vlanif120] ip address 10.1.2.1 24
    [*SwitchA-Vlanif120] quit
    [*SwitchA] interface 10ge 2/0/1
    [*SwitchA-10GE2/0/1] port link-type trunk
    [*SwitchA-10GE2/0/1] port trunk pvid vlan 120
    [*SwitchA-10GE2/0/1] port trunk allow-pass vlan 120
    [*SwitchA-10GE2/0/1] quit
    [*SwitchA] vlan 130
    [*SwitchA-vlan130] quit
    [*SwitchA] interface vlanif 130
    [*SwitchA-Vlanif130] ip address 10.1.3.1 24
    [*SwitchA-Vlanif130] quit
    [*SwitchA] interface 10ge 3/0/1
    [*SwitchA-10GE3/0/1] port link-type trunk
    [*SwitchA-10GE3/0/1] port trunk pvid vlan 130
    [*SwitchA-10GE3/0/1] port trunk allow-pass vlan 130
    [*SwitchA-10GE3/0/1] quit
    [*SwitchA] vlan 140
    [*SwitchA-vlan140] quit
    [*SwitchA] interface vlanif 140
    [*SwitchA-Vlanif140] ip address 10.1.4.1 24
    [*SwitchA-Vlanif140] quit
    [*SwitchA] interface 10ge 4/0/1
    [*SwitchA-10GE4/0/1] port link-type trunk
    [*SwitchA-10GE4/0/1] port trunk pvid vlan 140
    [*SwitchA-10GE4/0/1] port trunk allow-pass vlan 140
    [*SwitchA-10GE4/0/1] quit
    

  2. Configure NetStream sampling.

    # Configure NetStream sampling for the incoming and outgoing packets on 10GE1/0/1 and set the sampling interval to 1200.

    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] netstream sampler random-packets 1200 inbound
    [*SwitchA-10GE1/0/1] netstream sampler random-packets 1200 outbound
    [*SwitchA-10GE1/0/1] quit
    

  3. Configure Layer 2 NetStream flow statistics export.

    # Set the source IP address of the exported packets carrying Layer 2 NetStream flow statistics to 10.1.2.1, destination IP address to 10.1.2.2, and destination port number to 6000.

    [*SwitchA] netstream export ethernet source 10.1.2.1
    [*SwitchA] netstream export ethernet host 10.1.2.2 6000

  4. Configure the version for exported packets.

    # Set the version of exported packets to V9.

    [*SwitchA] netstream export ethernet version 9

  5. Enable Layer 2 statistics collection on the interface.

    # Enable NetStream statistics collection on 10GE1/0/1 for incoming and outgoing packets.

    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] netstream inbound ethernet
    [*SwitchA-10GE1/0/1] netstream outbound ethernet
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

  6. Verify the configuration.

    # View flow statistics.

    [~SwitchA] display netstream statistics ethernet slot 1
     Time statistics were last cleared: -                                           
     -------------------------------------------------------------------------------
     Packet Length    : Number                                                      
     -------------------------------------------------------------------------------
     1      ~    64   : 0                                                           
     65     ~    128  : 20                                                          
     129    ~    256  : 0                                                           
     257    ~    512  : 0                                                          
     513    ~    1024 : 0                                                           
     1025   ~    1500 : 0                                                           
     longer than 1500 : 0                                                           
     -------------------------------------------------------------------------------
     StreamType                                                                     
          Current           Aged        Created       Exported       Exported       
          (streams)         (streams)   (streams)     (streams)      (Packets)      
     -------------------------------------------------------------------------------
     ethernet                                                                       
                1             15             15             15             15       
     -------------------------------------------------------------------------------
    

Configuration Files

SwitchA configuration file

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 110 120 130 140 
# 
netstream export ethernet version 9                                             
netstream export ethernet source 10.1.2.1                                       
netstream export ethernet host 10.1.2.2 6000    
#                                                                               
interface Vlanif110                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif120                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif130                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif140                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                                
interface 10GE1/0/1                                                 
 port link-type trunk                                                           
 port trunk pvid vlan 110                                                       
 port trunk allow-pass vlan 110 
 netstream inbound ethernet                                                      
 netstream outbound ethernet                                                     
 netstream sampler random-packets 1200 inbound                         
 netstream sampler random-packets 1200 outbound 
#                                                                               
interface 10GE2/0/1                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 120                                                       
 port trunk allow-pass vlan 120  
#                                                                               
interface 10GE3/0/1                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 130                                                       
 port trunk allow-pass vlan 130 
#                                                                               
interface 10GE4/0/1                                                  
 port link-type trunk                                                           
 port trunk pvid vlan 140                                                       
 port trunk allow-pass vlan 140 
#                                                                               
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 28261

Downloads: 29

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next