No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, sFlow, and NETCONF.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a TCP Test Instance

Example for Configuring a TCP Test Instance

Networking Requirements

The NQA TCP test instance is used to obtain the time for setting up a TCP connection between SwitchA and SwitchC, as shown in the Figure 7-13.

Figure 7-13 Networking diagram for configuring a TCP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client and SwtichC as an NQA server.

  2. Configure the monitoring port number on the NQA server and create an NQA TCP test instance on the NQA client.

Procedure

  1. Configure each interface and ensure reachable routes between Switches, as shown in Figure 7-13.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] quit
    [*SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    [*SwitchA] commit

  2. Configure the NQA server on SwitchC.

    # Configure the IP address and port number for monitoring TCP connections on the NQA server.

    <SwitchC> system-view
    [~SwitchC] nqa server tcpconnect 10.2.1.2 9000
    [*SwitchC] commit

  3. Configure SwitchA.

    # Enable the NQA client and create a TCP Private test instance.

    [~SwitchA] nqa test-instance admin tcp
    [*SwitchA-nqa-admin-tcp] test-type tcp
    [*SwitchA-nqa-admin-tcp] destination-address ipv4 10.2.1.2
    [*SwitchA-nqa-admin-tcp] destination-port 9000 
    [*SwitchA-nqa-admin-tcp] commit 

  4. Start the test instance.

    [~SwitchA-nqa-admin-tcp] start now
    [*SwitchA-nqa-admin-tcp] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-tcp] display nqa results test-instance admin tcp
                                                                                    
    NQA entry(admin, tcp): test flag is active,test type is TCP                      
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3                Receive response times: 3             
       Completion:success                     RTD over thresholds number:0           
       Attempts number:1                      Drop operation number:0               
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT Status errors number:0             
       Destination IP address:10.2.1.2                                             
       Min/Max/Average completion time: 103/133/114                                 
       Sum/Square-Sum  completion time: 343/39747                                   
       Last response packet receiving time: 2012-08-09 00:24:06.1                                  
       Lost packet ratio: 0 %                            

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
     ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin tcp
     test-type tcp
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
     nqa server tcpconnect 10.2.1.2 9000
    #
     ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075344

Views: 19781

Downloads: 22

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next