No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of VPN, including GRE, BGP/MPLS IP VPN, BGP/MPLS IPv6 VPN, VLL, PWE3, and VPLS.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring CE Dual-homing

Example for Configuring CE Dual-homing

Networking Requirements

It is a trend to transmit all telecommunication services over the same IP network. Key services such 3rd Generation (3G)/next generation network (NGN), Internet Protocol television (IPTV) streaming media, and VPN services require high network reliability. The reliability of networks can be ensured at three levels: device-level, link-level, and network-level, through methods such as fast route convergence, fault detection, fast reroute, and route backup.

At the access layer, the CE dual-homing networking is a common method to improve the network reliability. A dual-homed CE device connects to two PE devices that belong to the same VPN. In this networking, the CE device connects to the backbone network through two links. The two links work in load balancing mode or active/standby mode.

As shown in Figure 2-51, CE1 is located in site1 of vpn1, and CE2 is located in site2 of vpn1. CE1 connects to PE1 and PE2, and CE2 connects to PE3 and PE4.

If the data traffic volume from CE1 to CE2 is large but traffic volume from CE2 to CE1 is small, the data traffic from CE1 to CE2 can be transmitted in load balancing mode. The data traffic from CE2 to CE1 is transmitted through PE4, and PE3 only works as a backup.

Figure 2-51 CE dual-homing networking

Devices, interfaces, and IP addresses

  • PE1



  • PE2



  • PE3



  • PE4



  • P1



  • P2



  • CE1



  • CE2



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic BGP/MPLS IP VPN functions.

  2. In the BGP view of CE1, configure load balancing for traffic sent to CE2.

  3. Increase the MED value of the BGP-VPN route on PE3 to ensure that the next hop in the route selected by CE2 to the customer network connected to CE1 is PE4.

Procedure

  1. Configure an IGP protocol on the MPLS backbone network so that the PE and P devices can communicate with each other.

    # Configure PE1.

    # Set IP addresses of interfaces. The IP addresses of the loopback interfaces must use a 32-bit mask.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface loopback 1
    [*PE1-LoopBack1] ip address 1.1.1.1 32
    [*PE1-LoopBack1] quit
    [*PE1] interface vlanif 10
    [*PE1-Vlanif10] ip address 100.1.1.1 30
    [*PE1-Vlanif10] quit
    [*PE1] commit

    # Configure the IS-IS protocol to advertise routes of the interfaces.

    [~PE1] isis 1
    [*PE1-isis-1] network-entity 10.0000.0000.0001.00
    [*PE1-isis-1] quit
    [*PE1] interface loopback 1
    [*PE1-LoopBack1] isis enable 1
    [*PE1-LoopBack1] quit
    [*PE1] interface vlanif 10
    [*PE1-Vlanif10] isis enable 1
    [*PE1-Vlanif10] quit
    [*PE1] commit

    The configurations of PE2, PE3, PE4, P1, and P2 are the same as that of PE1.

    After the configuration is complete, run the display ip routing-table command. You can see that PE1 and PE3 can learn the routes of Loopback1 interface of each other; PE2 and PE4 can learn routes of Loopback1 interface of each other.

  2. Enable basic MPLS capabilities and MPLS LDP on the PE and P devices to set LDP LSPs over the MPLS backbone network.

    # Configure PE1.

    # Enable MPLS and LDP in the system view, set the LSR ID to the IP address of the loopback interface, and trigger the LSP establishment.

    [~PE1] mpls lsr-id 1.1.1.1
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] commit

    # Enable MPLS and LDP on the interface connected to the backbone network.

    [~PE1] interface vlanif 10
    [*PE1-Vlanif10] mpls
    [*PE1-Vlanif10] mpls ldp
    [*PE1-Vlanif10] quit
    [*PE1] commit

    # The configurations of PE2, PE3, PE4, P1, and P2 are the same as that of PE1.

    After the configuration is complete, LDP sessions can be set up between PE1 and P, and between PE2 and P. Run the display mpls ldp session command, and you can see that the status of the sessions is Operational. Run the display mpls ldp lsp command, and you can see that information about the established LDP LSPs is displayed.

    Take the display on PE1 as an example:

    [~PE1] display mpls ldp session
     LDP Session(s) in Public Network
     LAM: Label Advertisement Mode,  KA: KeepAlive
     SsnAge: Session Age, Unit(DDDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv 
     ------------------------------------------------------------------------------ 
     5.5.5.5:0          Operational DU   Passive  0000:07:02  1688/1688 
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    
    [~PE1] display mpls ldp lsp
     LDP LSP Information
     An asterisk (*) before an LSP means the LSP is not established
     An asterisk (*) before a Label means the USCB or DSCB is stale
     An asterisk (*) before a UpstreamPeer means the session is in GR state
     An asterisk (*) before a DS means the session is in GR state
     An asterisk (*) before a NextHop means the LSP is FRR LSP
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop          OutInterface
     -------------------------------------------------------------------------------
            1.1.1.1/32   3/NULL         5.5.5.5         127.0.0.1        Loop1
            3.3.3.3/32   NULL/1025      -               10.1.1.2         Vlanif10
            5.5.5.5/32   NULL/3         -               10.1.1.2         Vlanif10
     -------------------------------------------------------------------------------
     TOTAL: 3 Normal LSP(s) Found, 0 Liberal LSP(s) Found
            0 FRR LSP(s) Found.
    

  3. Configure VPN instances on PE devices and bind the instances to the interfaces connected to CE devices.

    # Configure PE1.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE device must match the VPN target of the MP-BGP peer PE device so that the sites of the same VPN can communicate with each other.

    [~PE1] ip vpn-instance vpn1
    [*PE1-vpn-instance-vpn1] ipv4-family
    [*PE1-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:1
    [*PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [*PE1-vpn-instance-vpn1-af-ipv4] quit
    [*PE1-vpn-instance-vpn1] quit
    [*PE1] commit

    # Bind the VPN instance to the interface connected to CE1 and set the IP address of the interface.

    [~PE1] interface vlanif 101
    [*PE1-Vlanif101] ip binding vpn-instance vpn1
    [*PE1-Vlanif101] ip address 10.1.1.2 30
    [*PE1-Vlanif101] quit
    [*PE1] commit

    # Configure PE2.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE device must match the VPN target of the MP-BGP peer PE device so that the sites of the same VPN can communicate with each other.

    [~PE2] ip vpn-instance vpn1
    [*PE2-vpn-instance-vpn1] ipv4-family
    [*PE2-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:2
    [*PE2-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [*PE2-vpn-instance-vpn1-af-ipv4] quit
    [*PE2-vpn-instance-vpn1] quit
    [*PE2] commit

    # Bind the VPN instance to the interface connected to CE1 and set the IP address of the interface.

    [~PE2] interface vlanif 102
    [*PE2-Vlanif102] ip binding vpn-instance vpn1
    [*PE2-Vlanif102] ip address 10.2.1.2 30
    [*PE2-Vlanif102] quit
    [*PE2] commit

    # Configure PE3.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE device must match the VPN target of the MP-BGP peer PE device so that the sites of the same VPN can communicate with each other.

    [~PE3] ip vpn-instance vpn1
    [*PE3-vpn-instance-vpn1] ipv4-family
    [*PE3-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:3
    [*PE3-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [*PE3-vpn-instance-vpn1-af-ipv4] quit
    [*PE3-vpn-instance-vpn1] quit
    [*PE3] commit

    # Bind the VPN instance to the interface connected to CE2 and set the IP address of the interface.

    [~PE3] interface vlanif 103
    [*PE3-Vlanif103] ip binding vpn-instance vpn1
    [*PE3-Vlanif103] ip address 10.3.1.1 30
    [*PE3-Vlanif103] quit
    [*PE3] commit

    # Configure PE4.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE device must match the VPN target of the MP-BGP peer PE device so that the sites of the same VPN can communicate with each other.

    [~PE4] ip vpn-instance vpn1
    [*PE4-vpn-instance-vpn1] ipv4-family
    [*PE4-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:4
    [*PE4-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [*PE4-vpn-instance-vpn1-af-ipv4] quit
    [*PE4-vpn-instance-vpn1] quit
    [*PE4] commit

    # Bind the VPN instance to the interface connected to CE2 and set the IP address of the interface.

    [~PE4] interface vlanif 104
    [*PE4-Vlanif104] ip binding vpn-instance vpn1
    [*PE4-Vlanif104] ip address 10.4.1.1 30
    [*PE4-Vlanif104] quit
    [*PE4] commit

    # Assign IP addresses to the interfaces on the CE devices according to Figure 2-51. The configuration command is not provided here.

    After the configuration is complete, run the display ip vpn-instance verbose command on the PE devices to view the configuration of VPN instances.

    Take the display on PE1 as an example:

    [~PE1] display ip vpn-instance verbose
      Total VPN-Instances configured : 1
      Total IPv4 VPN-Instances configured : 1    
      Total IPv6 VPN-Instances configured : 0   
    
      VPN-Instance Name and ID : vpn1, 1
       Interfaces : Vlanif101      
      Address family IPv4                      
      Create date : 2012-08-16 16:48:30+08:00                                       
      Up time : 2 days, 07 hours, 54 minutes and 36 seconds  
      Vrf Status : UP
      Route Distinguisher : 100:1
      Export VPN Targets :  1:1
      Import VPN Targets :  1:1
      Label Policy : label per instance  
    

  4. Set up MP-IBGP peer relationships between the PE devices.

    # Configure PE1.

    # Specify PE3 as the IBGP peer and use the IP address of the loopback interface to set up an IBGP connection with the peer.

    [~PE1] bgp 100
    [*PE1-bgp] peer 3.3.3.3 as-number 100
    [*PE1-bgp] peer 3.3.3.3 connect-interface loopback 1
    [*PE1-bgp] commit

    # Enter the BGP-VPNv4 address family view and enable the local PE device to exchange VPN routing information with the IGBP peer.

    [~PE1-bgp] ipv4-family vpnv4
    [*PE1-bgp-af-vpnv4] peer 3.3.3.3 enable
    [*PE1-bgp-af-vpnv4] commit
    [~PE1-bgp-af-vpnv4] quit
    [~PE1-bgp] quit

    # Configure PE3.

    # Specify PE1 as the IBGP peer and use the IP address of the loopback interface to set up an IBGP connection with the peer.

    [~PE3] bgp 100
    [*PE3-bgp] peer 1.1.1.1 as-number 100
    [*PE3-bgp] peer 1.1.1.1 connect-interface loopback 1
    [*PE3-bgp] commit

    # Enter the BGP-VPN address family view and enable the local PE device to exchange VPN routing information with the IBGP peer.

    [~PE3-bgp] ipv4-family vpnv4
    [*PE3-bgp-af-vpnv4] peer 1.1.1.1 enable
    [*PE3-bgp-af-vpnv4] commit
    [~PE3-bgp-af-vpnv4] quit
    [~PE3-bgp] quit

    # Configure PE2.

    # Specify PE4 as the IBGP peer and use the IP address of the loopback interface to set up an IBGP connection with the peer.

    [~PE2] bgp 100
    [*PE2-bgp] peer 4.4.4.4 as-number 100
    [*PE2-bgp] peer 4.4.4.4 connect-interface loopback 1
    [*PE2-bgp] commit

    # Enter the BGP-VPNv4 address family view and enable the local PE device to exchange VPN routing information with the IBGP peer.

    [~PE2-bgp] ipv4-family vpnv4
    [*PE2-bgp-af-vpnv4] peer 4.4.4.4 enable
    [*PE2-bgp-af-vpnv4] commit
    [~PE2-bgp-af-vpnv4] quit
    [~PE2-bgp] quit

    # Configure PE4.

    # Specify PE2 as the IBGP peer and use the IP address of the loopback interface to set up an IBGP connection with the peer.

    [~PE4] bgp 100
    [*PE4-bgp] peer 2.2.2.2 as-number 100
    [*PE4-bgp] peer 2.2.2.2 connect-interface loopback 1
    [*PE4-bgp] commit

    # Enter the BGP-VPN address family view and enable the local PE device to exchange VPN routing information with the IBGP peer.

    [~PE4-bgp] ipv4-family vpnv4
    [*PE4-bgp-af-vpnv4] peer 2.2.2.2 enable
    [*PE4-bgp-af-vpnv4] commit
    [~PE4-bgp-af-vpnv4] quit
    [~PE4-bgp] quit

    After the configuration is complete, run the display bgp vpnv4 all peer command on the PE devices. You can see that the BGP peer relationships have been set up between the PE devices and are in Established state.

    Take the display on PE1 as an example:

    [~PE1] display bgp vpnv4 all peer
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      3.3.3.3         4   100       70       81     0 01:00:23 Established       3
    

  5. Configure EBGP between the PE and CE devices to import the VPN routes.

    # Configure CE1.

    # Enable BGP, specify PE1 and PE2 as EBGP peers, and import direct routes.

    [~CE1] bgp 65410
    [*CE1-bgp] peer 10.1.1.2 as-number 100
    [*CE1-bgp] peer 10.2.1.2 as-number 100
    [*CE1-bgp] import-route direct
    [*CE1-bgp] quit
    [*CE1] commit
    

    # Configure PE1.

    # Enable BGP, specify CE1 as the EBGP peer, and import direct routes.

    [~PE1] bgp 100
    [~PE1-bgp] ipv4-family vpn-instance vpn1
    [*PE1-bgp-vpn1] peer 10.1.1.1 as-number 65410
    [*PE1-bgp-vpn1] import-route direct
    [*PE1-bgp-vpn1] quit
    [*PE1] commit

    # Configure PE2.

    # Enable BGP, specify CE1 as the EBGP peer, and import direct routes.

    [~PE2] bgp 100
    [~PE2-bgp] ipv4-family vpn-instance vpn1
    [*PE2-bgp-vpn1] peer 10.2.1.1 as-number 65410
    [*PE2-bgp-vpn1] import-route direct
    [*PE2-bgp-vpn1] quit
    [*PE2] commit

    # Configure CE2.

    # Enable BGP, specify PE3 and PE4 as EBGP peers, and import direct routes.

    [~CE2] bgp 65420
    [*CE2-bgp] peer 10.3.1.1 as-number 100
    [*CE2-bgp] peer 10.4.1.1 as-number 100
    [*CE2-bgp] import-route direct
    [*CE2-bgp] quit
    [*CE2] commit
    

    # Configure PE3.

    # Enable BGP, specify CE2 as the EBGP peer, and import direct routes.

    [~PE3] bgp 100
    [~PE3-bgp] ipv4-family vpn-instance vpn1
    [*PE3-bgp-vpn1] peer 10.3.1.2 as-number 65420
    [*PE3-bgp-vpn1] import-route direct
    [*PE3-bgp-vpn1] quit
    [*PE3] commit

    # Configure PE4.

    # Enable BGP, specify CE2 as the EBGP peer, and import direct routes.

    [~PE4] bgp 100
    [~PE4-bgp] ipv4-family vpn-instance vpn1
    [*PE4-bgp-vpn1] peer 10.4.1.2 as-number 65420
    [*PE4-bgp-vpn1] import-route direct
    [*PE4-bgp-vpn1] quit
    [*PE4] commit

    After the configuration is complete, run the display bgp vpnv4 vpn-instance vpn-instancename peer command on the PE devices. You can see that the BGP peer relationships have been set up between the PE and CE devices and are in Established state. Each PE device can ping its local CE device.

    Take the display on PE1 as an example:

    [~PE1] display bgp vpnv4 vpn-instance vpn1 peer
    
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     
     VPN-Instance vpn1, router ID 1.1.1.1:   
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      10.1.1.1        4 65410      408      435     0 06:16:09 Established       5
    
    [~PE1] ping -vpn-instance vpn1 10.1.1.1
      PING 10.1.1.1 : 56  data bytes, press CTRL_C to break
          Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=80 ms
          Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=20 ms
          Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=30 ms
          Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=50 ms
          Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=30 ms
    
      --- 10.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 20/42/80 ms

  6. On CE1, configure load balancing for the traffic sent from CE1 to CE2.

    [~CE1] bgp 65410
    [~CE1-bgp] ipv4-family unicast
    [~CE1-bgp-af-ipv4] maximum load-balancing 2
    [*CE1-bgp-af-ipv4] commit
    [~CE1-bgp-af-ipv4] quit
    [~CE1-bgp] quit

  7. Configure a routing policy on PE3 to increase the MED value of the BGP routes advertised to CE2. Then the traffic sent from CE2 to CE1 is forwarded by PE4, and PE3 is a backup of PE4.

    [~PE3] route-policy policy1 permit node 10
    [*PE3-route-policy] apply cost 120
    [*PE3-route-policy] quit
    [*PE3] bgp 100
    [*PE3-bgp] ipv4-family vpn-instance vpn1
    [*PE3-bgp-vpn1] peer 10.3.1.2 route-policy policy1 export
    [*PE3-bgp-vpn1] commit
    [~PE3-bgp-vpn1] quit
    [~PE3-bgp] quit

    Check the BGP routing table of CE2. In the routing table, the route to 10.5.1.0/30 advertised by PE3 has a MED value of 120, larger than the MED value of the route advertised by PE4 (the default MED value is 0). Therefore, CE2 selects the route advertised by PE4.

  8. Verify the configuration.

    If the configuration is successful:

    The display ip routing-table command on CE1 displays the routes to the customer network connected to CE2. The routes work in load balancing mode.

    [~CE1] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 16       Routes : 17
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/30  Direct 0    0             D  10.1.1.1        Vlanif101
           10.1.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif101
           10.1.1.3/32  Direct 0    0             D  127.0.0.1       Vlanif101
           10.2.1.0/30  Direct 0    0             D  10.2.1.1        Vlanif102
           10.2.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif102
           10.2.1.3/32  Direct 0    0             D  127.0.0.1       Vlanif102
           10.3.1.0/30  EBGP   255  0             D  10.1.1.2        Vlanif101
           10.4.1.0/30  EBGP   255  0             D  10.2.1.2        Vlanif102
           10.5.1.0/24  Direct 0    0             D  10.5.1.1        Vlanif1001
           10.5.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif1001
         10.5.1.255/32  Direct 0    0             D  127.0.0.1       Vlanif1001
           10.6.1.0/24  EBGP   255  0             D  10.1.1.2        Vlanif101
                        EBGP   255  0             D  10.2.1.2        Vlanif102
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    

    The display ip routing-table command on CE2 displays the routes to the customer network connected to CE1. The next hop in the EBGP route is 10.4.1.1, which is the IP address of the interface connecting PE4 to CE2.

    [~CE2] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 16       Routes : 16
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/30  EBGP   255  120           D  10.3.1.1        Vlanif103
           10.2.1.0/30  EBGP   255  0             D  10.4.1.1        Vlanif104
           10.3.1.0/30  Direct 0    0             D  10.3.1.2        Vlanif103
           10.3.1.2/32  Direct 0    0             D  127.0.0.1       Vlanif103
           10.3.1.3/32  Direct 0    0             D  127.0.0.1       Vlanif103
           10.4.1.0/30  Direct 0    0             D  10.4.1.2        Vlanif104
           10.4.1.2/32  Direct 0    0             D  127.0.0.1       Vlanif104
           10.4.1.3/32  Direct 0    0             D  127.0.0.1       Vlanif104
           10.5.1.0/24  EBGP   255  0             D  10.4.1.1        Vlanif104
           10.6.1.0/24  Direct 0    0             D  10.6.1.1        Vlanif1002
           10.6.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif1002
         10.6.1.255/32  Direct 0    0             D  127.0.0.1       Vlanif1002
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 101 102 1001
    #
    interface Vlanif101
     ip address 10.1.1.1 255.255.255.252
    #
    interface Vlanif102
     ip address 10.2.1.1 255.255.255.252
    #
    interface Vlanif1001
     ip address 10.5.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE3/0/3
     port link-type trunk
     port trunk allow-pass vlan 1001
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      import-route direct
      maximum load-balancing 2
      peer 10.1.1.2 enable
      peer 10.2.1.2 enable
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 10 101
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 100.1.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif101
     ip binding vpn-instance vpn1
     ip address 10.1.1.2 255.255.255.252
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.1.1.1 as-number 65410
      import-route direct
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 20 102
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 100.2.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif102
     ip binding vpn-instance vpn1
     ip address 10.2.1.2 255.255.255.252
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 4.4.4.4 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 4.4.4.4 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.2.1.1 as-number 65410
      import-route direct
    #
    return
  • P1 configuration file

    #
    sysname P1
    #
    vlan batch 10 30
    #
    mpls lsr-id 5.5.5.5
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     network-entity 10.0000.0000.0005.00
    #
    interface Vlanif10
     ip address 100.1.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 100.3.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
     isis enable 1
    #
    return
  • P2 configuration file

    #
    sysname P2
    #
    vlan batch 20 40
    #
    mpls lsr-id 6.6.6.6
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     network-entity 10.0000.0000.0006.00
    #
    interface Vlanif20
     ip address 100.2.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 100.4.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack1
     ip address 6.6.6.6 255.255.255.255
     isis enable 1
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    vlan batch 30 103
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:3
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif30
     ip address 100.3.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif103
     ip binding vpn-instance vpn1
     ip address 10.3.1.1 255.255.255.252
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.3.1.2 as-number 65420
      peer 10.3.1.2 route-policy policy1 export
      import-route direct
    #
    route-policy policy1 permit node 10
     apply cost 120
    #
    return
  • PE4 configuration file

    #
    sysname PE4
    #
    vlan batch 40 104
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:4
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 4.4.4.4
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif40
     ip address 100.4.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif 104
     ip binding vpn-instance vpn1
     ip address 10.4.1.1 255.255.255.252
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 2.2.2.2 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.4.1.2 as-number 65420
      import-route direct
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 103 104 1002
    #
    interface Vlanif103
     ip address 10.3.1.2 255.255.255.252
    #
    interface Vlanif104
     ip address 10.4.1.2 255.255.255.252
    #
    interface Vlanif1002
     ip address 10.6.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE3/0/3
     port link-type trunk
     port trunk allow-pass vlan 1002
    #
    bgp 65420
     peer 10.3.1.1 as-number 100
     peer 10.4.1.1 as-number 100
     #
     ipv4-family unicast
      import-route direct
      peer 10.3.1.1 enable
      peer 10.4.1.1 enable
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075353

Views: 14093

Downloads: 25

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next