No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of VPN, including GRE, BGP/MPLS IP VPN, BGP/MPLS IPv6 VPN, VLL, PWE3, and VPLS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Hub and Spoke

Example for Configuring Hub and Spoke

Networking Requirements

A bank wants to realize secure communication between its headquarters and branches through MPLS VPN. VPN traffic from branches passes the headquarters so that the headquarters can monitor the traffic. The Hub and Spoke networking can meet the bank's needs. As shown in Figure 2-44, the Spoke-CE devices connect to branches of the bank, and the Hub-CE device connects to the headquarters. All traffic transmitted between Spoke-CE devices is forwarded by the Hub-CE device.

Figure 2-44 Hub and Spoke networking

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP protocol on the backbone network to enable the Hub-PE and Spoke-PE devices to communicate with each other.
  2. Enable basic MPLS capabilities and MPLS LDP on the backbone network to set up LDP LSPs.
  3. Set up MP-IBGP peer relationships between the Hub-PE and the Spoke-PE devices. The Spoke-PE devices do not need to set up an MP-IBGP peer relationship or exchange VPN routing information.

  4. Create two VPN instances on the Hub-PE device. One is used to receive routes from Spoke-PE devices, and the other is used to advertise routes to the Spoke-PE devices. Set import target of the first VPN instance to 100:1 and the export target of the other VPN instance to 200:1.

  5. Create a VPN instance on the Spoke-PE devices. Set the export target of the VPN instance to 100:1 and the import target to 200:1.

  6. Configure EBGP on the CE and PE devices to enable them to exchange VPN routing information. On the Hub-PE device, set the number of AS number repetitions to 1 so that the Hub-PE device accepts routes advertised by the Hub-CE device.

Procedure

  1. Configure OSPF on the backbone network to enable the Hub-PE and Spoke-PE devices to communicate with each other.

    # Configure Spoke-PE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Spoke-PE1
    [*HUAWEI] commit
    [~Spoke-PE1] interface loopback 1
    [*Spoke-PE1-LoopBack1] ip address 1.1.1.9 32
    [*Spoke-PE1-LoopBack1] quit
    [*Spoke-PE1] vlan batch 10 50
    [*Spoke-PE1] interface 10ge 2/0/2
    [*Spoke-PE1-10GE2/0/2] port link-type trunk
    [*Spoke-PE1-10GE2/0/2] port trunk allow-pass vlan 10
    [*Spoke-PE1-10GE2/0/2] quit
    [*Spoke-PE1] interface 10ge 1/0/1
    [*Spoke-PE1-10GE1/0/1] port link-type trunk
    [*Spoke-PE1-10GE1/0/1] port trunk allow-pass vlan 50 
    [*Spoke-PE1-10GE1/0/1] quit
    [*Spoke-PE1] interface vlanif 10
    [*Spoke-PE1-Vlanif10] ip address 8.1.1.1 24
    [*Spoke-PE1-Vlanif10] quit
    [*Spoke-PE1] ospf 1
    [*Spoke-PE1-ospf-1] area 0
    [*Spoke-PE1-ospf-1-area-0.0.0.0] network 8.1.1.0 0.0.0.255
    [*Spoke-PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*Spoke-PE1-ospf-1-area-0.0.0.0] quit
    [*Spoke-PE1-ospf-1] quit
    [*Spoke-PE1] commit

    The configurations of Hub-PE and Spoke-PE2 are the same as that of Spoke-PE1.

    After the configuration is complete, Hub-PE can establish OSPF neighbor relationships with the Spoke-PE devices. Run the display ospf peer command on the PE devices. You can see that the status of OSPF neighbor relationships is Full. Run the display ip routing-table command, and you can see that the Hub-PE and Spoke-PE devices have learned the route to the loopback interface of each other.

  2. Enable basic MPLS capabilities and MPLS LDP on the PE devices to set up LDP LSPs over the backbone network.

    # Configure the Hub-PE device.

    [~Hub-PE] mpls lsr-id 2.2.2.9
    [*Hub-PE] mpls
    [*Hub-PE-mpls] label advertise non-null
    [*Hub-PE-mpls] quit
    [*Hub-PE] mpls ldp
    [*Hub-PE-mpls-ldp] quit
    [*Hub-PE] interface vlanif 10
    [*Hub-PE-Vlanif10] mpls
    [*Hub-PE-Vlanif10] mpls ldp
    [*Hub-PE-Vlanif10] quit
    [*Hub-PE] interface vlanif 20
    [*Hub-PE-Vlanif20] mpls
    [*Hub-PE-Vlanif20] mpls ldp
    [*Hub-PE-Vlanif20] quit
    [*Hub-PE] commit

    # The configurations of the Spoke-PE devices are the same as that of the Hub-PE device.

    After the configuration is complete, the Hub-PE device can set up LDP peer relationships with the Spoke-PE devices. Run the display mpls ldp session command on the PE devices, and you can see that the State field is Operational. Run the display mpls ldp lsp command, and information about the established LDP LSPs is displayed.

  3. Configure VPN instances on the PE devices and bind the instances to interfaces connected to CE devices.

    NOTE:

    The import target of the VPN instances on the Hub-PE device is the export target of the VPN instance on the Spoke-PE devices. The import target and export target on the Hub-PE device are different. The import VPN target on the Spoke-PE devices is the export VPN target on the Hub-PE device.

    # Configure Spoke-PE1.

    [~Spoke-PE1] ip vpn-instance vpna
    [*Spoke-PE1-vpn-instance-vpna] ipv4-family
    [*Spoke-PE1-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [*Spoke-PE1-vpn-instance-vpna-af-ipv4] vpn-target 100:1 export-extcommunity
    [*Spoke-PE1-vpn-instance-vpna-af-ipv4] vpn-target 200:1 import-extcommunity
    [*Spoke-PE1-vpn-instance-vpna-af-ipv4] quit
    [*Spoke-PE1-vpn-instance-vpna] quit
    [*Spoke-PE1] interface vlanif 50
    [*Spoke-PE1-Vlanif50] ip binding vpn-instance vpna
    [*Spoke-PE1-Vlanif50] ip address 10.1.1.2 24
    [*Spoke-PE1-Vlanif50] quit
    [*Spoke-PE1] commit

    #Configure Spoke-PE2.

    [~Spoke-PE2] ip vpn-instance vpna
    [*Spoke-PE2-vpn-instance-vpna] ipv4-family
    [*Spoke-PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 100:3
    [*Spoke-PE2-vpn-instance-vpna-af-ipv4] vpn-target 100:1 export-extcommunity
    [*Spoke-PE2-vpn-instance-vpna-af-ipv4] vpn-target 200:1 import-extcommunity
    [*Spoke-PE2-vpn-instance-vpna-af-ipv4] quit
    [*Spoke-PE2-vpn-instance-vpna] quit
    [*Spoke-PE2] interface vlanif 60
    [*Spoke-PE2-Vlanif60] ip binding vpn-instance vpna
    [*Spoke-PE2-Vlanif60] ip address 10.4.1.2 24
    [*Spoke-PE2-Vlanif60] quit
    [*Spoke-PE2] commit

    # Configure the Hub-PE device.

    [~Hub-PE] ip vpn-instance vpn_in
    [*Hub-PE-vpn-instance-vpn_in] ipv4-family
    [*Hub-PE-vpn-instance-vpn_in-af-ipv4] route-distinguisher 100:21
    [*Hub-PE-vpn-instance-vpn_in-af-ipv4] vpn-target 100:1 import-extcommunity
    [*Hub-PE-vpn-instance-vpn_in-af-ipv4] quit
    [*Hub-PE-vpn-instance-vpn_in] quit
    [*Hub-PE] ip vpn-instance vpn_out
    [*Hub-PE-vpn-instance-vpn_out] ipv4-family
    [*Hub-PE-vpn-instance-vpn_out-af-ipv4] route-distinguisher 100:22
    [*Hub-PE-vpn-instance-vpn_out-af-ipv4] vpn-target 200:1 export-extcommunity
    [*Hub-PE-vpn-instance-vpn_out-af-ipv4] quit
    [*Hub-PE-vpn-instance-vpn_out] quit
    [*Hub-PE] interface vlanif 30
    [*Hub-PE-Vlanif30] ip binding vpn-instance vpn_in
    [*Hub-PE-Vlanif30] ip address 10.2.1.2 24
    [*Hub-PE-Vlanif30] quit
    [*Hub-PE] interface vlanif 40
    [*Hub-PE-Vlanif40] ip binding vpn-instance vpn_out
    [*Hub-PE-Vlanif40] ip address 10.3.1.2 24
    [*Hub-PE-Vlanif40] quit
    [*Hub-PE] commit

    # Configure IP addresses for the CE interfaces. The configuration procedure is not provided here.

    After the configuration is complete, run the display ip vpn-instance verbose command on the PE devices to view the configuration of VPN instances. Each PE device can ping its connected CE by using the ping -vpn-instance vpn-name ip-address command.

    NOTE:

    If a PE device has multiple interfaces bound to the same VPN instance, specify a source IP addresses by setting -a source-ip-address in the ping -vpn-instance vpn-instance-name -a source-ip-address dest-ip-address command to ping a remote CE device. If the source IP address is not specified, the ping operation fails.

  4. Set up EBGP peer relationships between the PE and CE devices and import VPN routes into BGP.

    NOTE:

    To accept the routes advertised by the Hub-CE, set the AS number repetitions to 1 on the Hub-PE device.

    # Configure Spoke-CE1.

    [~Spoke-CE1] bgp 65410
    [*Spoke-CE1-bgp] peer 10.1.1.2 as-number 100
    [*Spoke-CE1-bgp] import-route direct
    [*Spoke-CE1-bgp] commit
    [~Spoke-CE1-bgp] quit

    # Configure Spoke-PE1.

    [~Spoke-PE1] bgp 100
    [*Spoke-PE1-bgp] ipv4-family vpn-instance vpna
    [*Spoke-PE1-bgp-vpna] peer 10.1.1.1 as-number 65410
    [*Spoke-PE1-bgp-vpna] import-route direct
    [*Spoke-PE1-bgp-vpna] commit
    [~Spoke-PE1-bgp-vpna] quit
    [~Spoke-PE1-bgp] quit

    # Configure Spoke-CE2.

    [~Spoke-CE2] bgp 65420
    [*Spoke-CE2-bgp] peer 10.4.1.2 as-number 100
    [*Spoke-CE2-bgp] import-route direct
    [*Spoke-CE2-bgp] commit
    [~Spoke-CE2-bgp] quit

    # Configure Spoke-PE2.

    [~Spoke-PE2] bgp 100
    [*Spoke-PE2-bgp] ipv4-family vpn-instance vpna
    [*Spoke-PE2-bgp-vpna] peer 10.4.1.1 as-number 65420
    [*Spoke-PE2-bgp-vpna] import-route direct
    [*Spoke-PE2-bgp-vpna] commit
    [~Spoke-PE2-bgp-vpna] quit
    [~Spoke-PE2-bgp] quit

    # Configure the Hub-CE device.

    [~Hub-CE] bgp 65430
    [*Hub-CE-bgp] peer 10.2.1.2 as-number 100
    [*Hub-CE-bgp] peer 10.3.1.2 as-number 100
    [*Hub-CE-bgp] import-route direct
    [*Hub-CE-bgp] commit
    [~Hub-CE-bgp] quit

    # Configure the Hub-PE device.

    [~Hub-PE] bgp 100
    [*Hub-PE-bgp] ipv4-family vpn-instance vpn_in
    [*Hub-PE-bgp-vpn_in] peer 10.2.1.1 as-number 65430
    [*Hub-PE-bgp-vpn_in] import-route direct
    [*Hub-PE-bgp-vpn_in] quit
    [*Hub-PE-bgp] ipv4-family vpn-instance vpn_out
    [*Hub-PE-bgp-vpn_out] peer 10.3.1.1 as-number 65430
    [*Hub-PE-bgp-vpn_out] peer 10.3.1.1 allow-as-loop 1
    [*Hub-PE-bgp-vpn_out] import-route direct
    [*Hub-PE-bgp-vpn_out] quit
    [*Hub-PE-bgp] quit
    [*Hub-PE] commit

    After the configuration is complete, run the display bgp vpnv4 all peer command on a PE device. You can see that the BGP peer relationships have been set up between the PE and CE devices and are in Established state.

  5. Set up MP-IBGP peer relationships between the Spoke-PE and Hub-PE devices.

    NOTE:

    The Spoke-PE devices do not need to allow the repeated AS number, because the switch does not check the AS_Path attribute in the routing information advertised by the IBGP peers.

    # Configure Spoke-PE1.

    [~Spoke-PE1] bgp 100
    [~Spoke-PE1-bgp] peer 2.2.2.9 as-number 100
    [*Spoke-PE1-bgp] peer 2.2.2.9 connect-interface loopback 1
    [*Spoke-PE1-bgp] ipv4-family vpnv4
    [*Spoke-PE1-bgp-af-vpnv4] peer 2.2.2.9 enable
    [*Spoke-PE1-bgp-af-vpnv4] commit
    [~Spoke-PE1-bgp-af-vpnv4] quit

    #Configure Spoke-PE2.

    [~Spoke-PE2] bgp 100
    [~Spoke-PE2-bgp] peer 2.2.2.9 as-number 100
    [*Spoke-PE2-bgp] peer 2.2.2.9 connect-interface loopback 1
    [*Spoke-PE2-bgp] ipv4-family vpnv4
    [*Spoke-PE2-bgp-af-vpnv4] peer 2.2.2.9 enable
    [*Spoke-PE2-bgp-af-vpnv4] commit
    [~Spoke-PE2-bgp-af-vpnv4] quit

    # Configure the Hub-PE device.

    [~Hub-PE] bgp 100
    [~Hub-PE-bgp] peer 1.1.1.9 as-number 100
    [*Hub-PE-bgp] peer 1.1.1.9 connect-interface loopback 1
    [*Hub-PE-bgp] peer 3.3.3.9 as-number 100
    [*Hub-PE-bgp] peer 3.3.3.9 connect-interface loopback 1
    [*Hub-PE-bgp] ipv4-family vpnv4
    [*Hub-PE-bgp-af-vpnv4] peer 1.1.1.9 enable
    [*Hub-PE-bgp-af-vpnv4] peer 3.3.3.9 enable
    [*Hub-PE-bgp-af-vpnv4] commit
    [~Hub-PE-bgp-af-vpnv4] quit

    After the configuration is complete, run the display bgp peer or display bgp vpnv4 all peer command on the PE devices. You can see that the BGP peer relationships have been set up between the Spoke-PE devices and the Hub-PE device and are in Established state.

  6. Verify the configuration.

    After the configuration is complete, the Spoke-CE devices can ping each other. Run the tracert command on the CE devices, and you can see that the traffic between the Spoke-CE devices is forwarded through the Hub-CE device. You can also calculate the number of forwarding devices between the Spoke-CE devices based on the TTL value in the ping result.

    Take the display on Spoke-CE1 as an example.

    [~Spoke-CE1] ping 10.4.1.1
      PING 10.4.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.4.1.1: bytes=56 Sequence=1 ttl=250 time=80 ms
        Reply from 10.4.1.1: bytes=56 Sequence=2 ttl=250 time=129 ms
        Reply from 10.4.1.1: bytes=56 Sequence=3 ttl=250 time=132 ms
        Reply from 10.4.1.1: bytes=56 Sequence=4 ttl=250 time=92 ms
        Reply from 10.4.1.1: bytes=56 Sequence=5 ttl=250 time=126 ms
      --- 10.4.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 80/111/132 ms 
    
    [~Spoke-CE1] tracert 10.4.1.1
     traceroute to 10.4.1.1(10.4.1.1), max hops: 30 ,packet length: 40,press CTRL_
    C to break                                                                      
     1 10.1.1.2 9 ms  2 ms  2 ms                                                   
     2 10.3.1.1 7 ms  2 ms  2 ms                                                   
     3 10.2.1.2 1 ms  2 ms  2 ms                                                   
     4 10.4.1.2 4 ms  5 ms  4 ms                                                   
     5 10.4.1.1 7 ms  2 ms  2 ms  

    Run the display bgp routing-table command on the Spoke-CE devices. You can see the repeated AS number in AS paths of the BGP routes to the remote Spoke-CE device.

    Take the display on Spoke-CE1 as an example.

    [~Spoke-CE1] display bgp routing-table
                                                                                                                                        
     BGP Local router ID is 10.1.1.1                                                                                                    
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
    
    
     Total Number of Routes: 6 
            Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>     2.2.2.9/32         10.1.1.2                             0      100 65430?
     *>     10.1.1.0/24       0.0.0.0         0                     0      ?
     *                         10.1.1.2       0                     0      100?
     *>     10.1.1.1/32       0.0.0.0         0                     0      ?
     *>     10.2.1.0/24        10.1.1.2                             0      100 65430?
     *>     10.3.1.0/24        10.1.1.2                             0      100?
     *>     10.4.1.0/24         10.1.1.2                             0      100 65430 100?

Configuration Files

  • Spoke-CE1 configuration file

    #
    sysname Spoke-CE1
    #
    vlan batch 50
    #
    interface Vlanif50
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
    #
     ipv4-family unicast
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • Spoke-PE1 configuration file

    #
    sysname Spoke-PE1
    #
    vlan batch 10 50
    #
    ip vpn-instance vpna
     ipv4-family 
      route-distinguisher 100:1
      vpn-target 100:1 export-extcommunity
      vpn-target 200:1 import-extcommunity
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     label advertise non-null
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 8.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif50
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #  
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
    #
     ipv4-family unicast
      peer 2.2.2.9 enable
    #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.9 enable
    #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.1.1.1 as-number 65410
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 8.1.1.0 0.0.0.255
    #
    return
  • Spoke-PE2 configuration file

    #
    sysname Spoke-PE2
    #
    vlan batch 20 60
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:3
      vpn-target 100:1 export-extcommunity
      vpn-target 200:1 import-extcommunity
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
     label advertise non-null
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif20
     ip address 11.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif60
     ip binding vpn-instance vpna
     ip address 10.4.1.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
    #
     ipv4-family unicast
      peer 2.2.2.9 enable
    #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.9 enable
    #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.4.1.1 as-number 65420
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 11.1.1.0 0.0.0.255
    #
    return
  • Spoke-CE2 configuration file

    #
    sysname Spoke-CE2
    #
    vlan batch 60
    #
    interface Vlanif60
     ip address 10.4.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    bgp 65420
     peer 10.4.1.2 as-number 100
    #
     ipv4-family unicast
      import-route direct
      peer 10.4.1.2 enable
    #
    return
  • Hub-CE configuration file

    #
    sysname Hub-CE
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ip address 10.2.1.1 255.255.255.0
    #
    interface Vlanif40
     ip address 10.3.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    bgp 65430
     peer 10.2.1.2 as-number 100
     peer 10.3.1.2 as-number 100
    #
     ipv4-family unicast
      import-route direct
      peer 10.2.1.2 enable
      peer 10.3.1.2 enable
    #
    return
  • Hub-PE configuration file

    #
    sysname Hub-PE
    #
    vlan batch 10 20 30 40
    #
    ip vpn-instance vpn_in
     ipv4-family
      route-distinguisher 100:21
      vpn-target 100:1 import-extcommunity
    #
    ip vpn-instance vpn_out
     ipv4-family
      route-distinguisher 100:22
      vpn-target 200:1 export-extcommunity
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
     label advertise non-null
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 8.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 11.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip binding vpn-instance vpn_in
     ip address 10.2.1.2 255.255.255.0
    #
    interface Vlanif40
     ip binding vpn-instance vpn_out
     ip address 10.3.1.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE3/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE4/0/4
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
    #
     ipv4-family unicast
      peer 1.1.1.9 enable
      peer 3.3.3.9 enable
    #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
      peer 3.3.3.9 enable
    #
     ipv4-family vpn-instance vpn_in
      import-route direct
      peer 10.2.1.1 as-number 65430
    #
     ipv4-family vpn-instance vpn_out
      import-route direct
      peer 10.3.1.1 as-number 65430
      peer 10.3.1.1 allow-as-loop
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 8.1.1.0 0.0.0.255
      network 11.1.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075353

Views: 14632

Downloads: 25

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next