Example for Configuring Basic RIPng Functions
Networking Requirements
As shown in Figure 4-1, it is required that RIPng be enabled on all interfaces of Switch A, Switch B, Switch C, and Switch D and the switches communicate through RIPng.
Configuration Notes
When configuring basic RIPng functions, note the following:
RIPng takes effect only after IPv6 is enabled on interfaces.
Enable RIPng on switches and configure RIPng basic functions.
Procedure
- Configure IPv6 addresses for interfaces. The configuration details are not described here.
- Configure basic RIPng functions.
# Configure Switch A.
[~SwitchA] ripng 1
[*SwitchA-ripng-1] quit
[*SwitchA] interface vlanif 100
[*SwitchA-Vlanif100] ipv6 enable
[*SwitchA-Vlanif100] ripng 1 enable
[*SwitchA-Vlanif100] quit
[*SwitchA] commit
# Configure Switch B.
[~SwitchB] ripng 1
[*SwitchB-ripng-1] quit
[*SwitchB] interface vlanif 100
[*SwitchB-Vlanif100] ipv6 enable
[*SwitchB-Vlanif100] ripng 1 enable
[*SwitchB-Vlanif100] quit
[*SwitchB] interface vlanif 200
[*SwitchB-Vlanif200] ipv6 enable
[*SwitchB-Vlanif200] ripng 1 enable
[*SwitchB-Vlanif200] quit
[*SwitchB] interface vlanif 300
[*SwitchB-Vlanif300] ipv6 enable
[*SwitchB-Vlanif300] ripng 1 enable
[*SwitchB-Vlanif300] quit
[*SwitchB] commit
# Configure Switch C.
[~SwitchC] ripng 1
[*SwitchC-ripng-1] quit
[*SwitchC] interface vlanif 200
[*SwitchC-Vlanif200] ipv6 enable
[*SwitchC-Vlanif200] ripng 1 enable
[*SwitchC-Vlanif200] quit
[*SwitchC] commit
# Configure Switch D.
[~SwitchD] ripng 1
[*SwitchD-ripng-1] quit
[*SwitchD] interface vlanif 300
[*SwitchD-Vlanif300] ipv6 enable
[*SwitchD-Vlanif300] ripng 1 enable
[*SwitchD-Vlanif300] quit
[*SwitchD] commit
- Verify the configuration.
# View RIPng neighbors of Switch A.
[~SwitchA] display ripng 1 neighbor
Neighbor : FE80::225:9EFF:FE01:21C Vlanif100 Protocol : RIPNG
The command output shows that Switch A has established the neighbor relationship with Switch B on the network.
# View RIPng routing information of Switch A.
[~SwitchA] display ripng 1 route
Route Flags: A - Aging, S - Suppressed, G - Garbage-collect ---------------------------------------------------------------------------- Peer FE80::225:9EFF:FE01:21C on Vlanif100 Dest FC00:0:0:2::/64, via FE80::225:9EFF:FE01:21C, cost 1, tag 0, A, 4 Sec Dest FC00:0:0:3::/64, via FE80::225:9EFF:FE01:21C, cost 1, tag 0, A, 4 Sec
The command output shows that Switch A has learned routing information on the network.
Configuration Files
Configuration file of Switch A
#
sysname SwitchA
#
vlan batch 100
#
interface Vlanif 100
ipv6 enable
ipv6 address FC00:0:0:1::1/64
ripng 1 enable
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 100
#
ripng 1
#
return
Configuration file of Switch B
#
sysname SwitchB
#
vlan batch 100 200 300
#
interface Vlanif 100
ipv6 enable
ipv6 address FC00:0:0:1::2/64
ripng 1 enable
#
interface Vlanif 200
ipv6 enable
ipv6 address FC00:0:0:2::1/64
ripng 1 enable
#
interface Vlanif 300
ipv6 enable
ipv6 address FC00:0:0:3::1/64
ripng 1 enable
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 100
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 200
#
interface 10GE1/0/3
port link-type trunk
port trunk allow-pass vlan 300
#
ripng 1
#
return
Configuration file of Switch C
#
sysname SwitchC
#
vlan batch 200
#
interface Vlanif 200
ipv6 enable
ipv6 address FC00:0:0:2::2/64
ripng 1 enable
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 200
#
ripng 1
#
return
Configuration file of Switch D
#
sysname SwitchD
#
vlan batch 300
#
interface Vlanif 300
ipv6 enable
ipv6 address FC00:0:0:3::2/64
ripng 1 enable
#
interface 10GE1/0/3
port link-type trunk
port trunk allow-pass vlan 300
#
ripng 1
#
return