Example for Configuring Basic IPv6 IS-IS Functions
Networking Requirements
As shown in Figure 8-3:
Switch A, Switch B, Switch C, and Switch D belong to the same AS. It is required that IS-IS run on them to implement IPv6 interworking.
Switch A, Switch B, and Switch C belong to Area 10, and Switch D belongs to Area 20.
Switch A and Switch B are Level-1 devices; Switch C is a Level-1-2 device; Switch D is a Level-2 device.
Configuration Roadmap
The configuration roadmap is as follows:
Enable the IPv6 forwarding capability on each Switch, and configure an IPv6 address for each interface.
Enable IS-IS, configure the level, and specify the NET on each Switch.
Procedure
- Configure VLANs that interfaces belong to.
<HUAWEI> system-view [~HUAWEI] sysname switchA [*HUAWEI] commit [~switchA] vlan batch 10 [*switchA] interface 10ge 1/0/1 [*switchA-10GE1/0/1] port link-type trunk [*switchA-10GE1/0/1] port trunk allow-pass vlan 10 [*switchA-10GE1/0/1] commit [~switchA-10GE1/0/1] quit
The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA. The detailed configurations are not provided here.
- Enable the IPv6 forwarding capability, and configure an IPv6 address for each interface. Take the display on Switch A as an example. The configurations of the other three Switches are the same as that of Switch A, and are not provided here.
[~switchA] interface vlanif 10 [~switchA-Vlanif10] ipv6 enable [*switchA-Vlanif10] ipv6 address FC00:0:0:11::2 64 [*switchA-Vlanif10] commit [~switchA-Vlanif10] quit
- Configure IS-IS.
# Configure switch A.
[~switchA] isis 1
[*switchA-isis-1] is-level level-1
[*switchA-isis-1] network-entity 10.0000.0000.0001.00
[*switchA-isis-1] ipv6 enable
[*switchA-isis-1] quit
[*switchA] interface vlanif 10
[*switchA-Vlanif10] isis ipv6 enable 1
[*switchA-Vlanif10] commit
[~switchA-Vlanif10] quit
# Configure switch B.
[~switchB] isis 1
[*switchB-isis-1] is-level level-1
[*switchB-isis-1] network-entity 10.0000.0000.0002.00
[*switchB-isis-1] ipv6 enable
[*switchB-isis-1] quit
[*switchB] interface vlanif 20
[*switchB-Vlanif20] isis ipv6 enable 1
[*switchB-Vlanif20] commit
[~switchB-Vlanif20] quit
# Configure switch C.
[~switchC] isis 1
[*switchC-isis-1] ipv6 enable
[*switchC-isis-1] network-entity 10.0000.0000.0003.00
[*switchC-isis-1] quit
[*switchC] interface vlanif 10
[*switchC-Vlanif10] isis ipv6 enable 1
[*switchC-Vlanif10] quit
[*switchC] interface vlanif 20
[*switchC-Vlanif20] isis ipv6 enable 1
[*switchC-Vlanif20] quit
[*switchC] interface vlanif 30
[*switchC-Vlanif30] isis ipv6 enable 1
[*switchC-Vlanif30] isis circuit-level level-2
[*switchC-Vlanif30] commit
[~switchC-Vlanif30] quit
# Configure switch D.
[~switchD] isis 1
[*switchD-isis-1] is-level level-2
[*switchD-isis-1] network-entity 20.0000.0000.0001.00
[*switchD-isis-1] ipv6 enable
[*switchD-isis-1] quit
[*switchD] interface vlanif 30
[*switchD-Vlanif30] isis ipv6 enable 1
[*switchD-Vlanif30] quit
[*switchD] interface vlanif 40
[*switchD-Vlanif40] isis ipv6 enable 1
[*switchD-Vlanif40] commit
[~switchD-Vlanif40] quit
- Verify the configuration.
# View the IS-IS routing table of switch A. You can view that switch A has the routes to each network segment of the Level-1 area.
[switchA] display isis route
Route Information for ISIS(1) -------------------------------------------------------------------------------- Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut, U-Up/Down Bit Set ISIS(1) Level-1 Forwarding Table -------------------------------------------------------------------------------- IPV6 Dest. ExitInterface NextHop Cost -------------------------------------------------------------------------------- ::/0 Vlanif10 FE80::220B:C7FF:FE39:130C 10 A/-/- FC00:0:0:11::/6 Vlanif10 Direct 10 D/L/- 4 FC00:0:0:12::/6 Vlanif10 FE80::220B:C7FF:FE39:130C 20 A/-/- 4
# View detailed information about IS-IS neighbors on switch C.
[switchC] display isis peer
Peer Information for ISIS(1) -------------------------------------------------------------------------------- System ID Interface Circuit ID State HoldTime(s) Type PRI -------------------------------------------------------------------------------- 0000.0000.0002 Vlanif20 0000.0000.0002.01 Up 8 L1 64 0000.0000.0001 Vlanif30 0000.0000.0001.01 Up 9 L2 64 0000.0000.0001 Vlanif10 0000.0000.0003.01 Up 22 L1 64
# View detailed information about the IS-IS LSDB of switch C.
[switchC] display isis lsdb
Database Information for ISIS(1) -------------------------------------------------------------------------------- Level-1 Link State Database *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended), ATT-Attached, P-Partition, OL-Overload LSPID Seq Num Checksum HoldTime(s) Length ATT/P/OL -------------------------------------------------------------------------------- 0000.0000.0001.00-00 0x0000000b 0xc229 373 86 0/0/0 0000.0000.0002.00-00 0x00000008 0x08e4 431 86 0/0/0 0000.0000.0002.01-00 0x00000008 0xd3ed 431 55 0/0/0 0000.0000.0003.00-00* 0x0000000c 0x8af5 489 143 1/0/0 0000.0000.0003.01-00* 0x0000000a 0xa21b 489 55 0/0/0 Total LSP(s): 5 Level-2 Link State Database *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended), ATT-Attached, P-Partition, OL-Overload LSPID Seq Num Checksum HoldTime(s) Length ATT/P/OL -------------------------------------------------------------------------------- 0000.0000.0001.00-00 0x00000009 0x7883 557 116 0/0/0 0000.0000.0001.01-00 0x00000007 0xcef3 557 55 0/0/0 0000.0000.0003.00-00* 0x00000008 0x158d 489 146 0/0/0 Total LSP(s): 3
Configuration Files
Configuration file of switch A
#
sysname switchA
#
vlan batch 10
#
isis 1
is-level level-1
network-entity 10.0000.0000.0001.00
#
ipv6 enable topology standard
#
#
interface Vlanif10
ipv6 enable
ipv6 address FC00:0:0:11::2/64
isis ipv6 enable 1
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 10
#
return
Configuration file of switch B
#
sysname switchB
#
vlan batch 20
#
isis 1
is-level level-1
network-entity 10.0000.0000.0002.00
#
ipv6 enable topology standard
#
#
interface Vlanif20
ipv6 enable
ipv6 address FC00:0:0:12::2/64
isis ipv6 enable 1
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 20
#
return
Configuration file of switch C
#
sysname switchC
#
vlan batch 10 20 30
#
isis 1
network-entity 10.0000.0000.0003.00
#
ipv6 enable topology standard
#
#
interface Vlanif10
ipv6 enable
ipv6 address FC00:0:0:11::1/64
isis ipv6 enable 1
#
interface Vlanif20
ipv6 enable
ipv6 address FC00:0:0:12::1/64
isis ipv6 enable 1
#
interface Vlanif30
ipv6 enable
ipv6 address FC00:0:0:30::1/64
isis ipv6 enable 1
isis circuit-level level-2
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 10
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 20
#
interface 10GE1/0/3
port link-type trunk
port trunk allow-pass vlan 30
#
return
Configuration file of switch D
#
sysname switchD
#
vlan batch 30 40
#
isis 1
is-level level-2
network-entity 20.0000.0000.0001.00
#
ipv6 enable topology standard
#
#
interface Vlanif30
ipv6 enable
ipv6 address FC00:0:0:30::2/64
isis ipv6 enable 1
#
interface Vlanif40
ipv6 enable
ipv6 address FC00:0:0:20::1/64
isis ipv6 enable 1
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 30
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 40
#
return