Example for Configuring BGP Route Dampening
Networking Requirements
As shown in Figure 9-32, BGP is configured on all Switches. SwitchA resides in AS 100, SwitchB resides in AS 200, and SwitchC resides in AS 300. EBGP runs between SwitchC and SwitchA, and between SwitchC and SwitchB. SwitchC must apply different route dampening policies to routes of different EBGP peers to suppress unstable routes and improve network stability.
Configuration Roadmap
The configuration roadmap is as follows:
Configure a route dampening policy on SwitchC.
Apply the route dampening policy to flapping routes on SwitchC to suppress unstable routes and improve network stability.
Procedure
- Configure the VLAN to which each interface belongs.
<HUAWEI> system-view [~HUAWEI] sysname SwitchA [*HUAWEI] commit [~SwitchA] vlan batch 10 30 [*SwitchA] interface 10ge 1/0/1 [*SwitchA-10GE1/0/1] port link-type trunk [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10 [*SwitchA-10GE1/0/1] quit [*SwitchA] interface 10ge 1/0/2 [*SwitchA-10GE1/0/2] port link-type trunk [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 30 [*SwitchA-10GE1/0/2] quit [*SwitchA] commit
The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.
- Configure VLANIF interfaces and assign IP addresses to the VLANIF interfaces.
[~SwitchA] interface vlanif 10 [*SwitchA-Vlanif10] ip address 192.168.1.1 24 [*SwitchA-Vlanif10] quit [*SwitchA] interface vlanif 30 [*SwitchA-Vlanif30] ip address 10.1.1.1 8 [*SwitchA-Vlanif30] quit [*SwitchA] commit
The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.
- Configure BGP connections.
# Configure SwitchA.
[~SwitchA] bgp 100
[*SwitchA-bgp] router-id 172.17.1.1
[*SwitchA-bgp] peer 192.168.1.2 as-number 300
[*SwitchA-bgp] ipv4-family unicast
[*SwitchA-bgp-af-ipv4] network 10.0.0.0 255.0.0.0
[*SwitchA-bgp-af-ipv4] commit
[~SwitchA-bgp-af-ipv4] quit
[~SwitchA-bgp] quit
# Configure SwitchB.
[~SwitchB] bgp 200
[*SwitchB-bgp] router-id 172.17.2.2
[*SwitchB-bgp] peer 192.168.2.2 as-number 300
[*SwitchB-bgp] ipv4-family unicast
[*SwitchB-bgp-af-ipv4] network 172.16.1.0 255.255.255.0
[*SwitchB-bgp-af-ipv4] commit
[~SwitchB-bgp-af-ipv4] quit
[~SwitchB-bgp] quit
# Configure SwitchC.
[~SwitchC] bgp 300
[*SwitchC-bgp] router-id 172.17.3.3
[*SwitchC-bgp] peer 192.168.1.1 as-number 100
[*SwitchC-bgp] peer 192.168.2.1 as-number 200
[*SwitchC-bgp] commit
[~SwitchC-bgp] quit
# View the BGP peers of SwitchC.
[~SwitchC] display bgp peer BGP local router ID : 172.17.3.3 Local AS number : 300 Total number of peers : 3 Peers in established state : 3 Peer V AS MsgRcvd MsgSent OutQ Up/Down State PrefRcv 192.168.1.1 4 100 3 3 0 00:00:01 Established 0 192.168.2.1 4 200 3 3 0 00:00:00 Established 0
The preceding command output shows that the status of BGP connections of SwitchC is Established.
- Configure a BGP route dampening policy.
# Configure an IP prefix list prefix-a on SwitchC to allow routes with prefix 8.0.0.0/8 to pass through.
[~SwitchC] ip ip-prefix prefix-a index 10 permit 10.0.0.0 8
[*SwitchC] commit
# Configure an IP prefix list prefix-b on SwitchC to allow routes with prefix 9.1.1.0/24 to pass through.
[~SwitchC] ip ip-prefix prefix-b index 20 permit 172.16.1.0 24
[*SwitchC] commit
# Configure a route-policy dampen-policy on SwitchC to apply different route dampening policies to routes with different prefixes.
[~SwitchC] route-policy dampen-policy permit node 10
[*SwitchC-route-policy] if-match ip-prefix prefix-a
[*SwitchC-route-policy] apply dampening 10 1000 2000 5000
[*SwitchC-route-policy] commit
[~SwitchC-route-policy] quit
[~SwitchC] route-policy dampen-policy permit node 20
[*SwitchC-route-policy] if-match ip-prefix prefix-b
[*SwitchC-route-policy] apply dampening 10 800 3000 10000
[*SwitchC-route-policy] commit
[~SwitchC-route-policy] quit
# Apply the route dampening policy to flapping routes.
[~SwitchC] bgp 300
[~SwitchC-bgp] ipv4-family unicast
[~SwitchC-bgp-af-ipv4] dampening route-policy dampen-policy
[*SwitchC-bgp-af-ipv4] commit
[~SwitchC-bgp] quit
# View the configured BGP route dampening parameters on SwitchC.
[~SwitchC] display bgp routing-table dampening parameter Maximum Suppress Time(in second) : 3973 Ceiling Value : 16000 Reuse Value : 750 HalfLife Time(in second) : 900 Suppress-Limit : 2000 Route-policy : dampen-policy
Configuration Files
Configuration file of SwitchA
#
sysname SwitchA
#
vlan batch 10 30
#
interface Vlanif10
ip address 192.168.1.1 255.255.255.0
#
interface Vlanif30
ip address 10.1.1.1 255.0.0.0
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 10
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 30
#
bgp 100
router-id 172.17.1.1
peer 192.168.1.2 as-number 300
#
ipv4-family unicast
network 10.0.0.0 255.0.0.0
peer 192.168.1.2 enable
#
return
Configuration file of SwitchB
#
sysname SwitchB
#
vlan batch 20 40
#
interface Vlanif20
ip address 192.168.2.1 255.255.255.0
#
interface Vlanif40
ip address 172.16.1.1 255.255.255.0
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 40
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 20
#
bgp 200
router-id 172.17.2.2
peer 192.168.2.2 as-number 300
#
ipv4-family unicast
network 172.16.1.0 255.255.255.0
peer 192.168.2.2 enable
#
return
Configuration file of SwitchC
#
sysname SwitchC
#
vlan batch 10 20
#
interface Vlanif10
ip address 192.168.1.2 255.255.255.0
#
interface Vlanif20
ip address 192.168.2.2 255.255.255.0
#
interface 10GE1/0/1
port link-type trunk
port trunk allow-pass vlan 10
#
interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 20
#
bgp 300
router-id 172.17.3.3
peer 192.168.1.1 as-number 100
peer 192.168.2.1 as-number 200
#
ipv4-family unicast
dampening route-policy dampen-policy
peer 192.168.1.1 enable
peer 192.168.2.1 enable
#
route-policy dampen-policy permit node 10
if-match ip-prefix prefix-a
apply dampening 10 1000 2000 5000
#
route-policy dampen-policy permit node 20
if-match ip-prefix prefix-b
apply dampening 10 800 3000 10000
#
ip ip-prefix prefix-a index 10 permit 10.0.0.0 8
ip ip-prefix prefix-b index 20 permit 172.16.1.0 24
#
return