No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring SA Message Filtering

Example for Configuring SA Message Filtering

Networking Requirements

As shown in Figure 6-13, service data is transmitted in multicast mode on the network that is divided into three PIM-SM domains. The multicast source Source1 sends multicast data to multicast groups 225.1.1.0/30 and 226.1.1.0/30, and Source2 sends multicast data to the multicast group 227.1.1.0/30. According to service requirements, HostA and HostB need to receive only multicast data that is sent to multicast groups 225.1.1.0/30 and 226.1.1.0/30, and HostC needs to receive only multicast data that is sent to multicast groups 226.1.1.0/30 and 227.1.1.0/30.

Figure 6-13 Network diagram for configuring SA message filtering

Configuration Roadmap

Configure MSDP to implement multicast source information sharing among domains. Configure Source-Active (SA) message filtering so that the receivers receive only required multicast data.

  1. Configure IP addresses for the interfaces on each switch and configure OSPF in the PIM-SM domain.

  2. Enable multicast and PIM-SM on each interface. Configure a BSR boundary to divide the PIM-SM domain and enable IGMP on interfaces connected to network segments of receiver hosts.

  3. Configure Loopback0 interfaces on SwitchA, SwitchC, and SwitchD as the candidate bootstrap router (C-BSR) and the candidate rendezvous point (C-RP) of each PIM-SM domain.

  4. Set up MSDP peer relationships between RPs in PIM-SM domains. Set up the MSDP peer relationship between SwitchA and SwitchC, and between SwitchC and SwitchD.

  5. Configure rules for filtering SA messages. Prohibit SwitchC from forwarding SA messages carrying (Source1, 225.1.1.0/30) entries to SwitchD. Prohibit SwitchD from creating SA messages carrying Source2 information.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch.

    # According to Figure 6-13, configure IP addresses and masks for the interfaces in the PIM-SM domain. Configure OSPF between switches. The configuration details are not mentioned here.

  2. Enable multicast routing and configure PIM-SM.

    # Enable multicast routing on all switches and PIM-SM on all interfaces. Enable IGMP on interfaces connected to network segments of receiver hosts. The following information shows the configuration on SwitchA. The configurations on other switches are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] pim sm
    [*SwitchA-Vlanif100] igmp enable
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] interface vlanif 101
    [~SwitchA-Vlanif101] pim sm
    [*SwitchA-Vlanif101] commit
    [~SwitchA-Vlanif101] quit
    [~SwitchA] interface vlanif 102
    [~SwitchA-Vlanif102] pim sm
    [*SwitchA-Vlanif102] commit
    [~SwitchA-Vlanif102] quit
    [~SwitchA] interface loopback 0
    [~SwitchA-LoopBack0] pim sm
    [*SwitchA-LoopBack0] commit
    [~SwitchA-LoopBack0] quit

  3. Configure a BSR boundary to divide the PIM-SM domain.

    # Configure a BSR boundary on SwitchC. The configurations on SwitchA, SwitchB, and SwitchD are similar to the configuration on SwitchC, and are not mentioned here.

    [~SwitchC] interface vlanif 101
    [~SwitchC-Vlanif101] pim bsr-boundary
    [*SwitchC-Vlanif101] quit
    [*SwitchC] interface vlanif 103
    [*SwitchC-Vlanif103] pim bsr-boundary
    [*SwitchC-Vlanif103] quit
    [*SwitchC] interface vlanif 104
    [*SwitchC-Vlanif104] pim bsr-boundary
    [*SwitchC-Vlanif104] quit
    [*SwitchC] commit

  4. Configure C-BSRs and C-RPs.

    # Configure the C-BSR and C-RP on the Loopback0 interface of SwitchA. The configurations on SwitchC and SwitchD are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] pim
    [*SwitchA-pim] c-bsr loopback0
    [*SwitchA-pim] c-rp loopback0
    [*SwitchC-pim] commit
    [~SwitchC-pim] quit

  5. Configure MSDP peers.

    # Configure an MSDP peer on SwitchA.

    [~SwitchA] msdp
    [*SwitchA-msdp] peer 192.168.1.2 connect-interface vlanif 101
    [*SwitchA-msdp] commit
    [~SwitchA-msdp] quit

    # Configure MSDP peers on SwitchC.

    [~SwitchC] msdp
    [*SwitchC-msdp] peer 192.168.1.1 connect-interface vlanif 101
    [*SwitchC-msdp] peer 10.110.5.2 connect-interface vlanif 104
    [*SwitchC-msdp] commit
    [~SwitchC-msdp] quit

    # Configure an MSDP peer on SwitchD.

    [~SwitchD] msdp
    [*SwitchD-msdp] peer 10.110.5.1 connect-interface vlanif 104
    [*SwitchD-msdp] commit
    [~SwitchD-msdp] quit

  6. Configure rules for filtering SA messages.

    # Prohibit SwitchC from forwarding SA messages carrying (Source1, 225.1.1.0/30) entries to SwitchD.

    [~SwitchC] acl number 3001
    [*SwitchC-acl4-advance-3001] rule deny ip source 10.110.3.100 0 destination 225.1.1.0 0.0.0.3
    [*SwitchC-acl4-advance-3001] rule permit ip source any destination any
    [*SwitchC-acl4-advance-3001] commit
    [~SwitchC-acl4-advance-3001] quit
    [~SwitchC] msdp
    [*SwitchC-msdp] peer 10.110.5.2 sa-policy export 3001
    [*SwitchC-msdp] commit
    [~SwitchC-msdp] quit

    # Prohibit SwitchD from creating SA messages carrying Source2 information.

    [~SwitchD] acl number 2001
    [*SwitchD-acl4-basic-2001] rule deny source 10.110.6.100 0
    [*SwitchD-acl4-basic-2001] quit
    [*SwitchD] msdp
    [*SwitchD-msdp] import-source acl 2001
    [*SwitchD-msdp] quit
    [*SwitchD] commit

  7. Verify the configuration.

    # Run the display msdp sa-cache command to view information about the (S, G) entries in the SA cache on switches. The following output shows information about the (S, G) entries in the SA cache on SwitchC and SwitchD.

    [~SwitchC] display msdp sa-cache
    MSDP Source-Active Cache Information of VPN instance: public net
     MSDP Total Source-Active Cache - 8 entries
     MSDP matched 8 entries
    
    (10.110.3.100, 225.1.1.0)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28 
    
    (10.110.3.100, 225.1.1.1)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 225.1.1.2)
     Origin RP: 10.1.1.1 
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28 
    
    (10.110.3.100, 225.1.1.3)
     Origin RP: 10.1.1.1 
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.0)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.1)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.2)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.3)
     Origin RP: 10.1.1.1 
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    [~SwitchD] display msdp sa-cache
    MSDP Source-Active Cache Information of VPN instance: public net
     MSDP Total Source-Active Cache - 4 entries
     MSDP matched 4 entries
    
    (10.110.3.100, 226.1.1.0)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.1)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.2)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.3)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:24:53, Expires: 00:05:06
    
    

    The preceding output shows that only multicast data to multicast groups 225.1.1.0/30 and 226.1.1.0/30 exists in the SA cache on SwitchC, and only multicast data to the multicast group 226.1.1.0/30 exists in the SA cache on SwitchD.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 to 102
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif101
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.1.2 connect-interface Vlanif101
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 102 to 103 200
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif103
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif200
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 101 103 to 104 300
    #
    multicast routing-enable
    #
    acl number 3001
     rule 5 deny ip source 10.110.3.100 0 destination 225.1.1.0 0.0.0.3 
     rule 10 permit ip 
    #
    interface Vlanif101
     ip address 192.168.1.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif103
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif104
     ip address 10.110.5.1 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif300
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port default vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.110.4.0 0.0.0.255
      network 10.110.5.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.1.1 connect-interface Vlanif101
     peer 10.110.5.2 connect-interface Vlanif104
     peer 10.110.5.2 sa-policy export 3001
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 104 400 500
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 deny source 10.110.6.100 0 
    #
    interface Vlanif104
     ip address 10.110.5.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif400
     ip address 10.110.6.1 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 10.110.7.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port default vlan 500
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE1/0/3
     port default vlan 400
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 10.110.5.0 0.0.0.255
      network 10.110.6.0 0.0.0.255
      network 10.110.7.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     import-source acl 2001
     peer 10.110.5.1 connect-interface Vlanif104
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 24943

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next