No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast Static Routes to Connect RPF Routes

Example for Configuring Multicast Static Routes to Connect RPF Routes

Networking Requirements

In Figure 7-11, SwitchB and SwitchC run Open Shortest Path First (OSPF) to implement IP interworking, but they have no unicast route to SwitchA. Switch interfaces must run Protocol Independent Multicast Sparse Mode (PIM-SM) to provide multicast services. The receiver host (Receiver) can receive data from Source1 and also needs to receive data from Source2.

Figure 7-11 Configuring multicast static routes to connect RPF routes

Configuration Roadmap

A reverse path forwarding (RPF) route to Source2 can be established on the path SwitchC → SwitchB → SwitchA by configuring multicast static routes on SwitchB and SwitchC. The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces of the switches. Configure OSPF on SwitchB and SwitchC but not on SwitchA, so that SwitchB and SwitchC have no unicast route to SwitchA.

  2. Enable multicast routing on all switches and PIM-SM on all Layer 3 interfaces. Configure an interface as a C-BSR and C-RP. Enable IGMP on the interface connected to the network segment of the receiver host. After these basic multicast functions are configured, the switches can establish a multicast distribution tree using default parameter settings. Multicast data can then be forwarded to Receiver along the multicast distribution tree.

  3. Configure multicast static routes to Source2 on SwitchB and SwitchC.

Procedure

  1. Configure IP addresses for interfaces and configure OSPF on each switch. SwitchB is used as an example in the following operations. Configurations of the other switches are similar.

    # Create VLANs and add Layer 2 physical interfaces to the VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 13 20 40
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 20
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port default vlan 13
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] interface 10ge 1/0/3
    [*SwitchB-10GE1/0/3] port link-type trunk
    [*SwitchB-10GE1/0/3] port trunk allow-pass vlan 40
    [*SwitchB-10GE1/0/3] quit
    [*SwitchB] commit
    

    # Configure IP addresses and masks for Layer 3 VLANIF interfaces.

    [~SwitchB] interface vlanif 13
    [*SwitchB-Vlanif13] ip address 10.1.3.1 24
    [*SwitchB-Vlanif13] quit
    [*SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] ip address 10.1.2.2 24
    [*SwitchB-Vlanif20] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] ip address 10.1.4.1 24
    [*SwitchB-Vlanif40] quit
    [*SwitchB] commit
    

    # Configure OSPF on SwitchB and SwitchC.

    [~SwitchB] ospf
    [*SwitchB-ospf-1] area 0
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] quit
    [*SwitchB-ospf-1] quit
    [*SwitchB] commit

  2. Enable multicast routing on all switches, PIM-SM on all Layer 3 interfaces, and IGMP on the interface connected to the network segment of the receiver host.

    # On SwitchA, enable multicast routing globally and enable PIM-SM on the Layer 3 interfaces. (The configuration of SwitchB is similar to the configuration of SwitchA.)

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] commit
    

    # On SwitchC, enable multicast routing globally, enable PIM-SM on Layer 3 interfaces, and enable IGMP on the interface connected to the network segment of the receiver host.

    [~SwitchC] multicast routing-enable
    [*SwitchC] interface vlanif 20
    [*SwitchC-Vlanif20] pim sm
    [*SwitchC-Vlanif20] quit
    [*SwitchC] interface vlanif 12
    [*SwitchC-Vlanif12] pim sm
    [*SwitchC-Vlanif12] igmp enable
    [*SwitchC-Vlanif12] quit
    [*SwitchC] commit
    

    # Configure VLANIF20 as a C-BSR and C-RP on SwitchB.

    [~SwitchB] pim
    [*SwitchB-pim] c-bsr vlanif 20
    [*SwitchB-pim] c-rp vlanif 20
    [*SwitchB-pim] commit
    [~SwitchB-pim] quit
    

    # Source1 (10.1.3.2/24) and Source2 (10.1.5.2/24) send multicast data to group G (225.1.1.1). After Receiver joins group G, it receives the multicast data sent by Source1 but cannot receive the multicast data sent by Source2.

    # Run the display multicast rpf-info 10.1.5.2 command on SwitchB and SwitchC. No information is displayed, indicating that SwitchB and SwitchC have no RPF route to Source2.

  3. Configure multicast static routes.

    # Configure a multicast RPF static route to Source2 on SwitchB, and configure SwitchA as the RPF neighbor.

    [~SwitchB] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.4.2
    [*SwitchB] commit

    # Configure a multicast RPF static route to Source2 on SwitchC, and configure SwitchB as the RPF neighbor.

    [~SwitchC] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.2.2
    [*SwitchC] commit

  4. Verify the configuration.

    # Run the display multicast rpf-info 10.1.5.2 command on SwitchB and SwitchC to check the RPF route to Source2. The following information is displayed:

    [~SwitchB] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source: 10.1.5.2
         RPF interface: Vlanif40, RPF neighbor: 10.1.4.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selecting rule: preference-preferred
         Load splitting rule: disable 
    
    
    [~SwitchC] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source 10.1.5.2:
         RPF interface: Vlanif20, RPF neighbor: 10.1.2.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 

    # Run the display pim routing-table command on SwitchC to check the PIM routing table. SwitchC has multicast entries for Source2, indicating that Receiver can now receive multicast data from Source2.

    [~SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
    
     (*, 225.1.1.1)
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: WC
         UpTime: 03:54:19
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif12
                 Protocol: pim-sm, UpTime: 01:38:19, Expires: never
    
    (10.1.3.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: Vlanif12
                  Protocol: pim-sm, UpTime: 00:00:44, Expires: never
    
    (10.1.5.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: Vlanif12
                  Protocol: pim-sm, UpTime: 00:00:44, Expires: never
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    multicast routing-enable
    #
    vlan batch 11 40
    #
    interface Vlanif11
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 11
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return 
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 13 20 40
    #
    multicast routing-enable
    #
    interface Vlanif13
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port default vlan 13
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.4.2
    #
    pim
     c-bsr Vlanif20
     c-rp Vlanif20
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 12 20
    #
    multicast routing-enable
    #
    interface Vlanif12
     ip address 10.1.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port default vlan 12
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.2.2
    #
    return 
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 24686

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next