No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 Bidir-PIM and IPv6 PIM-SM on the Same Network

Example for Configuring IPv6 Bidir-PIM and IPv6 PIM-SM on the Same Network

Networking Requirements

On the network shown in Figure 5-5, HostA needs to receive data for multicast group FF1E::1 through IPv6 Bidir-PIM, and HostB needs to receive for multicast group FF2E::1 through IPv6 PIM-SM.

Figure 5-5 IPv6 Bidir-PIM and IPv6 PIM-SM on the same network

Table 5-27 Device configuration list

Device

VLANIF Interface/Loopback Interface

IPv6 Address

SwitchA

VLANIF30 FC00:0:0:2001:3::1/64
VLANIF100 FC00:0:0:2002:1::1/64
VLANIF200 FC00:0:0:2002:2::1/64
Loopback0 FC00:0:0:1::1/128

SwitchB

VLANIF10 FC00:0:0:2001:1::1/64
VLANIF100 FC00:0:0:2002:1::2/64

SwitchC

VLANIF20 FC00:0:0:2001:2::1/64
VLANIF200 FC00:0:0:2002:2::2/64

Configuration Roadmap

Configure dynamic rendezvous point (RP) to serve IPv6 Bidir-PIM and IPv6 PIM-SM on SwitchA and configure access control list (ACL) rules to define the range of multicast groups served by the dynamic RP. In this way, both IPv6 Bidir-PIM and IPv6 PIM-SM can function on the network. The configuration roadmap is as follows:

  1. Assign IPv6 addresses to interfaces and configure a unicast routing protocol on each switch.

  2. Enable IPv6 multicast routing on all the switches that provide multicast services.

  3. Enable IPv6 Bidir-PIM on all the switches that provide multicast services.

  4. Enable IPv6 PIM-SM on all interfaces of the switches that provide multicast services.

  5. Enable Multicast Listener Discovery (MLD) on switch interfaces directly connected to hosts.

  6. Configure the dynamic RP function. On SwitchA, configure dynamic RPs on different interfaces to serve IPv6 Bidir-PIM and IPv6 PIM-SM respectively, and configure ACL rules to define the range of multicast groups served by dynamic RPs.

Procedure

  1. Assign IPv6 addresses to interfaces and configure a unicast routing protocol on each switch.

    # Configure IPv6 addresses and masks for switch interfaces according to Figure 5-5. Configure Open Shortest Path First version 3 (OSPFv3) on the switches to implement IPv6 interworking between the switches and enable the switches to dynamically update routes. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    # Add interfaces of SwitchA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 30 100 200
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 30
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 200
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # Assign IPv6 addresses to interfaces of SwitchA.

    [~SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:2001:3::1 64
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ipv6 address fc00:0:0:2002:1::1 64
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ipv6 enable
    [*SwitchA-Vlanif200] ipv6 address fc00:0:0:2002:2::1 64
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ipv6 enable
    [*SwitchA-LoopBack0] ipv6 address fc00:0:0:1::1 128
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

    # Configure unicast routing protocol OSPFv3 on SwitchA.

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 10.1.1.1
    [*SwitchA-ospfv3-1] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ospfv3 1 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ospfv3 1 area 0
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ospfv3 1 area 0
    [*SwitchA-Vlanif200] quit
    [*SwitchA] commit
    

  2. Enable IPv6 multicast routing and IPv6 Bidir-PIM on the switches.

    # Enable IPv6 multicast routing and IPv6 Bidir-PIM on SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] bidir-pim
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

  3. Enable IPv6 PIM-SM on all the switch interfaces.

    # Enable IPv6 PIM-SM on all the interfaces of SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 30
    [~SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] pim ipv6 sm
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] pim ipv6 sm
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] pim ipv6 sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. Enable MLD on interfaces directly connected to network segments of hosts.

    # Configure SwitchB.

    [~SwitchB] interface vlanif 10
    [~SwitchB-Vlanif10] mld enable
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit
    

    # Configure SwitchC.

    [~SwitchC] interface vlanif 20
    [~SwitchC-Vlanif20] mld enable
    [*SwitchC-Vlanif20] commit
    [~SwitchC-Vlanif20] quit
    

  5. Configure the dynamic RP function.

    # Configure different C-RP interfaces to serve IPv6 Bidir-PIM and IPv6 PIM-SM on SwitchA.

    [~SwitchA] acl ipv6 number 2000
    [*SwitchA-acl6-basic-2000] rule permit source ff1e:: 64
    [*SwitchA-acl6-basic-2000] quit
    [*SwitchA] acl ipv6 number 2001
    [*SwitchA-acl6-basic-2001] rule permit source ff2e:: 64
    [*SwitchA-acl6-basic-2001] quit
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] c-bsr fc00:0:0:2001:3::1
    [*SwitchA-pim6] c-rp fc00:0:0:1::1 group-policy 2000 bidir
    [*SwitchA-pim6] c-rp fc00:0:0:2001:3::1 group-policy 2001
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

  6. Verify the configuration.

    # Run the display pim ipv6 routing-table command to view the IPv6 PIM routing table on each switch. You can see from the routing tables that multicast source FC00:0:0:2001:3::2/64 sends data to multicast groups FF1E::1/64 and FF2E::1/64, HostA joined group FF1E::1/64, and HostB joined group FF2E::1/64. For example, the IPv6 PIM routing tables on SwitchA and SwitchB are as follows:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:2001:3::1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:29:14
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:27:04, Expires: 00:03:27
    
    
     (FC00:0:0:2001:3::2, FF2E::1)
         RP: FC00:0:0:2001:3::1 (local)
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:00:31
         Upstream interface: Vlanif30
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:00:38, Expires: 00:02:53
    
     (*, FF1E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:29:22
         Rpf interface: LoopBack0
             Upstream neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif100
                 Protocol: bidir-pim, UpTime: 00:29:42, Expires: 00:02:48
            2: LoopBack0(RPF)
                 Protocol: bidir-pim, UpTime: 00:29:42, Expires: -
    [~SwitchB] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:1::1
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:17:14
         Rpf interface: Vlanif100
             Upstream neighbor: FE80::3ABA:34FF:FEF6:7605
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: mld, UpTime: 00:17:13, Expires: -
            2: Vlanif100(RPF)
                 Protocol: bidir-pim, UpTime: 00:17:14, Expires: - 

    According to the command output, HostA can receive data for group FF1E::1 through IPv6 Bidir-PIM, and HostB can receive data for group FF2E::1 through IPv6 PIM-SM.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 30 100 200
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF1E::/64
    #
    acl ipv6 number 2001
     rule 5 permit source FF2E::/64
    #
    ospfv3 1
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2001:3::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2002:1::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address FC00:0:0:2002:2::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:1::1/128
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    pim ipv6
     c-bsr FC00:0:0:2001:3::1
     bidir-pim
     c-rp FC00:0:0:1::1 group-policy 2000 bidir
     c-rp FC00:0:0:2001:3::1 group-policy 2001
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 100
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001:1::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2002:1::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    pim ipv6
     bidir-pim
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 200
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001:2::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address FC00:0:0:2002:2::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    pim ipv6
     bidir-pim
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 24163

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next