No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IPv4 PIM-DM Functions

Example for Configuring Basic IPv4 PIM-DM Functions

Networking Requirements

Figure 4-25 shows a small-scale network with densely distributed users. Host A and Host B need to receive multicast data from the multicast source (Source).

Figure 4-25 Basic PIM-DM network

Configuration Roadmap

Since users are densely distributed on the network, PIM-DM can be deployed on the network to provide multicast services for the user hosts. After PIM-DM is configured on the network, all user hosts in a multicast group can receive multicast data sent from the multicast source to the group.

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on the switches. PIM is an intra-domain multicast routing protocol that depends on a unicast routing protocol. It can work only when the unicast routing protocol works normally.

  2. Enable multicast routing on all the switches that need to provide multicast services. Multicast routing is the prerequisite for PIM-DM configuration.

  3. Enable PIM-DM on all interfaces of the switches. Other PIM-DM functions can be configured only after PIM-DM is enabled.

  4. Enable IGMP on the interfaces connected to network segments of hosts. The IGMP protocol maintains group memberships. The leaf switches use IGMP to maintain list of group member ports.

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on the switches.

    Configure IP addresses and masks for switch interfaces according to Figure 4-25. Configure OSPF on the switches to implement IP interworking and dynamic updates of multicast routes based on unicast routing.

    # Add interfaces of SwitchA to VLANs. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port default vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # Assign IP addresses to VLANIF interfaces on SwitchA. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 192.168.5.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ip address 10.110.1.1 24
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 192.168.1.1 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

    # Configure a routing protocol on SwitchA. OSPF is used in this example. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Enable multicast routing on all switches and enable PIM-DM on all interfaces.

    # Enable multicast routing globally and enable PIM-DM on all interfaces on SwitchA. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim dm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim dm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim dm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  3. Enable IGMP on the interfaces connected to network segments of hosts.

    # Enable IGMP on the VLANIF interface of SwitchA connected to the network segment of hosts. The configurations on SwitchB and SwitchC are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] igmp enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit
    

  4. Verify the configuration.

    # Run the display pim interface command on the switches to check the PIM configuration and running status on switch interfaces. The following is an example of command output on SwitchC. The State field is up, indicating that the PIM protocol is running on the interfaces, and the PIM neighbor relationship has been established.

    [~SwitchC] display pim interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt     DR-Pri     DR-Address      
     Vlanif40            up         1       30          1     10.110.2.2 (local) 
     Vlanif50            up         1       30          1     192.168.3.2
    

    # Run the display pim routing-table command to check the PIM routing tables on the switches. You can see from the PIM routing tables that the multicast source (10.110.3.100/24) sends multicast data to the group (225.1.1.1/24), and Host A and Host B have joined the group. The command outputs on the switches are as follows:

    [~SwitchA] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 00:00:29
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:00:29, Expires: never
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:00:29
         Upstream interface: Vlanif30
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-dm, UpTime: 00:00:29, Expires: -
    
    [~SwitchB] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 00:00:29
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:00:29, Expires: never
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:00:29
         Upstream interface: Vlanif80
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: None
    
    [~SwitchC] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 00:00:29
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:00:29, Expires: never
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:01:25
         Upstream interface: Vlanif50
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-dm, UpTime: 00:01:25, Expires: -
    
    [~SwitchD] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: LOC ACT
         UpTime: 00:00:29
         Upstream interface: Vlanif70
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif30
                 Protocol: pim-dm, UpTime: 00:00:29, Expires: never
             2: Vlanif60
                 Protocol: pim-dm, UpTime: 00:00:26, Expires: never
    
    [~SwitchE] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:01:22
         Upstream interface: Vlanif60
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif50
                 Protocol: pim-dm, UpTime: 00:01:22, Expires: never
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.5.1 255.255.255.0
     pim dm
    #
    interface Vlanif20
     ip address 10.110.1.1 255.255.255.0
     pim dm 
     igmp enable
    #
    interface Vlanif30
     ip address 192.168.1.1 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 40 80
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 10.110.2.1 255.255.255.0
     pim dm
     igmp enable
    #
    interface Vlanif80
     ip address 192.168.2.1 255.255.255.0
     pim dm 
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/2
     port default vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 10.110.2.2 255.255.255.0
     pim dm 
     igmp enable
    #
    interface Vlanif50
     ip address 192.168.3.1 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 30 60 70
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 192.168.1.2 255.255.255.0
     pim dm
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim dm
    #
    interface Vlanif70
     ip address 10.110.3.1 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port default vlan 70
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 80
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.5.2 255.255.255.0
     pim dm
    #
    interface Vlanif50
     ip address 192.168.3.2 255.255.255.0
     pim dm
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim dm
    #
    interface Vlanif80
     ip address 192.168.2.2 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 24420

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next