No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic MLD Functions

Example for Configuring Basic MLD Functions

Networking Requirements

As shown in Figure 3-14, network segments N1 and N2 composed of different user groups exist on an IPv6 network. SwitchA connects to N1, and SwitchB and SwitchC connect to N2. The Protocol Independent Multicast (PIM) for IPv6 (PIM IPv6) network uses multicast address FF16::1 to transmit video streams. The multicast function needs to be enabled on the network so that hosts can receive multicast data.

Figure 3-14 Network diagram for basic MLD configurations

Configuration Roadmap

To meet the preceding requirements, configure basic MLD functions.

  1. Configure an IPv6 unicast routing protocol on the network to implement IP interworking. Multicast routing protocols work depending on unicast routing protocols.
  2. Configure IPv6 PIM-SM on all the switches that provide IPv6 multicast services.
  3. Enable MLD on the interfaces connected to hosts so that hosts can receive multicast data.

Procedure

  1. Configure IPv6 addresses for interfaces and configure an IPv6 unicast routing protocol on the interfaces.

    # Create VLANs and add physical interfaces to VLANs on the switches. Configure IPv6 addresses for the VLANIF interfaces. Configure Open Shortest Path First Version 3 (OSPFv3) on the switches to implement IP interworking. The configurations on SwitchB, SwitchC, and SwitchD are similar to those on SwitchA and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 11
    [*SwitchA] interface 10GE 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10GE 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 11
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] ipv6 enable
    [*SwitchA-Vlanif11] ipv6 address fc00:0:0:2::1 64
    [*SwitchA-Vlanif11] ospfv3 100 area 0
    [*SwitchA-Vlanif11] quit
    [*SwitchA] commit

  2. Configure IPv6 PIM-SM on all switches.

    # Enable the IPv6 multicast function on SwitchD, and enable IPv6 PIM-SM on all interfaces of SwitchD. The configurations of SwitchA, SwitchB and SwitchC are similar to the configuration of SwitchD, and are not mentioned here.

    [~SwitchD] multicast ipv6 routing-enable
    [*SwitchD] interface vlanif 11
    [*SwitchD-Vlanif11] pim ipv6 sm
    [*SwitchD-Vlanif11] quit
    [*SwitchD] interface vlanif 21
    [*SwitchD-Vlanif21] pim ipv6 sm
    [*SwitchD-Vlanif21] quit
    [*SwitchD] interface vlanif 31
    [*SwitchD-Vlanif31] pim ipv6 sm
    [*SwitchD-Vlanif31] quit
    [*SwitchD] interface vlanif 40
    [*SwitchD-Vlanif40] pim ipv6 sm
    [*SwitchD-Vlanif40] quit
    [*SwitchD] commit

    # Configure an RP. Configure C-BSR and C-RP on SwitchD.

    [~SwitchD] pim ipv6
    [*SwitchD-pim6] c-bsr fc00:0:0:7::1
    [*SwitchD-pim6] c-rp fc00:0:0:7::1
    [*SwitchD-pim6] commit
    [~SwitchD-pim6] quit
    

  3. Enable MLD on the interfaces connected to user hosts.

    # Enable MLD on VLANIF 10 of SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] mld enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

  4. Verify the configuration.

    # Run the display mld interface command to check information about MLD configuration and running on each interface of the switches. MLD information about VLANIF 20 on SwitchB is as follows:

    [~SwitchB] display mld interface vlanif 20 verbose
    Interface information
     Vlanif20(FE80::225:9EFF:FE95:7C27):
       MLD is enabled
       Current MLD version is 2
       MLD state: up
       MLD group policy: none
       Query interval for MLD (negotiated): 125 s
       Query interval for MLD (configured): 125 s
       Other querier timeout for MLD: 0 s
       Maximum query response time for MLD: 10 s
       Last listener query time: 2 s
       Last listener query interval: 1 s
       Startup query interval: 31 s
       Startup query count: 2
       General query timer expiry (hours:minutes:seconds): 00:00:28
       Querier for MLD: FE80::225:9EFF:FE95:7C27 (this router)
       MLD activity: 2 joins, 0 dones
       Robustness (negotiated): 2
       Robustness (configured): 2
       Require-router-alert: disabled
       Send-router-alert: enabled
       Ip-source-policy: disabled  
       Query Ip-source-policy: disabled 
       Prompt-leave: disabled
       SSM-Mapping: disabled
       Startup-query-timer-expiry: off
       Other-querier-present-timer-expiry: off
      Total 1 MLD Group reported 
    

    The command output shows that SwitchB is a querier. This is because the IPv6 address of VLANIF 20 on SwitchB is smaller than that of SwitchC on the same network segment. In addition, VLANIF 20 has received Multicast Listener Report messages from a multicast group.

    # Run the display pim ipv6 routing-table command to check the IPv6 PIM-SM multicast routing table on each switch. The IPv6 PIM-SM multicast routing table on SwitchA is as follows:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
      
     (*, FF16::1)
         RP: FC00:0:0:7::1
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:21:35 
         Upstream interface: Vlanif11 
             Upstream neighbor: FE80::225:9EFF:FE01:20E   
             RPF prime neighbor: FE80::225:9EFF:FE01:20E 
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10 
                 Protocol: mld, UpTime: 00:21:35, Expires: -  
      
     (FC00:0:0:7::5, FF16::1)  
         RP: FC00:0:0:7::1
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:22:46 
         Upstream interface: Vlanif11  
             Upstream neighbor: FE80::225:9EFF:FE01:20E  
             RPF prime neighbor: FE80::225:9EFF:FE01:20E 
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10 
                 Protocol: pim-sm, UpTime: 00:22:47, Expires: -
    
    

    The command output shows that (*, FF16::1) and (FC00:0:0:7::5, FF16::1) entries exist on SwitchA. This indicates that VLANIF 10 has joined multicast groups FF16::1 and can receive multicast data from multicast source FC00:0:0:7::5.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 to 11
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0 
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:4::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 31
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:5::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:6::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 11 21 31 40
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address FC00:0:0:2::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:4::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:6::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:7::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    pim ipv6
     c-bsr FC00:0:0:7::1
     c-rp FC00:0:0:7::1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 25520

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next