No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 PIM-SM in the ASM Model

Example for Configuring IPv6 PIM-SM in the ASM Model

Networking Requirements

As shown in Figure 5-1, the shared network segment is connected to the Internet. HostA and HostB want to receive multicast data from Source.

Figure 5-1 Network diagram for configuring IPv6 PIM-SM in the ASM model

Table 5-23 Device configuration list

Device

VLANIF Interface

IPv6 Address

SwitchA

VLANIF10

FC00:0:0:2001::1/64

VLANIF20

FC00:0:0:3001::1/64

VLANIF30

FC00:0:0:2002::1/64

SwitchB

VLANIF40

FC00:0:0:4001::1/64

VLANIF90

FC00:0:0:2003::1/64

SwitchC

VLANIF40

FC00:0:0:4001::2/64

VLANIF50

FC00:0:0:2004::1/64

SwitchD

VLANIF30

FC00:0:0:2002::2/64

VLANIF60

FC00:0:0:2005::1/64

VLANIF70

FC00:0:0:6001::1/64

VLANIF80

FC00:0:0:5001::1/64

SwitchE

VLANIF10

FC00:0:0:2001::2/64

VLANIF50

FC00:0:0:2004::2/64

VLANIF60

FC00:0:0:2005::2/64

VLANIF90

FC00:0:0:2003::2/64

Configuration Roadmap

Configure the IPv6 PIM-SM protocol on the switches to enable them to provide the Any-Source Multicast (ASM) service for user hosts on the network. Then all the hosts in a multicast group can receive multicast data sent from any sources to this group.

  1. Configure an IPv6 address for each interface and an IPv6 unicast routing protocol. IPv6 PIM is an intra-domain multicast routing protocol that depends on IPv6 unicast routing protocols.

  2. Enable the IPv6 multicast function on all switches to provide IPv6 multicast services. Before configuring IPv6 PIM-SM, you must enable the IPv6 multicast function.

  3. Enable IPv6 PIM-SM on all interfaces. You can configure other IPv6 PIM-SM functions only after IPv6 PIM-SM is enabled.

  4. Enable Multicast Listener Discovery (MLD) on interfaces that connect the switch and hosts. A receiver can join and leave a multicast group by sending MLD messages. The leaf switches maintain the multicast member relationship through MLD.

  5. Enable IPv6 PIM silent on interfaces that connect the switch and hosts to prevent malicious hosts from simulating sending Hello packets. In this manner, security of IPv6 PIM-SM domain is ensured.

    NOTE:

    If the user host network segment connects to multiple switches, do not enable IPv6 PIM silent on interfaces that connect these switches and user hosts. For example, IPv6 PIM silent cannot be enabled on SwitchB and SwitchC in the figure.

  6. Configure the rendezvous point (RP). In IPv6 PIM-SM domain, RP is essential in providing ASM services and helps forward multicast data. You are advised to configure RP on switches that have more multicast flows. For example, you can configure RP on SwitchE in the figure.

  7. Configure the bootstrap router (BSR) boundary on interfaces connected to the Internet. The Bootstrap message cannot pass through the BSR boundary; therefore, the BSR serves only this IPv6 PIM-SM domain. In this manner, multicast services can be controlled effectively.

Procedure

  1. Configure an IPv6 address for each interface and an IPv6 unicast routing protocol.

    # Configure the IPv6 address and mask for each interface shown in Figure 5-1, and configure Open Shortest Path First version 3 (OSPFv3) on each switch to ensure that switches can communicate at the network layer and can dynamically update routes through the IPv6 unicast routing protocol. The configuration of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not provided here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] vlan batch 10 20 30
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:3001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:2002::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type access
    [*SwitchA-10GE1/0/2] port default vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit

  2. Enable multicast, and enable IPv6 PIM-SM on all interfaces.

    # Enable IPv6 multicast on all switches and IPv6 PIM-SM on all interfaces. The configuration of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  3. Enable MLD on interfaces that connect the switch and hosts.

    # Enable MLD on interfaces that connect SwitchA and user hosts. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not provided here.

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] mld enable
    [*SwitchA-Vlanif20] commit

  4. Enable IPv6 PIM silent on interfaces on SwitchA.

    [~SwitchA-Vlanif20] pim ipv6 silent
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit

  5. Configure the RP.

    # Configure the C-RP on SwitchE and specify the group address range served by the C-RP.

    [~SwitchE] acl ipv6 number 2001
    [*SwitchE-acl6-basic-2001] rule permit source ff1e::1 64
    [*SwitchE-acl6-basic-2001] quit
    [*SwitchE] pim ipv6
    [*SwitchE-pim6] c-rp fc00:0:0:2005::2 group-policy 2001
    [*SwitchE-pim6] commit

    # Configure a C-BSR on SwitchE.

    [~SwitchE-pim6] c-bsr fc00:0:0:2005::2
    [*SwitchE-pim6] commit
    [~SwitchE-pim6] quit

  6. Configure the BSR boundary on interfaces that connect SwitchD to the Internet.

    [~SwitchD] interface vlanif 70
    [~SwitchD-Vlanif70] pim ipv6 bsr-boundary
    [*SwitchD-Vlanif70] commit
    [~SwitchD-Vlanif70] quit

  7. Verify the configuration.

    # Run the display pim ipv6 interface command to check the IPv6 PIM configuration and status. In this example, IPv6 PIM information on SwitchC is displayed as follows:

    [~SwitchC] display pim ipv6 interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt   DR-Pri     DR-Address
     Vlanif40            up    1      30         1          FE80::200:FF:FE13:21
     Vlanif50            up    1      30         1          FE80::200:FF:FE00:10(local)
    

    # Run the display pim ipv6 bsr-info command to check information about the BSR selection on the switch. For example, BSR information on SwitchA and SwitchE is displayed as follows (C-BSR information is also displayed on SwitchE).

    [~SwitchA] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2005::2
         Priority: 0
         Hash mask length: 126
         State: Accept Preferred
         Uptime: 01:40:40
         Next BSR message scheduled at: 00:01:42
         C-RP Count: 1
    
    [~SwitchE] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2005::2
         Priority: 0
         Hash Mask length: 126
         State: Elected
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: FC00:0:0:2005::2
         Priority: 0
         Hash mask length: 126
         State:Elected
         Wait to be BSR: 0

    # Run the display pim ipv6 rp-info command to check the RP information on the switch. In this example, the RP information on SwitchA is displayed as follows:

    [~SwitchA] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF0E::1/64
         RP: FC00:0:0:2005::2
         Priority: 192
         Uptime: 00:05:19
         Expires: 00:02:11
    

    # Run the display pim ipv6 routing-table command to view the IPv6 PIM multicast routing table. Multicast source S (FC00:0:0:5001::5/64) sends multicast packets to multicast groups FF1E::1/64 and FF1E::2/64. HostA needs to receive data sent to group FF1E::1, and HostB needs to receive data sent to group FF1E::2.

    NOTE:

    By default, after the receiver's DR receives the first multicast data, an SPT switchover is performed and (S, G) routing entries are created. Therefore, (S, G) routing entries displayed on the switch are (S, G) entries after the SPT switchover.

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: mld, UpTime: 00:02:15, Expires:  -
    
     (FC00:0:0:5001::5, FF1E::1)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:11
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::A01:10C:1
             RPF prime neighbor: FE80::A01:10C:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-sm, UpTime: 00:00:11, Expires: -
    
    
    [~SwitchB] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:14:44
         Upstream interface: Vlanif90
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: mld, UpTime: 00:14:44, Expires: -
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:2:42
         Upstream interface: Vlanif90
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:14:44, Expires: -
    
    
    [~SwitchC] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag:
         UpTime: 00:2:42
         Upstream interface: Vlanif50
             Upstream neighbor: FE80::71FE:11:21
             RPF prime neighbor: FE80::71FE:11:21
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:13:46, Expires: -
    
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 2 (S, G) entry
     (FC00:0:0:5001::5, FF1E::1)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:16:56
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:16:56, Expires: 00:02:34
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:54
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
                1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:02:54, Expires: 00:02:36
    
    
    [~SwitchE] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (*, G) entry; 2 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Register
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
    
     (FC00:0:0:5001::5, FF1E::1)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:16:56
         Upstream interface: Vlanif60
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:16:56, Expires: 00:02:34
    
     (*, FF1E::2)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Register
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
             2: Vlanif50
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:54
         Upstream interface: Vlanif60
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
             2: Vlanif50
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:3001::1/64
     pim ipv6 silent
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 40 90
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.2.2.2 
     area 0.0.0.0 
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/0/2
     port default vlan 40
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0 
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4001::2/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2004::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 30 60 70 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0 
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2005::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address FC00:0:0:6001::1/64
     pim ipv6 bsr-boundary
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:5001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 80
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 90
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2001
     rule 0 permit source FF1E::1/64
    #
    ospfv3 100
     router-id 10.5.5.5
     area 0.0.0.0 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2004::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2005::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address FC00:0:0:2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    pim ipv6
     c-bsr FC00:0:0:2005::2
     c-rp FC00:0:0:2005::2 group-policy 2001
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 20554

Downloads: 21

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next