No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Layer 3 Multicast over M-LAG

Example for Configuring IPv4 Layer 3 Multicast over M-LAG

Networking Requirements

On the IPv4 network shown in Figure 4-31, the Layer 2 access switch (Switch) is dual-homed to active-active VRRP gateways SwitchA and SwitchB through an M-LAG to enhance network reliability. The receiver connected to Switch wants to receive the multicast video program from the source.

Figure 4-31 Network diagram for IPv4 Layer 3 multicast over M-LAG configuration
Table 4-31 Device configuration list

Device

Interface

VLANIF Interface

IP Address

SwitchA

10GE1/0/1

VLANIF 12

10.3.1.1/24

10GE1/0/6

VLANIF 13

10.5.1.1/24

Eth-Trunk 10

VLANIF 11

10.2.1.1/24

MEth0/0/0

10.1.1.1/32

SwitchB

10GE1/0/1

VLANIF 14

10.4.1.1/24

10GE1/0/6

VLANIF 13

10.5.1.2/24

Eth-Trunk 10

VLANIF 11

10.2.1.2/24

MEth0/0/0

10.1.1.2/32

SwitchC

10GE1/0/1

VLANIF 12

10.3.1.2/24

10GE1/0/2

VLANIF 14

10.4.1.2/24

10GE1/0/3

VLANIF 15

10.6.1.1/24

Configuration Roadmap

NOTE:

To meet the requirements, the M-LAG master and backup switches (SwitchA and SwitchB) must have both a peer link and a direct Layer 3 link between them, and they must have the same multicast configuration.

The configuration roadmap is as follows:

  1. Configure M-LAG and VRRP on SwitchA and SwitchB, and configure active-active access on Switch to enhance reliability.

  2. Configure a unicast routing protocol on SwitchA, SwitchB, and SwitchC to implement IP interworking. Multicast routing works depending on unicast routing.

  3. Enable PIM-SM and IGMP on VLANIF interfaces of SwitchA and SwitchB, and enable PIM-SM on VLANIF interfaces of SwitchC, so that multicast forwarding entries can be created on the switches.

  4. Enable the PIM silent function on user-side VLANIF interfaces on SwitchA and SwitchB, to ensure that SwitchA and SwitchB both act as DRs and send Join messages to the RP.

  5. On SwitchA and SwitchB, enable IGMP snooping in the VLANs corresponding to the VLANIF interfaces to implement accurate multicast forwarding on the Layer 2 network.

  6. Disable STP on the interfaces at both sides of the Layer 3 link between SwitchA and SwitchB, and specify the VLAN that is not allowed on the peer-link. This ensures normal multicast forwarding on the M-LAG.

Procedure

  1. Configure an M-LAG based on Virtual Spanning Tree Protocol (V-STP) and a VRRP group.

    1. Configure a V-STP-based M-LAG.

      # On SwitchA, configure a Dynamic Fabric Service (DFS) group, a peer-link, V-STP, an M-LAG, the LACP M-LAG system priority and system ID, to set up a V-STP-based M-LAG. The configuration on SwitchB is similar to the configuration on SwitchA. For details, see its configuration file.
      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchA
      [*HUAWEI] commit
      [~SwitchA] interface meth 0/0/0
      [~SwitchA-MEth0/0/0] ip address 10.1.1.1 32
      [*SwitchA-MEth0/0/0] quit
      [*SwitchA] dfs-group 1
      [*SwitchA-dfs-group-1] source ip 10.1.1.1
      [*SwitchA-dfs-group-1] priority 150
      [*SwitchA-dfs-group-1] quit
      [*SwitchA] interface eth-trunk 1
      [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/4 to 1/0/5
      [*SwitchA-Eth-Trunk1] mode lacp-static
      [*SwitchA-Eth-Trunk1] peer-link 1
      [*SwitchA-Eth-Trunk1] quit
      [*SwitchA] stp mode rstp
      [*SwitchA] stp v-stp enable
      [*SwitchA] vlan batch 11
      [*SwitchA] interface eth-trunk 10
      [*SwitchA-Eth-Trunk10] mode lacp-static
      [*SwitchA-Eth-Trunk10] port link-type trunk
      [*SwitchA-Eth-Trunk10] port trunk allow-pass vlan 11
      [*SwitchA-Eth-Trunk10] trunkport 10ge 1/0/2 to 1/0/3
      [*SwitchA-Eth-Trunk10] dfs-group 1 m-lag 1
      [*SwitchA-Eth-Trunk10] lacp m-lag priority 10
      [*SwitchA-Eth-Trunk10] lacp m-lag system-id 00e0-fc00-0000
      [*SwitchA-Eth-Trunk10] quit
      [*SwitchA] commit
      # On Switch, create an Eth-Trunk and bind uplink interfaces to the Eth-Trunk.
      <HUAWEI> system-view
      [~HUAWEI] sysname Switch
      [*HUAWEI] commit
      [~Switch] vlan batch 11
      [*Switch] interface eth-trunk 20
      [*Switch-Eth-Trunk20] mode lacp-static
      [*Switch-Eth-Trunk20] port link-type trunk
      [*Switch-Eth-Trunk20] port trunk allow-pass vlan 11
      [*Switch-Eth-Trunk20] trunkport 10ge 1/0/1 to 1/0/4
      [*Switch-Eth-Trunk20] quit
      [*Switch] commit
    2. Configure VRRP.

      # Configure a VRRP group on SwitchA. The configuration on SwitchB is similar to the configuration on SwitchA. For details, see its configuration file. The two switches in the VRRP group work in active-active mode. Configure the same VRID and virtual IP address on the two switches to provide the same virtual IP address and virtual MAC address to the M-LAG.
      [~SwitchA] interface vlanif 11
      [*SwitchA-Vlanif11] ip address 10.2.1.1 24
      [*SwitchA-Vlanif11] vrrp vrid 1 virtual-ip 10.2.1.111
      [*SwitchA-Vlanif11] quit
      [*SwitchA] commit

  2. Configure OSPF to implement IP interworking.

    # Configure SwitchA. The configurations on SwitchB and SwitchC are similar to the configuration on SwitchA. For details, see their configuration files.

    [~SwitchA] vlan batch 12 13
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 12
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/6
    [*SwitchA-10GE1/0/6] port link-type trunk
    [*SwitchA-10GE1/0/6] port trunk allow-pass vlan 13
    [*SwitchA-10GE1/0/6] quit
    [*SwitchA] interface vlanif 12
    [*SwitchA-Vlanif12] ip address 10.3.1.1 24
    [*SwitchA-Vlanif12] quit
    [*SwitchA] interface vlanif 13
    [*SwitchA-Vlanif13] ip address 10.5.1.1 24
    [*SwitchA-Vlanif13] quit
    [*SwitchA] ospf 1
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.5.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] quit
    [*SwitchA-ospf-1] quit
    [*SwitchA] commit
    NOTE:

    If the peer-link is selected as the optimal link to the RP or multicast source by the unicast routing protocol, multicast traffic with the peer-link interface as the outbound interface may fail to be forwarded. To prevent this problem, ensure that the Layer 3 link between the M-LAG master and backup devices has a route cost smaller than or equal to the route cost of the peer-link, so that the Layer 3 link is selected as the optimal route by the unicast routing protocol.

  3. Enable PIM-SM and IGMP on VLANIF interfaces of SwitchA and SwitchB, and enable PIM-SM on VLANIF interfaces of SwitchC, so that multicast forwarding entries can be created on the switches.

    # Configure SwitchA. The configuration on SwitchB is similar to the configuration on SwitchA. For details, see its configuration file.
    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] igmp enable
    [*SwitchA-Vlanif11] quit
    [*SwitchA] interface vlanif 12
    [*SwitchA-Vlanif12] pim sm
    [*SwitchA-Vlanif12] igmp enable
    [*SwitchA-Vlanif12] quit
    [*SwitchA] interface vlanif 13
    [*SwitchA-Vlanif13] pim sm
    [*SwitchA-Vlanif13] igmp enable
    [*SwitchA-Vlanif13] quit
    [*SwitchA] commit
    # Configure SwitchC. Configure VLANIF 15 of SwitchC as a C-BSR and C-RP.
    [~SwitchC] multicast routing-enable
    [*SwitchC] interface vlanif 12
    [*SwitchC-Vlanif12] pim sm
    [*SwitchC-Vlanif12] quit
    [*SwitchC] interface vlanif 14
    [*SwitchC-Vlanif14] pim sm
    [*SwitchC-Vlanif14] quit
    [*SwitchC] interface vlanif 15
    [*SwitchC-Vlanif15] pim sm
    [*SwitchC-Vlanif15] quit
    [*SwitchC] pim
    [*SwitchC-pim] c-bsr vlanif 15
    [*SwitchC-pim] c-rp vlanif 15
    [*SwitchC-pim] quit
    [*SwitchC] commit

  4. Enable the PIM silent function on user-side VLANIF interfaces of SwitchA and SwitchB.

    # Configure SwitchA. The configuration on SwitchB is similar to the configuration on SwitchA. For details, see its configuration file.
    [~SwitchA] interface vlanif 11
    [~SwitchA-Vlanif11] pim silent
    [*SwitchA-Vlanif11] quit
    [*SwitchA] commit

  5. On SwitchA and SwitchB, enable IGMP snooping in the VLANs corresponding to the VLANIF interfaces.

    # Configure SwitchA. The configuration on SwitchB is similar to the configuration on SwitchA. For details, see its configuration file.
    [~SwitchA] igmp snooping enable
    [*SwitchA] vlan 11
    [*SwitchA-vlan11] igmp snooping enable
    [*SwitchA-vlan11] quit
    [*SwitchA] vlan 12
    [*SwitchA-vlan12] igmp snooping enable
    [*SwitchA-vlan12] quit
    [*SwitchA] vlan 13
    [*SwitchA-vlan13] igmp snooping enable
    [*SwitchA-vlan13] quit
    [*SwitchA] commit

  6. Disable STP on the interfaces at both sides of the Layer 3 link between the M-LAG master and backup switches, and specify the VLAN that is not allowed on the peer-link.

    # Configure SwitchA. The configuration on SwitchB is similar to the configuration on SwitchA. For details, see its configuration file.
    [~SwitchA] interface 10ge 1/0/6
    [~SwitchA-10GE1/0/6] stp disable
    [*SwitchA-10GE1/0/6] quit
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] port vlan exclude 13
    [*SwitchA-Eth-Trunk1] quit
    [*SwitchA] commit

  7. Verify the configuration.

    # Run the display dfs-group command on SwitchA to check M-LAG information.

    [~SwitchA] display dfs-group 1 m-lag
    *                : Local node
    Heart beat state : OK
    Node 1 *
      Dfs-Group ID   : 1
      Priority       : 150
      Address        : ip address 10.1.1.1
      State          : Master
      Causation      : -
      System ID      : 0025-9e95-7c31
      SysName        : SwitchA
      Version        : V200R003C00SPC200
      Device Type    : CE6850EI
    Node 2
      Dfs-Group ID   : 1
      Priority       : 120
      Address        : ip address 10.1.1.2
      State          : Backup
      Causation      : -
      System ID      : 0025-9e95-7c11
      SysName        : SwitchB
      Version        : V200R003C00SPC200
      Device Type    : CE6850EI

    The Heart beat state field is OK, indicating that the heartbeat between the two switches is normal. SwitchA, acting as Node 1, has a priority of 150 and is in Master state. SwitchB, acting as Node 2, has a priority of 120 and is in Backup state. The preceding information shows that SwitchA is the M-LAG master device, and SwitchB is the M-LAG backup device.

    # Run the display pim interface command on SwitchA and SwitchB to check the PIM configuration and running status on interfaces.

    [~SwitchA] display pim interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt     DR-Pri     DR-Address
     Vlanif11            up         0       30          1     10.2.1.1 (local)
     Vlanif12            up         1       30          1     10.3.1.2
     Vlanif13            up         1       30          1     10.5.1.2 
    [~SwitchB] display pim interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt     DR-Pri     DR-Address
     Vlanif11            up         0       30          1     10.2.1.2 (local)
     Vlanif14            up         0       30          1     10.4.1.2 
     Vlanif13            up         0       30          1     10.5.1.2 (local)

    According to the preceding information, VLANIF 11 of SwitchA and VLANIF 11 of SwitchB are both DRs; therefore, both SwitchA and SwitchB will send Join messages to the upstream RP.

    # Run the display pim routing-table command on SwitchA, SwitchB, and SwitchC to check the PIM-SM routing tables on them.

    [~SwitchC] display pim routing-table
     VPN-Instance: public net                                          
     Total 1 (*, G) entry; 1 (S, G) entry                              
      
     (*, 225.1.1.1)                                                    
         RP: 10.6.1.1 (local)                                          
         Protocol: pim-sm, Flag: WC                                    
         UpTime: 00:14:45                                              
         Upstream interface: Register                                  
             Upstream neighbor: NULL                                   
             RPF prime neighbor: NULL                                  
         Downstream interface(s) information:                          
         Total number of downstreams: 2
            1: Vlanif12
                 Protocol: pim-sm, UpTime: 00:14:45, Expires: 00:02:45 
            2: Vlanif14
                 Protocol: pim-sm, UpTime: 00:14:45, Expires: 00:02:45 
    
     (10.6.1.2, 225.1.1.1)                                             
         RP: 10.6.1.1 (local)                                          
         Protocol: pim-sm, Flag: SPT LOC ACT                     
         UpTime: 00:15:47                                              
         Upstream interface: Vlanif15                                  
             Upstream neighbor: NULL                                   
             RPF prime neighbor: NULL                                  
         Downstream interface(s) information:                          
         Total number of downstreams: 2
            1: Vlanif12
                 Protocol: pim-sm, UpTime: 00:14:45, Expires: 00:02:45 
            2: Vlanif14
                 Protocol: pim-sm, UpTime: 00:14:45, Expires: 00:02:45 
         

    According to the preceding information, SwitchC has two downstream interfaces VLANIF 12 and VLANIF 14. Because both SwitchA and SwitchB are DRs, data sent from the multicast source is forwarded to the two switches through the two downstream interfaces. In real-world application, the downstream interfaces on SwitchC are determined by the unicast routes from the DRs to the RP.

    [~SwitchA] display pim routing-table
     VPN-Instance: public net                                 
     Total 1 (*, G) entry; 1 (S, G) entry                     
                                                              
     (*, 225.1.1.1)                                           
         RP: 10.6.1.1                                         
         Protocol: pim-sm, Flag: WC                           
         UpTime: 00:18:31                                     
         Upstream interface: Vlanif12                         
             Upstream neighbor: 10.3.1.2                      
             RPF prime neighbor: 10.3.1.2                     
         Downstream interface(s) information:                 
         Total number of downstreams: 1                       
            1: Vlanif11
                 Protocol: igmp, UpTime: 00:18:31, Expires: - 
                                                              
     (10.6.1.2, 225.1.1.1)                                    
         RP: 10.6.1.1                                         
         Protocol: pim-sm, Flag: SPT ACT                      
         UpTime: 00:17:31                                     
         Upstream interface: Vlanif12                         
             Upstream neighbor: 10.3.1.2                      
             RPF prime neighbor: 10.3.1.2                     
         Downstream interface(s) information:                 
         Total number of downstreams: 1                       
            1: Vlanif11
                 Protocol: pim-sm, UpTime: 00:17:31, Expires: - 
    [~SwitchB] display pim routing-table
     VPN-Instance: public net                                 
     Total 1 (*, G) entry; 1 (S, G) entry                     
                                                              
     (*, 225.1.1.1)                                           
         RP: 10.6.1.1                                         
         Protocol: pim-sm, Flag: WC                           
         UpTime: 00:18:59                                     
         Upstream interface: Vlanif14                         
             Upstream neighbor: 10.4.1.2                      
             RPF prime neighbor: 10.4.1.2                     
         Downstream interface(s) information:                 
         Total number of downstreams: 1                       
            1: Vlanif11
                 Protocol: igmp, UpTime: 00:18:59, Expires: - 
                                                              
     (10.6.1.2, 225.1.1.1)                                    
         RP: 10.6.1.1                                         
         Protocol: pim-sm, Flag: SPT ACT                      
         UpTime: 00:17:59                                     
         Upstream interface: Vlanif14                         
             Upstream neighbor: 10.4.1.2                      
             RPF prime neighbor: 10.4.1.2                     
         Downstream interface(s) information:                 
         Total number of downstreams: 1                       
            1: Vlanif11
                 Protocol: pim-sm, UpTime: 00:17:59, Expires: - 

    The preceding information shows that both SwitchA and SwitchB have a downstream interface VLANIF 11. When the M-LAG is functioning normally, both the M-LAG master and backup member interfaces can forward multicast data traffic to the receiver, implementing load sharing. The M-LAG master and backup devices share load according to the following rule: If the last decimal number of the multicast group address is an odd number, such as the address 225.1.1.1, the M-LAG master member interface forwards the multicast data traffic. If the last decimal number of the multicast group address is an even number, such as the address 225.1.1.2, the M-LAG backup member interface forwards the multicast data traffic. In this example, the M-LAG master member interface forwards data traffic to the multicast group address 225.1.1.1.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    dfs-group 1
     priority 150
     source ip 10.1.1.1
    #
    vlan batch 11 to 13
    #
    stp mode rstp
    stp v-stp enable
    #
    multicast routing-enable
    #
    igmp snooping enable
    #
    vlan 11
     igmp snooping enable
    #
    vlan 12
     igmp snooping enable
    #
    vlan 13
     igmp snooping enable
    #
    interface Vlanif11
     ip address 10.2.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.2.1.111
     pim silent
     pim sm
     igmp enable
    #
    interface Vlanif12
     ip address 10.3.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif13
     ip address 10.5.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface MEth0/0/0
     ip address 10.1.1.1 255.255.255.255
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
     port vlan exclude 13
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 1
     lacp m-lag priority 10
     lacp m-lag system-id 00e0-fc00-0000
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 12
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6
     port link-type trunk
     port trunk allow-pass vlan 13
     stp disable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.5.1.0 0.0.0.255
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    dfs-group 1
     priority 120
     source ip 10.1.1.2
    #
    vlan batch 11 13 to 14
    #
    stp mode rstp
    stp v-stp enable
    #
    multicast routing-enable
    #
    igmp snooping enable
    #
    vlan 11
     igmp snooping enable
    #
    vlan 13
     igmp snooping enable
    #
    vlan 14
     igmp snooping enable
    #
    interface Vlanif11
     ip address 10.2.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.2.1.111
     pim silent
     pim sm
     igmp enable
    #
    interface Vlanif13
     ip address 10.5.1.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif14
     ip address 10.4.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface MEth0/0/0
     ip address 10.1.1.2 255.255.255.255
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
     port vlan exclude 13
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
     dfs-group 1 m-lag 1
     lacp m-lag priority 10
     lacp m-lag system-id 00e0-fc00-0000
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 14
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6
     port link-type trunk
     port trunk allow-pass vlan 13
     stp disable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.2 0.0.0.0
      network 10.4.1.0 0.0.0.255
      network 10.5.1.0 0.0.0.255
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 12 14 to 15
    #
    multicast routing-enable
    #
    interface Vlanif12
     ip address 10.3.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif14
     ip address 10.4.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif15
     ip address 10.6.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 12
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 14
    #
    interface 10GE1/0/3
     port default vlan 15
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
      network 10.6.1.0 0.0.0.255
    #
    pim
     c-bsr Vlanif15
     c-rp Vlanif15
    #
    return
    
  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 11
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
    #
    interface 10GE1/0/1
     eth-trunk 20
    #
    interface 10GE1/0/2
     eth-trunk 20
    #
    interface 10GE1/0/3
     eth-trunk 20
    #
    interface 10GE1/0/4
     eth-trunk 20
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 25026

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next