No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Layer 3 Multicast Over VXLAN (in Different AS Domains)

Example for Configuring IPv4 Layer 3 Multicast Over VXLAN (in Different AS Domains)

Networking Requirements

As shown in Figure 14-20, on an IPv4 network, leaf 1, leaf 2, and leaf 3 are deployed as distributed VXLAN gateways. Leaf 1 is in AS100, and leaf 2 and leaf 3 are in AS200. Leaf 1, leaf 2, and leaf 3 use AS300 as the multi-instance process ID of BGP EVPN to establish BGP EVPN peers.

The multicast source is connected to the VXLAN through a Layer 2 sub-interface on leaf 1, and belongs to BD10. Receiver 1 is also connected to the VXLAN through a Layer 2 sub-interface on leaf 1, and belongs to BD20. Receiver 2 is connected to leaf 2 through the customer edge (CE). Layer 3 multicast over VPN is deployed between the CE and leaf 2. (In this example, leaf 2 is directly connected to the CE through a common Layer 3 interface.) Receiver 3 and receiver 4 are connected to the VXLAN through a Layer 2 sub-interface on leaf 3, and belong to BD10 and BD20 respectively. The source, receiver 1, receiver 3, and receiver 4 are on the VXLAN overlay network, and receiver 2 is on the external network. Receiver 1, receiver 2, and receiver 3 implements VOD through specified multicast sources. The VOD group addresses are 232.1.1.1, 232.1.1.2, and 232.1.1.3 respectively. Receiver 4 implements VOD without specifying the multicast source. The multicast group address is 225.1.1.1.

To meet the preceding requirements, configure IPv4 Layer 3 multicast on the VXLAN where distributed gateways are deployed.

Figure 14-20 Networking diagram for configuring IPv4 Layer 3 multicast over VXLAN (in different AS domains)

Table 14-16 Networking information

Device

Interface

IP Address

Leaf1

10GE1/0/1

10.1.1.1/24

10GE1/0/2

10.1.2.1/24

VBDIF10

192.168.10.1/24

VBDIF20

192.168.20.1/24

LoopBack1

1.1.1.1/32

LoopBack2

1.1.1.9/32

LoopBack3

1.1.1.10/32

Leaf2

10GE1/0/1

10.1.1.2/24

10GE1/0/2

10.1.3.1/24

10GE1/0/3

192.168.30.1/24

VBDIF10

192.168.10.2/24

LoopBack1

2.2.2.2/32

LoopBack2

2.2.2.9/32

Leaf3

10GE1/0/1

10.1.2.2/24

10GE1/0/2

10.1.3.2/24

VBDIF10

192.168.10.3/24

VBDIF20

192.168.20.2/24

LoopBack1

3.3.3.3/32

LoopBack2

3.3.3.9/32

CE

10GE1/0/1

192.168.30.2/24

10GE1/0/2

192.168.40.1/24

Configuration Roadmap

Perform configuration under the following guidelines:
  1. Configure each leaf to set up VXLAN tunnels through BGP Ethernet VPN (EVPN), configure the leaves to be distributed gateways, and realize Layer 3 interconnection on the leaf side through VPN routes.

  2. Configure BUM multicast replication for Layer 3 network identifiers (VNIs) of L3VPN instances on each leaf.

  3. Configure BGP MVPN neighbor relationships between leaf 1, leaf 2, and leaf 3.

  4. Configure the VXLAN I-PMSI tunnel on each leaf.

  5. Bind interfaces to L3VPN instances on each leaf, enable PIM SM on the interfaces, and create a VPN multicast routing table.

  6. Configure IGMP on each VBDIF interface and the multicast physical interfaces that connect to user subnets.

  7. Configure Layer 3 multicast over VPN between leaf 2 and the CE.

Data Preparation

To complete the configuration, you need to prepare the following data:

  • VLAN IDs of the multicast source and receivers on the VXLAN overlay network (VLAN 10 and VLAN 20)

  • BD IDs (BD10 and BD20)

  • VNI IDs of the BDs (VNI 10 and VNI 20)

  • L3VPN instance name (mcast1) and the VNI ID of the L3VPN instance (VNI 5010)

  • RD values of the EVPN instances (11:1 and 11:2) and RT values (12:1, 12:2, and 13:1)

  • RD value of the L3VPN instance (1:1), RT value the L3VPN instance (1:1), and RT value used for interoperation between the L3VPN instance and the EVPN instance (13:1)

  • Multicast group address for BUM multicast replication of Layer 3 VNIs of L3VPN instances (225.0.0.1)

  • MVPN ID of each leaf (IP address of the Loopback2 interface)

  • Local VPN instance ID of each leaf (1)

  • Static RP of the public network instance (1.1.1.1) and that of the VPN instance (1.1.1.10)

Procedure

  1. Configure the IP address and the unicast routing protocol for each switch interface.

    # Configure IP addresses and masks for switch interfaces according to Table 14-16. The configurations of leaf 2, leaf 3, and CE are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1
    [*HUAWEI] commit
    [~Leaf1] interface loopback 1
    [*Leaf1-LoopBack1] ip address 1.1.1.1 32
    [*Leaf1-LoopBack1] quit
    [*Leaf1] interface loopback 2
    [*Leaf1-LoopBack2] ip address 1.1.1.9 32
    [*Leaf1-LoopBack2] quit
    [*Leaf1] interface loopback 3
    [*Leaf1-LoopBack3] ip address 1.1.1.10 32
    [*Leaf1-LoopBack3] quit
    [*Leaf1] interface 10ge 1/0/1
    [*Leaf1-10GE1/0/1] undo portswitch
    [*Leaf1-10GE1/0/1] ip address 10.1.1.1 24
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] interface 10ge 1/0/2
    [*Leaf1-10GE1/0/2] undo portswitch
    [*Leaf1-10GE1/0/2] ip address 10.1.2.1 24
    [*Leaf1-10GE1/0/2] quit
    [*Leaf1] commit

  2. Configure the VXLAN.

    # If the CE6870EI and CE6875EI are used as VXLAN gateways, you need to configure the VXLAN tunnel mode and enable the VXLAN ACL extension function before configuring VXLAN. If other models are used as VXLAN gateways, skip this step. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    [~Leaf1] ip tunnel mode vxlan
    [*Leaf1] assign forward nvo3 acl extend enable
    Info: The configuration will take effect after system reboot.
    [*Leaf1] commit
    NOTE:
    • After configuring the VXLAN tunnel mode and enabling the VXLAN ACL extension function, you need to save the configuration and restart the device to make the configuration take effect. You are advised to save all the configurations and restart the device after all the configurations are complete.

    • For more restrictions on VXLAN configurations, see CloudEngine 8800, 7800, 6800, and 5800 Series Switches Configuration Guide-VXLAN.

    # Configure BGP for the VXLAN underlay network.
    • Configure leaf 1.
      [~Leaf1] bgp 100
      [*Leaf1-bgp] peer 10.1.1.2 as-number 200
      [*Leaf1-bgp] peer 10.1.2.2 as-number 200
      [*Leaf1-bgp] network 1.1.1.1 32
      [*Leaf1-bgp] network 1.1.1.9 32
      [*Leaf1-bgp] quit
      [*Leaf1] commit
    • Configure leaf 2.
      [~Leaf2] bgp 200
      [*Leaf2-bgp] peer 10.1.1.1 as-number 100
      [*Leaf2-bgp] peer 10.1.3.2 as-number 200
      [*Leaf2-bgp] network 2.2.2.2 32
      [*Leaf2-bgp] network 2.2.2.9 32
      [*Leaf2-bgp] quit
      [*Leaf2] commit
    • Configure leaf 3.
      [~Leaf3] bgp 200
      [*Leaf3-bgp] peer 10.1.2.1 as-number 100
      [*Leaf3-bgp] peer 10.1.3.1 as-number 200
      [*Leaf3-bgp] network 3.3.3.3 32
      [*Leaf3-bgp] network 3.3.3.9 32
      [*Leaf3-bgp] quit
      [*Leaf3] commit

    # Configure service access points on leaf 1 and leaf 3. The configurations of leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file. Leaf 2 is directly connected to the CE through a common Layer 3 interface. Therefore, no service access point needs to be configured on leaf 2.

    [~Leaf1] bridge-domain 10
    [*Leaf1-bd10] quit
    [*Leaf1] interface 10ge 1/0/3.1 mode l2
    [*Leaf1-10GE1/0/3.1] encapsulation dot1q vid 10
    [*Leaf1-10GE1/0/3.1] bridge-domain 10
    [*Leaf1-10GE1/0/3.1] quit
    [*Leaf1] bridge-domain 20
    [*Leaf1-bd20] quit
    [*Leaf1] interface 10ge 1/0/4.1 mode l2
    [*Leaf1-10GE1/0/4.1] encapsulation dot1q vid 20
    [*Leaf1-10GE1/0/4.1] bridge-domain 20
    [*Leaf1-10GE1/0/4.1] quit
    [*Leaf1] commit

    # Configure BGP EVPN on each leaf as the VXLAN control plane protocol. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    [~Leaf1] evpn-overlay enable
    [*Leaf1] commit

    # Configure BGP EVPN peers on each leaf as the VXLAN control plane protocol. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    [~Leaf1] bgp 300 instance evpn1
    [*Leaf1-bgp-instance-evpn1] peer 2.2.2.9 as-number 300
    [*Leaf1-bgp-instance-evpn1] peer 2.2.2.9 connect-interface LoopBack2
    [*Leaf1-bgp-instance-evpn1] peer 3.3.3.9 as-number 300
    [*Leaf1-bgp-instance-evpn1] peer 3.3.3.9 connect-interface LoopBack2
    [*Leaf1-bgp-instance-evpn1] l2vpn-family evpn
    [*Leaf1-bgp-instance-evpn1-af-evpn] peer 2.2.2.9 enable
    [*Leaf1-bgp-instance-evpn1-af-evpn] peer 3.3.3.9 enable
    [*Leaf1-bgp-instance-evpn1-af-evpn] quit
    [*Leaf1-bgp-instance-evpn1] quit
    [*Leaf1] commit

    # Configure L3VPN instances and EVPN instances on each leaf. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    [~Leaf1] ip vpn-instance mcast1
    [*Leaf1-vpn-instance-mcast1] vxlan vni 5010
    [*Leaf1-vpn-instance-mcast1] ipv4-family
    [*Leaf1-vpn-instance-mcast1-af-ipv4] route-distinguisher 1:1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] vpn-target 1:1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] vpn-target 13:1 evpn
    [*Leaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf1-vpn-instance-mcast1] quit
    [*Leaf1] bridge-domain 10
    [*Leaf1-bd10] vxlan vni 10
    [*Leaf1-bd10] evpn
    [*Leaf1-bd10-evpn] route-distinguisher 11:1
    [*Leaf1-bd10-evpn] vpn-target 12:1
    [*Leaf1-bd10-evpn] vpn-target 13:1
    [*Leaf1-bd10-evpn] quit
    [*Leaf1-bd10] quit
    [*Leaf1] bridge-domain 20
    [*Leaf1-bd20] vxlan vni 20
    [*Leaf1-bd20] evpn
    [*Leaf1-bd20-evpn] route-distinguisher 11:2
    [*Leaf1-bd20-evpn] vpn-target 12:2
    [*Leaf1-bd20-evpn] vpn-target 13:1
    [*Leaf1-bd20-evpn] quit
    [*Leaf1-bd20] quit
    [*Leaf1] commit
    # Configure inbound replication on each leaf. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.
    [~Leaf1] interface nve 1
    [*Leaf1-Nve1] source 1.1.1.9
    [*Leaf1-Nve1] vni 5010 head-end peer-list protocol bgp
    [*Leaf1-Nve1] quit
    [*Leaf1] commit
    # Configure the VXLAN Layer 3 gateways on each leaf.
    • If the CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI is used as the Layer 3 VXLAN gateway, configure the service loopback interface on the device before configuring a VXLAN Layer 3 gateway. If other models are used as VXLAN Layer 3 gateways, skip this step. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

      [~Leaf1] interface eth-trunk 1
      [*Leaf1-Eth-Trunk1] service type tunnel
      [*Leaf1-Eth-Trunk1] quit
      [*Leaf1] interface 10ge 1/0/5
      [*Leaf1-10GE1/0/5] eth-trunk 1
      [*Leaf1-10GE1/0/5] quit
      [*Leaf1] commit
      NOTE:
      • A member interface must be an idle physical interface that does not carry any service. There is no requirement for the status of a physical interface.
      • Ensure that the bandwidth of the Eth-Trunk interface (multicast loopback interface) is at least twice the bandwidth required for transmitting traffic on the Layer 3 VXLAN gateway. For example, if traffic is sent from users to the gateway across the VXLAN network at a rate of 10 Gbit/s, add two 10GE interfaces to the Eth-Trunk interface (multicast loopback interface) as the service loopback interfaces.
    • Configure the VXLAN Layer 3 gateway on leaf 1.
      [~Leaf1] interface vbdif 10
      [*Leaf1-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf1-Vbdif10] ip address 192.168.10.1 24
      [*Leaf1-Vbdif10] vxlan anycast-gateway enable
      [*Leaf1-Vbdif10] arp collect host enable
      [*Leaf1-Vbdif10] quit
      [*Leaf1] interface vbdif 20
      [*Leaf1-Vbdif20] ip binding vpn-instance mcast1
      [*Leaf1-Vbdif20] ip address 192.168.20.1 24
      [*Leaf1-Vbdif20] vxlan anycast-gateway enable
      [*Leaf1-Vbdif20] arp collect host enable
      [*Leaf1-Vbdif20] quit
      [*Leaf1] commit
    • Configure the VXLAN Layer 3 gateway on leaf 2. Receiver 2 is connected to leaf 2 through the CE, and leaf 2 does not need to advertise host routes. Therefore, leaf 2 does not need to be configured to collect host information (the arp collect host enable command).
      [~Leaf2] interface vbdif 10
      [*Leaf2-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf2-Vbdif10] ip address 192.168.10.2 24
      [*Leaf2-Vbdif10] vxlan anycast-gateway enable
      [*Leaf2-Vbdif10] quit
      [*Leaf2] commit
    • Configure the VXLAN Layer 3 gateway on leaf 3.
      [~Leaf3] interface vbdif 10
      [*Leaf3-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf3-Vbdif10] ip address 192.168.10.3 24
      [*Leaf3-Vbdif10] vxlan anycast-gateway enable
      [*Leaf3-Vbdif10] arp collect host enable
      [*Leaf3-Vbdif10] quit
      [*Leaf3] interface vbdif 20
      [*Leaf3-Vbdif20] ip binding vpn-instance mcast1
      [*Leaf3-Vbdif20] ip address 192.168.20.2 24
      [*Leaf3-Vbdif20] vxlan anycast-gateway enable
      [*Leaf3-Vbdif20] arp collect host enable
      [*Leaf3-Vbdif20] quit
      [*Leaf3] commit
    # Configure BGP on leaf 1 and leaf 3 to advertise IRB routes to neighbors.
    • Configure leaf 1.
      [~Leaf1] bgp 300 instance evpn1
      [~Leaf1-bgp-instance-evpn1] l2vpn-family evpn
      [~Leaf1-bgp-instance-evpn1-af-evpn] peer 2.2.2.9 advertise irb
      [*Leaf1-bgp-instance-evpn1-af-evpn] peer 3.3.3.9 advertise irb
      [*Leaf1-bgp-instance-evpn1-af-evpn] quit
      [*Leaf1-bgp-instance-evpn1] quit
      [*Leaf1] commit
    • Configure leaf 3.
      [~Leaf3] bgp 300 instance evpn1
      [~Leaf3-bgp-instance-evpn1] l2vpn-family evpn
      [~Leaf3-bgp-instance-evpn1-af-evpn] peer 1.1.1.9 advertise irb
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 2.2.2.9 advertise irb
      [*Leaf3-bgp-instance-evpn1-af-evpn] quit
      [*Leaf3-bgp-instance-evpn1] quit
      [*Leaf3] commit
    # Configure BGP on leaf 1 and leaf 2 to advertise IP prefix routes to neighbors.
    • Configure leaf 1.
      [~Leaf1] bgp 100
      [~Leaf1-bgp] ipv4-family vpn-instance mcast1
      [*Leaf1-bgp-mcast1] advertise l2vpn evpn
      [*Leaf1-bgp-mcast1] network 1.1.1.10 32
      [*Leaf1-bgp-mcast1] quit
      [*Leaf1-bgp] quit
      [*Leaf1] commit
    • Configure leaf 2.
      [~Leaf2] bgp 200
      [~Leaf2-bgp] ipv4-family vpn-instance mcast1
      [*Leaf2-bgp-mcast1] advertise l2vpn evpn
      [*Leaf2-bgp-mcast1] quit
      [*Leaf2-bgp] quit
      [*Leaf2] commit

    # Configure public network Layer 3 multicast on each leaf. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    [~Leaf1] multicast routing-enable
    [*Leaf1] interface loopback 1
    [*Leaf1-LoopBack1] pim sm
    [*Leaf1-LoopBack1] quit
    [*Leaf1] interface 10ge 1/0/1
    [*Leaf1-10GE1/0/1] pim sm
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] interface 10ge 1/0/2
    [*Leaf1-10GE1/0/2] pim sm
    [*Leaf1-10GE1/0/2] quit
    [*Leaf1] pim
    [*Leaf1-pim] static-rp 1.1.1.1
    [*Leaf1-pim] quit
    [*Leaf1] commit

    # Configure BUM multicast replication for Layer 3 VNIs of L3VPN instances on each leaf. The configurations of leaf 2 and leaf 3 are similar to the configurations of leaf 1, and are not mentioned here. For details, see the configuration file.

    [~Leaf1] interface nve 1
    [~Leaf1-Nve1] vni 5010 mcast-group 225.0.0.1
    [*Leaf1-Nve1] quit
    [*Leaf1] commit

    After the preceding configurations are complete, VXLAN tunnels can be established between leaves. The display vxlan tunnel command can be run to query VXLAN tunnel information. For example, in the command output of leaf 1, the State field is up, indicating that the VXLAN tunnel is reachable. When the Type field is static, the destination IP address is statically configured. If the Type field is dynamic, the destination IP address is dynamically learned through the protocol.

    [~Leaf1] display vxlan tunnel
    Number of vxlan tunnel : 3
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  1.1.1.9               225.0.0.1             up     static   04:30:52  
    4026531843  1.1.1.9               3.3.3.9               up     dynamic  04:30:52  
    4026531845  1.1.1.9               2.2.2.9               up     dynamic  04:30:52 

  3. Configure BGP MVPN neighbors on each leaf.

    • Configure leaf 1.
      [~Leaf1] bgp 100
      [~Leaf1-bgp] peer 2.2.2.2 as-number 200
      [*Leaf1-bgp] peer 2.2.2.2 connect-interface LoopBack1
      [*Leaf1-bgp] peer 2.2.2.2 ebgp-max-hop 255
      [*Leaf1-bgp] peer 3.3.3.3 as-number 200
      [*Leaf1-bgp] peer 3.3.3.3 connect-interface LoopBack1
      [*Leaf1-bgp] peer 3.3.3.3 ebgp-max-hop 255
      [*Leaf1-bgp] ipv4-family mvpn
      [*Leaf1-bgp-af-mvpn] peer 2.2.2.2 enable
      [*Leaf1-bgp-af-mvpn] peer 3.3.3.3 enable
      [*Leaf1-bgp-af-mvpn] quit
      [*Leaf1-bgp] quit
      [*Leaf1] commit
    • Configure leaf 2.
      [~Leaf2] bgp 200
      [~Leaf2-bgp] peer 1.1.1.1 as-number 100
      [*Leaf2-bgp] peer 1.1.1.1 connect-interface LoopBack1
      [*Leaf2-bgp] peer 1.1.1.1 ebgp-max-hop 255
      [*Leaf2-bgp] peer 3.3.3.3 as-number 200
      [*Leaf2-bgp] peer 3.3.3.3 connect-interface LoopBack1
      [*Leaf2-bgp] ipv4-family mvpn
      [*Leaf2-bgp-af-mvpn] peer 1.1.1.1 enable
      [*Leaf2-bgp-af-mvpn] peer 3.3.3.3 enable
      [*Leaf2-bgp-af-mvpn] quit
      [*Leaf2-bgp] quit
      [*Leaf2] commit
    • Configure leaf 3.
      [~Leaf3] bgp 200
      [~Leaf3-bgp] peer 1.1.1.1 as-number 100
      [*Leaf3-bgp] peer 1.1.1.1 connect-interface LoopBack1
      [*Leaf3-bgp] peer 1.1.1.1 ebgp-max-hop 255
      [*Leaf3-bgp] peer 2.2.2.2 as-number 200
      [*Leaf3-bgp] peer 2.2.2.2 connect-interface LoopBack1
      [*Leaf3-bgp] ipv4-family mvpn
      [*Leaf3-bgp-af-mvpn] peer 1.1.1.1 enable
      [*Leaf3-bgp-af-mvpn] peer 2.2.2.2 enable
      [*Leaf3-bgp-af-mvpn] quit
      [*Leaf3-bgp] quit
      [*Leaf3] commit

  4. Configure the VXLAN I-PMSI tunnel on each leaf.

    # Configure leaf 1. The MVPN ID configured on the distributed VXLAN gateway must be the VTEP IP address of the current gateway.

    [~Leaf1] multicast mvpn 1.1.1.9
    [*Leaf1] ip vpn-instance mcast1
    [*Leaf1-vpn-instance-mcast1] ipv4-family
    [*Leaf1-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf1-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] auto-discovery inter-as
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] spt-only mode
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf1-vpn-instance-mcast1] quit
    [*Leaf1] commit

    # Configure leaf 2.

    [~Leaf2] multicast mvpn 2.2.2.9
    [*Leaf2] ip vpn-instance mcast1
    [*Leaf2-vpn-instance-mcast1] ipv4-family
    [*Leaf2-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf2-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf2-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] auto-discovery inter-as
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf2-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf2-vpn-instance-mcast1] quit
    [*Leaf2] commit

    # Configure leaf 3. Receiver 4 on the leaf 3 side does not have a specified multicast source, that is, it adopts the (*, G) join mode. Therefore, the establishment mode of the PIM SM multicast distribution tree (MDT) needs to be specified for leaf 3 and leaf 1 on the multicast source side. In this example, the spt-only mode (not crossing the public network) mode is used.

    [~Leaf3] multicast mvpn 3.3.3.9
    [*Leaf3] ip vpn-instance mcast1
    [*Leaf3-vpn-instance-mcast1] ipv4-family
    [*Leaf3-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf3-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf3-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] auto-discovery inter-as
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] spt-only mode
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf3-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf3-vpn-instance-mcast1] quit
    [*Leaf3] commit

  5. Configure PIM SM and IGMP on the VBDIF interface.

    # Configure leaf 1.

    [~Leaf1] interface vbdif 10
    [~Leaf1-Vbdif10] pim sm
    [*Leaf1-Vbdif10] igmp enable
    [*Leaf1-Vbdif10] quit
    [*Leaf1] interface vbdif 20
    [*Leaf1-Vbdif20] pim sm
    [*Leaf1-Vbdif20] igmp enable
    [*Leaf1-Vbdif20] igmp version 3
    [*Leaf1-Vbdif20] quit
    [*Leaf1] commit

    # Configure leaf 2.

    [~Leaf2] interface vbdif 10
    [~Leaf2-Vbdif10] pim sm
    [*Leaf2-Vbdif10] igmp enable
    [*Leaf2-Vbdif10] igmp version 3
    [*Leaf2-Vbdif10] quit
    [*Leaf2] commit

    # Configure leaf 3.

    [~Leaf3] interface vbdif 10
    [~Leaf3-Vbdif10] pim sm
    [*Leaf3-Vbdif10] igmp enable
    [*Leaf3-Vbdif10] igmp version 3
    [*Leaf3-Vbdif10] quit
    [*Leaf3] interface vbdif 20
    [*Leaf3-Vbdif20] pim sm
    [*Leaf3-Vbdif20] igmp enable
    [*Leaf3-Vbdif20] quit
    [*Leaf3] commit

  6. Configure VPN static RP on leaf 1 and leaf 3.

    # Configure leaf 1.

    [~Leaf1] interface loopback 3
    [~Leaf1-LoopBack3] ip binding vpn-instance mcast1
    [*Leaf1-LoopBack3] ip address 1.1.1.10 32
    [*Leaf1-LoopBack3] pim sm
    [*Leaf1-LoopBack3] quit
    [*Leaf1] pim vpn-instance mcast1
    [*Leaf1-pim-mcast1] static-rp 1.1.1.10
    [*Leaf1-pim-mcast1] quit
    [*Leaf1] commit

    # Configure leaf 3.

    [*Leaf3] pim vpn-instance mcast1
    [*Leaf3-pim-mcast1] static-rp 1.1.1.10
    [*Leaf3-pim-mcast1] quit
    [*Leaf3] commit

  7. Configure Layer 3 multicast over VPN between leaf 2 and the CE.

    # Configure leaf 2.

    [~Leaf2] interface 10ge 1/0/3
    [~Leaf2-10GE1/0/3] ip binding vpn-instance mcast1
    [*Leaf2-10GE1/0/3] ip address 192.168.30.1 24
    [*Leaf2-10GE1/0/3] pim sm
    [*Leaf2-10GE1/0/3] igmp enable
    [*Leaf2-10GE1/0/3] igmp version 3
    [*Leaf2-10GE1/0/3] quit
    [*Leaf2] ip route-static vpn-instance mcast1 192.168.40.1 24 10ge 1/0/3
    [*Leaf2] bgp 200
    [*Leaf2-bgp] ipv4-family vpn-instance mcast1
    [*Leaf2-bgp-mcast1] import-route static
    [*Leaf2-bgp-mcast1] quit
    [*Leaf2-bgp] quit
    [*Leaf2] commit

    # Configure the CE.

    [~CE] multicast routing-enable
    [*CE] interface 10ge 1/0/1
    [*CE-10GE1/0/1] pim sm
    [*CE-10GE1/0/1] quit
    [*CE] interface 10ge 1/0/2
    [*CE-10GE1/0/2] pim sm
    [*CE-10GE1/0/2] igmp enable
    [*CE-10GE1/0/2] igmp version 3
    [*CE-10GE1/0/2] quit
    [*CE] ip route-static 192.168.10.1 24 10ge 1/0/1
    [*CE] commit

  8. Verify the configuration.

    # Run the display bgp mvpn all peer command on each leaf to query the BGP MVPN neighbor information. For example, the command output of leaf 1 is as follows:

    [~Leaf1] display bgp mvpn all peer
     BGP local router ID        : 1.1.1.1
     Local AS number            : 100
     Total number of peers      : 2
     Peers in established state : 2
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      2.2.2.2         4         100     1860     1859     0 04:43:30 Established        1
      3.3.3.3         4         100     3219     3221     0 04:43:39 Established        1
    # After each receiver joins a multicast group, run the display pim vpn-instance mcast1 routing-table command on each leaf to query the information about the VPN PIM routing table.
    • According to the command output of leaf 1, receiver 1 (local) joins the multicast group through IGMP, and receiver 2 (remote) and receiver 3 (remote) join the multicast group through BGP.
      [~Leaf1] display pim vpn-instance mcast1 routing-table
       VPN-Instance: mcast1
       Total 1 (*, G) entry; 4 (S, G) entries
      
       (*, 225.1.1.1)
           RP: 1.1.1.10 (local)
           Protocol: pim-sm, Flag: WC
           UpTime: 04:43:57
           Upstream interface: Register
               Upstream neighbor: NULL
               RPF prime neighbor: NULL
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: pseudo
                   Protocol: BGP, UpTime: 04:43:57, Expires: -
       
       (192.168.10.9, 225.1.1.1)
           RP: 1.1.1.10 (local)
           Protocol: pim-sm, Flag: SPT LOC ACT
           UpTime: 04:43:57
           Upstream interface: 10GE1/0/3.1
               Upstream neighbor: NULL
               RPF prime neighbor: NULL
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: pseudo
                   Protocol: pim-sm, UpTime: 04:43:57, Expires: -
      
       (192.168.10.9, 232.1.1.1)
           Protocol: pim-ssm, Flag: SPT LOC ACT SG_RCVR 
           UpTime: 04:44:12
           Upstream interface: Vbdif10
               Upstream neighbor: NULL
               RPF prime neighbor: NULL
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: Vbdif20
                   Protocol: igmp, UpTime: 04:44:12, Expires: -
      
       (192.168.10.9, 232.1.1.2)
           Protocol: pim-ssm, Flag: SPT LOC ACT
           UpTime: 04:44:12
           Upstream interface: Vbdif10
               Upstream neighbor: NULL
               RPF prime neighbor: NULL
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: pseudo
                   Protocol: BGP, UpTime: 04:44:12, Expires: -
                      
       (192.168.10.9, 232.1.1.3)
           Protocol: pim-ssm, Flag: SPT LOC ACT
           UpTime: 04:43:52
           Upstream interface: Vbdif10
               Upstream neighbor: NULL
               RPF prime neighbor: NULL
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: pseudo
                   Protocol: BGP, UpTime: 04:43:52, Expires: -
      
    • According to the command output of leaf 2, the upstream interface of the VPN PIM router entry corresponding to receiver 2 is Through-BGP, and the downstream outbound interface is 10GE1/0/3.
      [~Leaf2] display pim vpn-instance mcast1 routing-table
       VPN-Instance: mcast1
       Total 1 (S, G) entry
       
       (192.168.10.9, 232.1.1.2)
           Protocol: pim-ssm, Flag: SPT ACT 
           UpTime: 04:43:52
           Upstream interface: through-BGP
               Upstream neighbor: 1.1.1.1
               RPF prime neighbor: 1.1.1.1
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: 10GE1/0/3
                   Protocol: igmp, UpTime: 04:43:52, Expires: -
    • According to the command output of leaf 3, the upstream interface of the VPN PIM router entry corresponding to receiver 3 is Through-BGP, and the downstream outbound interface is VBDIF10. No multicast source is specified for receiver 4. The VPN PIM router entry corresponding to receiver 4 is the (*, G) entry, and the downstream outbound interface is VBDIF20.
      [~Leaf3] display pim vpn-instance mcast1 routing-table
       VPN-Instance: mcast1
       Total 1 (*, G) entry; 2 (S, G) entries
       
       (*, 225.1.1.1)
           RP: 1.1.1.10 
           Protocol: pim-sm, Flag: WC
           UpTime: 04:43:57
           Upstream interface: through-BGP
               Upstream neighbor: 1.1.1.1
               RPF prime neighbor: 1.1.1.1
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: Vbdif20
                   Protocol: igmp, UpTime: 04:43:57, Expires: -
       
       (192.168.10.9, 225.1.1.1)
           RP: 1.1.1.10 
           Protocol: pim-sm, Flag: SPT ACT
           UpTime: 04:43:57
           Upstream interface: through-BGP
               Upstream neighbor: 1.1.1.1
               RPF prime neighbor: 1.1.1.1
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: Vbdif20
                   Protocol: pim-sm, UpTime: 04:43:57, Expires: -
       
       (192.168.10.9, 232.1.1.3)
           Protocol: pim-ssm, Flag: SPT ACT
           UpTime: 04:44:50
           Upstream interface: through-BGP
               Upstream neighbor: 1.1.1.1
               RPF prime neighbor: 1.1.1.1
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: Vbdif10
                   Protocol: igmp, UpTime: 04:44:50, Expires: -

Configuration File

  • Leaf1 Configuration file

    #
    sysname Leaf1
    #
    assign forward nvo3 acl extend enable //This step is required only for the CE6870EI and CE6875EI.
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 1.1.1.9
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       spt-only mode
       auto-discovery inter-as
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #               
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    bridge-domain 20
     vxlan vni 20   
     evpn           
      route-distinguisher 11:2
      vpn-target 12:2 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:2 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.1 255.255.255.0
     pim sm         
     igmp enable    
     vxlan anycast-gateway enable
     arp collect host enable
    #               
    interface Vbdif20
     ip binding vpn-instance mcast1
     ip address 192.168.20.1 255.255.255.0
     pim sm         
     igmp enable    
     igmp version 3    
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk1 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     service type tunnel
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.2.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/3.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/4.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    #
    interface 10GE1/0/5 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     eth-trunk 1
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface LoopBack2
     ip address 1.1.1.9 255.255.255.255
    #
    interface LoopBack3
     ip binding vpn-instance mcast1
     ip address 1.1.1.10 255.255.255.255
     pim sm
    #                
    interface Nve1  
     source 1.1.1.9 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
    #
    bgp 100         
     peer 2.2.2.2 as-number 200
     peer 2.2.2.2 ebgp-max-hop 255
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 200
     peer 3.3.3.3 ebgp-max-hop 255
     peer 3.3.3.3 connect-interface LoopBack1
     peer 10.1.1.2 as-number 200
     peer 10.1.2.2 as-number 200
     #              
     ipv4-family unicast
      network 1.1.1.1 255.255.255.255
      network 1.1.1.9 255.255.255.255
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
      peer 10.1.1.2 enable
      peer 10.1.2.2 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #               
     ipv4-family vpn-instance mcast1
      network 1.1.1.10 255.255.255.255
      advertise l2vpn evpn
     #              
    bgp 300 instance evpn1
     peer 2.2.2.9 as-number 300
     peer 2.2.2.9 connect-interface LoopBack2
     peer 3.3.3.9 as-number 300
     peer 3.3.3.9 connect-interface LoopBack2
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.9 enable
      peer 2.2.2.9 advertise irb
      peer 3.3.3.9 enable
      peer 3.3.3.9 advertise irb
    #
    pim
     static-rp 1.1.1.1
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • Leaf2 Configuration file

    #
    sysname Leaf2
    #
    assign forward nvo3 acl extend enable //This step is required only for the CE6870EI and CE6875EI.
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 2.2.2.9
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       auto-discovery inter-as
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #               
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.2 255.255.255.0
     pim sm         
     igmp enable    
     igmp version 3    
     vxlan anycast-gateway enable
    #
    interface Eth-Trunk1 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     service type tunnel
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.3.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/3
     undo portswitch
     ip binding vpn-instance mcast1
     ip address 192.168.30.1 255.255.255.0
     pim sm
     igmp enable
     igmp version 3    
    #
    interface 10GE1/0/4 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     eth-trunk 1
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #               
    interface LoopBack2
     ip address 2.2.2.9 255.255.255.255
    #
    interface Nve1  
     source 2.2.2.9 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
    #
    bgp 200         
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 ebgp-max-hop 255
     peer 1.1.1.1 connect-interface LoopBack1
     peer 3.3.3.3 as-number 200
     peer 3.3.3.3 connect-interface LoopBack1
     peer 10.1.1.1 as-number 100
     peer 10.1.3.2 as-number 200
     #              
     ipv4-family unicast
      network 2.2.2.2 255.255.255.255
      network 2.2.2.9 255.255.255.255
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
      peer 10.1.1.1 enable
      peer 10.1.3.2 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
     #              
     ipv4-family vpn-instance mcast1
      import-route static
      advertise l2vpn evpn
     #              
    bgp 300 instance evpn1
     peer 1.1.1.9 as-number 300
     peer 1.1.1.9 connect-interface LoopBack2
     peer 3.3.3.9 as-number 300
     peer 3.3.3.9 connect-interface LoopBack2
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.9 enable
      peer 3.3.3.9 enable
    #
    pim
     static-rp 1.1.1.1
    #               
    ip route-static vpn-instance mcast1 192.168.40.0 255.255.255.0 10GE1/0/3
    #
    rturn
    
  • Leaf3 Configuration file

    #
    sysname Leaf3
    #
    assign forward nvo3 acl extend enable //This step is required only for the CE6870EI and CE6875EI.
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 3.3.3.9
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       rpt-spt mode
       auto-discovery inter-as
       ipmsi-tunnel  
        vxlan static
     vxlan vni 5010 
    #
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    bridge-domain 20
     vxlan vni 20   
     evpn           
      route-distinguisher 11:2
      vpn-target 12:2 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:2 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.3 255.255.255.0
     pim sm         
     igmp enable
     igmp version 3    
     vxlan anycast-gateway enable
     arp collect host enable
    #               
    interface Vbdif20
     ip binding vpn-instance mcast1
     ip address 192.168.20.2 255.255.255.0
     pim sm         
     igmp enable    
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk1 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     service type tunnel
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.2.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.3.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/3.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/4.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    #
    interface 10GE1/0/5 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     eth-trunk 1
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #               
    interface LoopBack2
     ip address 3.3.3.9 255.255.255.255
    #
    interface Nve1  
     source 3.3.3.9 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
    #               
    bgp 200         
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 ebgp-max-hop 255
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 200
     peer 2.2.2.2 connect-interface LoopBack1
     peer 10.1.2.1 as-number 100
     peer 10.1.3.1 as-number 200
     #              
     ipv4-family unicast
      network 3.3.3.3 255.255.255.255
      network 3.3.3.9 255.255.255.255
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 10.1.2.1 enable
      peer 10.1.3.1 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #              
    bgp 300 instance evpn1
     peer 1.1.1.9 as-number 300
     peer 1.1.1.9 connect-interface LoopBack2
     peer 2.2.2.9 as-number 300
     peer 2.2.2.9 connect-interface LoopBack2
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.9 enable
      peer 1.1.1.9 advertise irb
      peer 2.2.2.9 enable
      peer 2.2.2.9 advertise irb
    #               
    pim
     static-rp 1.1.1.1
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • CE Configuration file

    #
    sysname CE
    #
    multicast routing-enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.30.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.40.1 255.255.255.0
     pim sm         
     igmp enable
     igmp version 3    
    #
    ip route-static 192.168.10.0 255.255.255.0 10GE1/0/1
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 30722

Downloads: 36

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next