No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Static IPv4 Multicast Group on an Interface

Example for Configuring a Static IPv4 Multicast Group on an Interface

Networking Requirements

In Figure 2-17, users are located on network segments N1 and N2. On the Protocol Independent Multicast (PIM) network, SwitchA connects to network segment N1, whereas SwitchB and SwitchC connect to network segment N2. The PIM network uses multicast addresses 225.1.1.1 through 225.1.1.5 to transmit video streams.

HostA on N1 and HostC and HostD on N2 want to receive video streams in multicast mode. HostA wants to receive data of group 225.1.1.1 for a long time, whereas HostC and HostD do not have such requirements.

Figure 2-17 Network diagram for static multicast group configuration

Configuration Roadmap

Based on the requirement of HostA, you need to configure static multicast group 225.1.1.1 on SwitchA's interface connected to N1. The configuration roadmap is as follows:

  1. To ensure normal operating of the multicast routing protocol, configure a unicast routing protocol on the network to implement IP interworking. Multicast routing protocols are dependent on unicast routing protocols.

  2. To enable the switches to forward video streams to the hosts in multicast mode, configure basic multicast functions on the switches.

  3. To enable HostA to receive data of group 225.1.1.1 in a long time, statically bind SwitchA's interface connected to N1 to this group.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each switch.

    # Configure IP addresses and masks for switch interfaces according to Figure 2-17. Configure Open Shortest Path First (OSPF) on the switches to implement IP interworking and dynamic route update. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here. See Configuration Files.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 11
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 11
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.110.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] ip address 192.168.1.1 24
    [*SwitchA-Vlanif11] quit
    [*SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Enable IP multicast routing on each switch and enable Protocol Independent Multicast Sparse Mode (PIM-SM) on all interfaces.

    # Enable IP multicast routing on SwitchA and enable PIM-SM on all its interfaces. The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here. See Configuration Files.

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 11
    [~SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] commit
    [~SwitchA-Vlanif11] quit
    

  3. Configure a static rendezvous point (RP).

    # Configure a static RP on SwitchA. Specify VLANIF40 of SwitchD as the static RP. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here. See Configuration Files.

    [~SwitchA] pim
    [*SwitchA-pim] static-rp 192.168.4.1
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit
    

  4. On SwitchA, SwitchB, and SwitchC, enable IGMP on the interfaces connected to the receiver network segments.

    # Enable IGMP on VLANIF10 of SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here. See Configuration Files.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  5. Statically bind VLANIF10 of SwitchA to group 225.1.1.1 so that hosts connected to VLANIF10 can receive stable multicast data sent to this group.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp static-group 225.1.1.1
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  6. Verify the configuration.

    # Run the display igmp interface command to check the IGMP configuration and running status on each interface. The IGMP command output on VLANIF20 of SwitchB is as follows:

    [~SwitchB] display igmp interface vlanif 20
    Interface information of VPN instance: public net
     Vlanif20(10.110.2.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: none 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.2.1 (this router)
      Total 2 IGMP Groups reported

    The command output shows that IGMP is enabled on VLANIF20 of SwitchB.

    # Run the display pim routing-table command on SwitchA. You can see that VLANIF10 has been statically bound to multicast group 225.1.1.1. The command output information is as follows:

    [~SwitchA] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 192.168.4.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:12:17
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: static igmp, UpTime: 00:12:17, Expires: -

    The command output shows that SwitchA has a (*, 225.1.1.1) entry, with the downstream interface VLANIF10 and protocol type static igmp. This verifies that VLANIF10 has been statically bound to multicast group 225.1.1.1. If IGMP is disabled on VLANIF10 of SwitchA, the protocol type is static.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 to 11
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp static-group 225.1.1.1
    #
    interface Vlanif11
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif21
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 31
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif31
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 11 21 31 40
    #
    multicast routing-enable
    #
    interface Vlanif11
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 30667

Downloads: 36

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next