No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Layer 3 Multicast Over VXLAN When the Receiver Is Dual-Homed to VXLAN Through M-LAG in the Distributed Active-Active Gateway Scenario

Example for Configuring IPv4 Layer 3 Multicast Over VXLAN When the Receiver Is Dual-Homed to VXLAN Through M-LAG in the Distributed Active-Active Gateway Scenario

Networking Requirements

On an IPv4 network shown in Figure 14-21, Leaf 1, Leaf 2, and Leaf 3 are configured with distributed VXLAN gateways. Leaf 2 and Leaf 3 form a multi-chassis link aggregation group (M-LAG) (active-active gateways). The multicast source and receiver are located on the VXLAN overlay network. The source is connected to the VXLAN network through the Layer 2 sub-interface on Leaf 1, and belongs to BD20. The receiver is connected to the VXLAN network through the Layer 2 sub-interface on Leaf 2 and Leaf 3 (active-active gateways), and belongs to BD10. The receiver receives program traffic from the specified source 192.168.20.9 to the multicast group 232.1.1.1.

To meet the preceding requirements, configure IPv4 Layer 3 multicast on the VXLAN network where distributed gateways are deployed.

Figure 14-21 Networking diagram for configuring IPv4 Layer 3 multicast over VXLAN when the receiver is dual-homed to VXLAN through M-LAG in the distributed active-active gateway scenario

Table 14-17 Networking information

Device

Interface

IP Address

Leaf 1

10GE1/0/1

10.1.1.1/24

VBDIF20

192.168.20.1/24

LoopBack1

1.1.1.1/32

LoopBack2

1.1.1.10/32

Leaf 2

10GE1/0/1

10.1.2.1/24

VBDIF10

192.168.10.1/24

LoopBack1

2.2.2.2/32

LoopBack2

2.2.2.210/32

MEth0/0/0

10.10.10.1/24

VLANIF4000

10.10.20.1/24

Leaf 3

10GE1/0/1

10.1.3.1/24

VBDIF10

192.168.10.1/24

LoopBack1

3.3.3.3/32

LoopBack2

2.2.2.210/32

MEth0/0/0

10.10.10.2/24

VLANIF4000

10.10.20.2/24

Spine

10GE1/0/1

10.1.1.2/24

10GE1/0/2

10.1.2.2/24

10GE1/0/3

10.1.3.2/24

LoopBack1

4.4.4.4/32

Configuration Roadmap

Perform configuration under the following guidelines:
  1. Configure M-LAG between Leaf 2 and Leaf 3.

  2. Configure each leaf to set up VXLAN tunnels through BGP Ethernet VPN (EVPN), configure leaf switches to function as distributed gateways, and enable the hosts connected to Leaf 1 to communicate at Layer 3 through VPN routes.

  3. Configure BUM multicast replication for the Layer 3 network identifier (VNI) of the L3VPN instance on each leaf.

  4. Configure BGP MVPN peer relationships between Leaf 1, Leaf 2, and Leaf 3.

  5. Configure the VXLAN I-PMSI tunnel on each leaf.

  6. Bind an interface to the L3VPN instance on each leaf, enable PIM SM on the interfaces, and create a multicast routing table for the VPN.

  7. Configure IGMP on the interfaces of multicast devices that connect to user subnets.

Data Preparation

To complete the configuration, you need to prepare the following data:

  • VLAN IDs of the multicast source and receivers on the VXLAN overlay network (VLAN 10 and VLAN 20)

  • BD IDs (BD10 and BD20)

  • VNI IDs of the BDs (VNI 10 and VNI 20)

  • L3VPN instance name (mcast1) and VNI ID of the L3VPN instance (VNI 5010)

  • RDs of the EVPN instances (11:1 and 11:2) and RTs of the EVPN instances (12:1, 12:2, and 13:1)

  • RD of the L3VPN instance (1:1), RT of the L3VPN instance (1:1), and RT used for interoperation between the L3VPN instance and the EVPN instance (13:1)

  • Multicast group address for BUM multicast replication of Layer 3 VNIs of L3VPN instances (225.0.0.1)

  • MVPN ID of Leaf 1 (IP address of the Loopback1 interface), that of Leaf 2 (IP address of the Loopback2 interface), and that of Leaf 3 (IP address of the Loopback2 interface)

  • Local VPN instance ID of each leaf (1)

  • Static RP of the public network instance (4.4.4.4) and that of the VPN instance (1.1.1.10)

Procedure

  1. Configure the IP address and the unicast routing protocol for each switch interface.

    # Configure IP addresses and masks for switch interfaces according to Table 14-17. Configure switches to interconnect with each other using OSPF, and ensure that switches can intercommunicate with each other at the network layer. The configurations of Leaf 2, Leaf 3, and the spine are similar to the configurations of Leaf 1. For details, see the configuration file.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1
    [*HUAWEI] commit
    [~Leaf1] interface loopback 1
    [*Leaf1-LoopBack1] ip address 1.1.1.1 32
    [*Leaf1-LoopBack1] quit
    [*Leaf1] interface 10ge 1/0/1
    [*Leaf1-10GE1/0/1] undo portswitch
    [*Leaf1-10GE1/0/1] ip address 10.1.1.1 24
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] ospf
    [*Leaf1-ospf-1] area 0
    [*Leaf1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*Leaf1-ospf-1-area-0.0.0.0] quit
    [*Leaf1-ospf-1] quit
    [*Leaf1] commit

    After OSPF is configured successfully, the switches can learn the interface IP address of each other and successfully ping each other. For example, if you ping the Loopback1 interface address of Leaf 2 on Leaf 1, the output is as follows:

    [~Leaf1] ping 2.2.2.2
      PING 2.2.2.2: 56  data bytes, press CTRL_C to break                           
        Reply from 2.2.2.2: bytes=56 Sequence=1 ttl=254 time=2 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=2 ttl=254 time=1 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=3 ttl=254 time=1 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=4 ttl=254 time=1 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=5 ttl=254 time=1 ms                   
                                                                                    
      --- 2.2.2.2 ping statistics ---                                               
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/1/1 ms 

  2. Configure V-STP-based M-LAG on Leaf 2 and Leaf 3.

    # Configure V-STP-based M-LAG on Leaf 2. The configuration of Leaf 3 is similar to the configuration of Leaf 2. For details, see the configuration file.

    NOTE:

    If the link between Leaf 2 and the VXLAN network fails, Leaf 2 will discard all user traffic that reaches it, because no uplink interface is available. In this case, you can configure a Monitor Link group to associate the uplink and downlink interfaces of Leaf 2. If the uplink interface of Leaf 2 is Down, the downlink interface also goes Down. As a result, user-side traffic is not forwarded through Leaf 2. This prevents traffic from being discarded. For details about how to configure a Monitor Link group, see Configuring the Uplink and Downlink Interfaces in a Monitor Link Group.

    [~Leaf2] interface meth 0/0/0
    [~Leaf2-MEth0/0/0] ip address 10.10.10.1 24
    [*Leaf2-MEth0/0/0] quit
    [*Leaf2] stp mode rstp
    [*Leaf2] stp v-stp enable
    [*Leaf2] dfs-group 1
    [*Leaf2-dfs-group-1] source ip 10.10.10.1
    [*Leaf2-dfs-group-1] quit
    [*Leaf2] interface eth-trunk 1
    [*Leaf2-Eth-Trunk1] trunkport 10ge 1/0/4 to 1/0/5
    [*Leaf2-Eth-Trunk1] mode lacp-static
    [*Leaf2-Eth-Trunk1] peer-link 1
    [*Leaf2-Eth-Trunk1] quit
    [*Leaf2] interface eth-trunk 10
    [*Leaf2-Eth-Trunk10] trunkport 10ge 1/0/2 to 1/0/3
    [*Leaf2-Eth-Trunk10] mode lacp-static
    [*Leaf2-Eth-Trunk10] dfs-group 1 m-lag 1
    [*Leaf2-Eth-Trunk10] stp edged-port enable
    [*Leaf2-Eth-Trunk10] quit
    [*Leaf2] commit

  3. Configure the VXLAN.

    # If the CE6870EI and CE6875EI are used as VXLAN gateways, you need to configure the VXLAN tunnel mode and enable the VXLAN ACL extension function before configuring VXLAN. If other models are used as VXLAN gateways, skip this step. The configurations of Leaf 2 and Leaf 3 are similar to the configurations of Leaf 1. For details, see the configuration file.

    [~Leaf1] ip tunnel mode vxlan
    [*Leaf1] assign forward nvo3 acl extend enable
    Info: The configuration will take effect after system reboot.
    [*Leaf1] commit
    NOTE:
    • After configuring the VXLAN tunnel mode and enabling the VXLAN ACL extension function, you need to save the configuration and restart the device to make the configuration take effect. You are advised to restart the device after all the configurations are complete and saved.

    • For more restrictions on VXLAN configurations, see CloudEngine 8800, 7800, 6800, and 5800 Series Switches Configuration Guide-VXLAN.

    # Configure service access points on the leaf switches.
    • Configure Leaf 1.
      [~Leaf1] bridge-domain 20
      [*Leaf1-bd20] quit
      [*Leaf1] interface 10ge 1/0/2.1 mode l2
      [*Leaf1-10GE1/0/2.1] encapsulation dot1q vid 20
      [*Leaf1-10GE1/0/2.1] bridge-domain 20
      [*Leaf1-10GE1/0/2.1] quit
      [*Leaf1] commit
    • # Configure Leaf 2. The configuration of Leaf 3 is similar to the configuration of Leaf 2. For details, see the configuration file.
      [~Leaf2] bridge-domain 10
      [*Leaf2-bd10] quit
      [*Leaf2] interface eth-trunk 10.1 mode l2
      [*Leaf2-Eth-Trunk10.1] encapsulation dot1q vid 10
      [*Leaf2-Eth-Trunk10.1] bridge-domain 10
      [*Leaf2-Eth-Trunk10.1] quit
      [*Leaf2] commit

    # Configure BGP EVPN on each leaf as the VXLAN control plane protocol and configure BGP EVPN peers. The configurations of Leaf 2 and Leaf 3 are similar to the configuration of Leaf 1. For details, see the configuration file.

    [~Leaf1] evpn-overlay enable
    [*Leaf1] bgp 100
    [*Leaf1-bgp] peer 2.2.2.2 as-number 100
    [*Leaf1-bgp] peer 2.2.2.2 connect-interface LoopBack1
    [*Leaf1-bgp] peer 3.3.3.3 as-number 100
    [*Leaf1-bgp] peer 3.3.3.3 connect-interface LoopBack1
    [*Leaf1-bgp] l2vpn-family evpn
    [*Leaf1-bgp-af-evpn] peer 2.2.2.2 enable
    [*Leaf1-bgp-af-evpn] peer 3.3.3.3 enable
    [*Leaf1-bgp-af-evpn] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

    # Configure L3VPN instances and EVPN instances on each leaf. The configurations of Leaf 2 and Leaf 3 are similar to the configuration of Leaf 1. For details, see the configuration file.

    [~Leaf1] ip vpn-instance mcast1
    [*Leaf1-vpn-instance-mcast1] vxlan vni 5010
    [*Leaf1-vpn-instance-mcast1] ipv4-family
    [*Leaf1-vpn-instance-mcast1-af-ipv4] route-distinguisher 1:1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] vpn-target 1:1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] vpn-target 13:1 evpn
    [*Leaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf1-vpn-instance-mcast1] quit
    [*Leaf1] bridge-domain 20
    [*Leaf1-bd20] vxlan vni 20
    [*Leaf1-bd20] evpn
    [*Leaf1-bd20-evpn] route-distinguisher 11:2
    [*Leaf1-bd20-evpn] vpn-target 12:2
    [*Leaf1-bd20-evpn] vpn-target 13:1
    [*Leaf1-bd20-evpn] quit
    [*Leaf1-bd20] quit
    [*Leaf1] commit
    # Configure ingress replication on each leaf.
    • Configure Leaf 1.
      [~Leaf1] interface nve 1
      [*Leaf1-Nve1] source 1.1.1.1
      [*Leaf1-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Leaf1-Nve1] quit
      [*Leaf1] commit
    • Configure Leaf 2.
      [~Leaf2] interface nve 1
      [*Leaf2-Nve1] source 2.2.2.210
      [*Leaf2-Nve1] mac-address 0000-5e00-0101
      [*Leaf2-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Leaf2-Nve1] quit
      [*Leaf2] commit
    • Configure Leaf 3. Because Leaf 2 and Leaf 3 work as active-active gateways, ensure that the IP address and MAC address of the NVE interface must be the same on the two devices.
      [~Leaf3] interface nve 1
      [*Leaf3-Nve1] source 2.2.2.210
      [*Leaf3-Nve1] mac-address 0000-5e00-0101
      [*Leaf3-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Leaf3-Nve1] quit
      [*Leaf3] commit
    # Configure the VXLAN Layer 3 gateway function on each leaf.
    • If the CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI is used as a Layer 3 VXLAN gateway, configure the service loopback interface on the device before configuring the VXLAN Layer 3 gateway function. If other models are used as VXLAN Layer 3 gateways, skip this step. The configurations of Leaf 2 and Leaf 3 are similar to the configuration of Leaf 1. For details, see the configuration file.

      [~Leaf1] interface eth-trunk 2
      [*Leaf1-Eth-Trunk2] service type tunnel
      [*Leaf1-Eth-Trunk2] quit
      [*Leaf1] interface 10ge 1/0/5
      [*Leaf1-10GE1/0/5] eth-trunk 2
      [*Leaf1-10GE1/0/5] quit
      [*Leaf1] commit
      NOTE:
      • A member interface must be an idle physical interface that does not carry any service. There is no requirement for the status of a physical interface.
      • Ensure that the bandwidth of the Eth-Trunk interface (multicast loopback interface) is at least twice the bandwidth required for transmitting traffic on the Layer 3 VXLAN gateway. For example, if traffic is sent from users to the gateway across the VXLAN network at a rate of 10 Gbit/s, add two 10GE interfaces to the Eth-Trunk interface (multicast loopback interface) as the service loopback interfaces.
    • Configure the VXLAN Layer 3 gateway on Leaf 1.
      [~Leaf1] interface vbdif 20
      [*Leaf1-Vbdif20] ip binding vpn-instance mcast1
      [*Leaf1-Vbdif20] ip address 192.168.20.1 24
      [*Leaf1-Vbdif20] vxlan anycast-gateway enable
      [*Leaf1-Vbdif20] arp collect host enable
      [*Leaf1-Vbdif20] quit
      [*Leaf1] commit
    • Configure the VXLAN Layer 3 gateway on Leaf 2.
      [~Leaf2] interface vbdif 10
      [*Leaf2-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf2-Vbdif10] ip address 192.168.10.1 24
      [*Leaf2-Vbdif10] vxlan anycast-gateway enable
      [*Leaf2-Vbdif10] arp collect host enable
      [*Leaf2-Vbdif10] quit
      [*Leaf2] commit
    • Configure the VXLAN Layer 3 gateway on Leaf 3. Because Leaf 2 and Leaf 3 are active-active gateways. Ensure that the IP addresses of the VBDIF interfaces on the two devices are the same.
      [~Leaf3] interface vbdif 10
      [*Leaf3-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf3-Vbdif10] ip address 192.168.10.1 24
      [*Leaf3-Vbdif10] vxlan anycast-gateway enable
      [*Leaf3-Vbdif10] arp collect host enable
      [*Leaf3-Vbdif10] quit
      [*Leaf3] commit

    # Configure BGP on each leaf to advertise IRB routes to its peers. The configurations of Leaf 2 and Leaf 3 are similar to the configurations of Leaf 1. For details, see the configuration file.

    [~Leaf1] bgp 100
    [~Leaf1-bgp] l2vpn-family evpn
    [~Leaf1-bgp-af-evpn] peer 2.2.2.2 advertise irb
    [*Leaf1-bgp-af-evpn] peer 3.3.3.3 advertise irb
    [*Leaf1-bgp-af-evpn] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

    # Configure BGP on Leaf 1 to advertise IP prefix routes to its peers.

    [~Leaf1] bgp 100
    [~Leaf1-bgp] ipv4-family vpn-instance mcast1
    [*Leaf1-bgp-mcast1] advertise l2vpn evpn
    [*Leaf1-bgp-mcast1] network 1.1.1.10 32
    [*Leaf1-bgp-mcast1] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

    # Configure public network Layer 3 multicast on each leaf and spine. The configurations of Leaf 1, Leaf 2, and Leaf 3 are similar to that of the spine. For details, see the configuration file.

    [~Spine] multicast routing-enable
    [*Spine] interface loopback 1
    [*Spine-LoopBack1] pim sm
    [*Spine-LoopBack1] quit
    [*Spine] interface 10ge 1/0/1
    [*Spine-10GE1/0/1] pim sm
    [*Spine-10GE1/0/1] quit
    [*Spine] interface 10ge 1/0/2
    [*Spine-10GE1/0/2] pim sm
    [*Spine-10GE1/0/2] quit
    [*Spine] interface 10ge 1/0/3
    [*Spine-10GE1/0/3] pim sm
    [*Spine-10GE1/0/3] quit
    [*Spine] pim
    [*Spine-pim] static-rp 4.4.4.4
    [*Spine-pim] quit
    [*Spine] commit

    # Configure BUM multicast replication for the Layer 3 VNI of the L3VPN instance on each leaf. The configurations of Leaf 2 and Leaf 3 are similar to the configuration of Leaf 1. For details, see the configuration file.

    [~Leaf1] interface nve 1
    [~Leaf1-Nve1] vni 5010 mcast-group 225.0.0.1
    [*Leaf1-Nve1] quit
    [*Leaf1] commit
    # Add VLANIF interfaces on Leaf 2 and Leaf 3 to multicast groups so that the M-LAG master and backup devices can synchronize VXLAN-encapsulated multicast packets through the peer-link. The configuration of Leaf 3 is similar to the configuration of Leaf 2. For details, see the configuration file.
    [~Leaf2] vlan 4000
    [*Leaf2-vlan4000] quit
    [*Leaf2] interface vlanif 4000
    [*Leaf2-Vlanif4000] ip address 10.10.20.1 24
    [*Leaf2-Vlanif4000] vxlan multicast-group member enable
    [*Leaf2-Vlanif4000] pim sm
    [*Leaf2-Vlanif4000] quit
    [*Leaf2] commit

    After the preceding configurations are complete, VXLAN tunnels can be established between the leaf switches. The display vxlan tunnel command can be run to query VXLAN tunnel information. For example, in the command output of Leaf 1, the State field is up, indicating that the VXLAN tunnel is reachable. If the Type field is static, the destination IP address is statically configured. If the Type field is dynamic, the destination IP address is dynamically learned through the protocol.

    [~Leaf1] display vxlan tunnel
    Number of vxlan tunnel : 2
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  1.1.1.1               225.0.0.1             up     static   04:44:52  
    4026531845  1.1.1.1               2.2.2.210             up     dynamic  04:40:52 

  4. Configure BGP MVPN peers on each leaf.

    # Configure Leaf 1. The configurations of Leaf 2 and Leaf 3 are similar to the configuration of Leaf 1. For details, see the configuration file.

    [~Leaf1] bgp 100
    [~Leaf1-bgp] ipv4-family mvpn
    [*Leaf1-bgp-af-mvpn] peer 2.2.2.2 enable
    [*Leaf1-bgp-af-mvpn] peer 3.3.3.3 enable
    [*Leaf1-bgp-af-mvpn] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

  5. Configure the VXLAN I-PMSI tunnel on each leaf.

    # Configure Leaf 1. The MVPN ID configured on the distributed VXLAN gateway must be the VTEP IP address of the current gateway.

    [~Leaf1] multicast mvpn 1.1.1.1
    [*Leaf1] ip vpn-instance mcast1
    [*Leaf1-vpn-instance-mcast1] ipv4-family
    [*Leaf1-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf1-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf1-vpn-instance-mcast1] quit
    [*Leaf1] commit

    # Configure Leaf 2.

    [~Leaf2] multicast mvpn 2.2.2.210
    [*Leaf2] ip vpn-instance mcast1
    [*Leaf2-vpn-instance-mcast1] ipv4-family
    [*Leaf2-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf2-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf2-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf2-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf2-vpn-instance-mcast1] quit
    [*Leaf2] commit

    # Configure Leaf 3. Because Leaf 2 and Leaf 3 are active-active gateways, ensure that the MVPN IDs configured on the two devices are the same and are both set to the VTEP IP addresses of the devices.

    [~Leaf3] multicast mvpn 2.2.2.210
    [*Leaf3] ip vpn-instance mcast1
    [*Leaf3-vpn-instance-mcast1] ipv4-family
    [*Leaf3-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf3-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf3-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf3-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf3-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf3-vpn-instance-mcast1] quit
    [*Leaf3] commit

  6. Configure PIM SM and IGMP on the VBDIF interface.

    # Configure Leaf 1.

    [~Leaf1] interface vbdif 20
    [~Leaf1-Vbdif20] pim sm
    [*Leaf1-Vbdif20] igmp enable
    [*Leaf1-Vbdif20] quit
    [*Leaf1] commit

    # Configure Leaf 2.

    [~Leaf2] interface vbdif 10
    [~Leaf2-Vbdif10] pim sm
    [*Leaf2-Vbdif10] igmp enable
    [*Leaf2-Vbdif10] igmp version 3
    [*Leaf2-Vbdif10] quit
    [*Leaf2] commit

    # Configure Leaf 3.

    [~Leaf3] interface vbdif 10
    [~Leaf3-Vbdif10] pim sm
    [*Leaf3-Vbdif10] igmp enable
    [*Leaf3-Vbdif10] igmp version 3
    [*Leaf3-Vbdif10] quit
    [*Leaf3] commit

  7. Configure a VPN static RP on each leaf.

    # Configure Leaf 1.

    [~Leaf1] interface loopback 2
    [~Leaf1-LoopBack2] ip binding vpn-instance mcast1
    [*Leaf1-LoopBack2] ip address 1.1.1.10 32
    [*Leaf1-LoopBack2] pim sm
    [*Leaf1-LoopBack2] quit
    [*Leaf1] pim vpn-instance mcast1
    [*Leaf1-pim-mcast1] static-rp 1.1.1.10
    [*Leaf1-pim-mcast1] quit
    [*Leaf1] commit

    # Configure Leaf 2.

    [*Leaf2] pim vpn-instance mcast1
    [*Leaf2-pim-mcast1] static-rp 1.1.1.10
    [*Leaf2-pim-mcast1] quit
    [*Leaf2] commit

    # Configure Leaf 3.

    [*Leaf3] pim vpn-instance mcast1
    [*Leaf3-pim-mcast1] static-rp 1.1.1.10
    [*Leaf3-pim-mcast1] quit
    [*Leaf3] commit

  8. Verify the configuration.

    # Run the display bgp mvpn all peer command on each leaf. The BGP MVPN peer information can be displayed. For example, the command output on Leaf 1 is as follows:

    [~Leaf1] display bgp mvpn all peer
     BGP local router ID        : 1.1.1.1
     Local AS number            : 100
     Total number of peers      : 2
     Peers in established state : 2
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      2.2.2.2         4         100     1860     1859     0 04:43:30 Established        1
      3.3.3.3         4         100     3219     3221     0 04:43:39 Established        1
    # After each receiver joins a multicast group, run the display pim vpn-instance mcast1 routing-table command on each leaf. The information about the VPN PIM routing table can be displayed.
    • The command output on Leaf 1 shows that the receiver joins through BGP.
      [~Leaf1] display pim vpn-instance mcast1 routing-table
       VPN-Instance: mcast1
       Total 1 (S, G) entry
      
       (192.168.20.9, 232.1.1.1)
           Protocol: pim-ssm, Flag: SPT LOC ACT
           UpTime: 04:44:39
           Upstream interface: Vbdif20
               Upstream neighbor: NULL
               RPF prime neighbor: NULL
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: pseudo
                   Protocol: BGP, UpTime: 04:44:39, Expires: -
      
    • The command output on Leaf 2 shows that the upstream interface in the VPN PIM routing entry for the receiver is Through-BGP and the downstream interface is VBDIF 10.
      [~Leaf2] display pim vpn-instance mcast1 routing-table
       VPN-Instance: mcast1
       Total 1 (S, G) entry
       
       (192.168.20.9, 232.1.1.1)
           Protocol: pim-ssm, Flag: SPT ACT 
           UpTime: 04:44:18
           Upstream interface: through-BGP
               Upstream neighbor: 1.1.1.1
               RPF prime neighbor: 1.1.1.1
           Downstream interface(s) information:
           Total number of downstreams: 1
              1: Vbdif10
                   Protocol: igmp, UpTime: 04:44:18, Expires: -

Configuration File

  • Leaf 1 configuration file

    #
    sysname Leaf1
    #
    assign forward nvo3 acl extend enable //This step is required only for the CE6870EI and CE6875EI.
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 1.1.1.1
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #
    bridge-domain 20
     vxlan vni 20   
     evpn           
      route-distinguisher 11:2
      vpn-target 12:2 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:2 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #
    interface Vbdif20
     ip binding vpn-instance mcast1
     ip address 192.168.20.1 255.255.255.0
     pim sm         
     igmp enable    
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk2 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     service type tunnel
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    #
    interface 10GE1/0/5 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     eth-trunk 2
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #               
    interface LoopBack2
     ip binding vpn-instance mcast1
     ip address 1.1.1.10 255.255.255.255
     pim sm
    #
    interface Nve1  
     source 1.1.1.1 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
    #
    bgp 100         
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #              
     ipv4-family vpn-instance mcast1
      network 1.1.1.10 255.255.255.255
      advertise l2vpn evpn
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise irb
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #               
    pim
     static-rp 4.4.4.4
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • Leaf 2 configuration file

    #
    sysname Leaf2
    #
    assign forward nvo3 acl extend enable //This step is required only for the CE6870EI and CE6875EI.
    #
    dfs-group 1
     source ip 10.10.10.1
    #
    vlan batch 4000
    #
    stp mode rstp
    stp v-stp enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 2.2.2.210
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #               
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.1 255.255.255.0
     pim sm
     igmp enable
     igmp version 3    
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vlanif4000
     ip address 10.10.20.1 255.255.255.0
     pim sm
     vxlan multicast-group member enable
    #
    interface MEth0/0/0
     ip address 10.10.10.1 255.255.255.0
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk2 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     service type tunnel
    #
    interface Eth-Trunk10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     eth-trunk 2
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #               
    interface LoopBack2
     ip address 2.2.2.210 255.255.255.255
    #               
    interface Nve1  
     source 2.2.2.210 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
     mac-address 0000-5e00-0101
    #
    bgp 100         
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
     #              
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 2.2.2.2 0.0.0.0
      network 2.2.2.210 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    pim
     static-rp 4.4.4.4
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • Leaf 3 configuration file

    #
    sysname Leaf3
    #
    assign forward nvo3 acl extend enable //This step is required only for the CE6870EI and CE6875EI.
    #
    dfs-group 1
     source ip 10.10.10.2
    #
    vlan batch 4000
    #
    stp mode rstp
    stp v-stp enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 2.2.2.210
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.1 255.255.255.0
     pim sm         
     igmp enable
     igmp version 3    
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vlanif4000
     ip address 10.10.20.2 255.255.255.0
     pim sm
     vxlan multicast-group member enable
    #
    interface MEth0/0/0
     ip address 10.10.10.2 255.255.255.0
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk2 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     service type tunnel
    #
    interface Eth-Trunk10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.3.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6 //This step is required only for the CE8860EI, CE8850EI, CE7855EI,
    CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI.
     eth-trunk 2
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface LoopBack2
     ip address 2.2.2.210 255.255.255.255
    #
    interface Nve1  
     source 2.2.2.210 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
     mac-address 0000-5e00-0101
    #               
    bgp 100         
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #              
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 2.2.2.210 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.3.0 0.0.0.255
    #
    pim
     static-rp 4.4.4.4
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • Spine Configuration file

    #
    sysname Spine
    #
    multicast routing-enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.2.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #
    ospf 1          
     area 0.0.0.0   
      network 4.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    pim
     static-rp 4.4.4.4
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 20289

Downloads: 21

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next