No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Multicast Load Splitting

Example for Configuring IPv4 Multicast Load Splitting

Networking Requirements

In Figure 7-12, SwitchE connects to HostA and has three equal-cost routes to the multicast source (Source). According to the default reverse path forwarding (RPF) check policy, SwitchE will select one of these equal-cost routes to transmit multicast data. When the rate of multicast traffic is high, the network may become congested, lowering the quality of multicast services. To ensure the quality of multicast services, multicast load splitting needs to be configured so that multicast data can be transmitted through multiple equal-cost routes.

Figure 7-12 Networking diagram of multicast load splitting

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on the switches.

  2. Configure a unicast routing protocol, Intermediate System-Intermediate System (IS-IS) in this example, to implement interworking among all switches and ensure that route costs are the same.

  3. Enable multicast routing on all switches and enable Protocol Independent Multicast Sparse Mode (PIM-SM) on all Layer 3 interfaces. Configure the loopback interface on SwitchA as a C-BSR and C-RP.

  4. On SwitchE, configure stable-preferred multicast load splitting to ensure stable transmission of multicast services.

  5. On SwitchE, configure static multicast groups on the interface connected to the network segment of HostA, because HostA needs to receive data of these groups for a long time.

Procedure

  1. Configure IP addresses for interfaces on the switches. SwitchA is used as an example in the following operations. Configurations of the other switches are similar.

    # Create VLANs and add Layer 2 physical interfaces to the VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30 40
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port default vlan 10
    [*SwitchA-10GE1/0/4] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 40
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # Configure IP addresses and masks for Layer 3 interfaces.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.110.1.2 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ip address 192.168.1.1 24
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 192.168.2.1 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] ip address 192.168.3.1 24
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ip address 10.1.1.1 32
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit
    

  2. Configure IS-IS to implement interworking among all switches and ensure that route costs are the same (SwitchA as an example).

    [~SwitchA] isis
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis enable
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] isis enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] isis enable
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] isis enable
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] isis enable
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit
    

  3. Enable multicast routing on all switches and enable PIM-SM on all Layer 3 interfaces.

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback 0
    [*SwitchA-LoopBack0] pim sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. Configure a C-BSR and C-RP on SwitchA.

    # Configure Loopback0 on SwitchA as a C-BSR and C-RP.

    [~SwitchA] pim
    [*SwitchA-pim] c-bsr loopback 0
    [*SwitchA-pim] c-rp loopback 0
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit

  5. Configure stable-preferred multicast load splitting on SwitchE.

    [~SwitchE] multicast load-splitting stable-preferred
    [*SwitchE] commit

  6. Configure static multicast groups on the interface of SwitchE connected to the network segment of HostA.

    # Configure static multicast groups 225.1.1.1 to 225.1.1.3 on VLANIF 140.

    [~SwitchE] interface Vlanif140
    [~SwitchE-Vlanif140] igmp static-group 225.1.1.1 inc-step-mask 32 number 3
    [*SwitchE-Vlanif140] commit
    [~SwitchE-Vlanif140] quit

  7. Verify the configuration of stable-preferred multicast load splitting.

    # Source (10.110.1.1/24) sends multicast data to multicast groups 225.1.1.1 to 225.1.1.3. HostA can receive multicast data from Source. Brief information about the PIM routing table on SwitchE is as follows:

    [~SwitchE] display pim routing-table brief
     VPN-Instance: public net
     Total 3 (*, G) entries, 3 (S, G) entries
     Entries                                Upstream interface       NDwnstrms
     (*, 225.1.1.1)                         Vlanif100                 1
     (10.110.1.1, 225.1.1.1)                Vlanif100                 1
     (*, 225.1.1.2)                         Vlanif80                  1
     (10.110.1.1, 225.1.1.2)                Vlanif80                  1
     (*, 225.1.1.3)                         Vlanif60                  1
     (10.110.1.1, 225.1.1.3)                Vlanif60                  1

    (*, G) and (S, G) entries are evenly distributed on the three equal-cost routes. The upstream interfaces of the routes are VLANIF 100, VLANIF 80, and VLANIF 60, respectively.

    NOTE:

    The load splitting algorithm processes (*, G) and (S, G) entries separately using the same rule.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 30 40
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.110.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif30
     ip address 192.168.2.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif40
     ip address 192.168.3.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/4
     port default vlan 10
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
     isis enable 1
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 30 80
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif30
     ip address 192.168.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif80
     ip address 192.168.5.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 40 100
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif40
     ip address 192.168.3.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif100
     ip address 192.168.6.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 60 80 100 140
    #
    multicast routing-enable
    multicast load-splitting stable-preferred
    #
    isis 1
     network-entity 10.0000.0000.0005.00
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif80
     ip address 192.168.5.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif100
     ip address 192.168.6.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Vlanif140
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp static-group 225.1.1.1 inc-step-mask 0.0.0.1 number 3
     isis enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/4
     port default vlan 140
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 25246

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next