No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IPv4 Bidir-PIM Functions

Example for Configuring Basic IPv4 Bidir-PIM Functions

Networking Requirements

Figure 4-29 shows an enterprise campus network. A multicast protocol is required on the network to allow multi-party video conferences among users connected to the network.

Figure 4-29 Network diagram for basic Bidir-PIM configurations

Configuration Roadmap

If a multi-party video conferencing network runs Protocol Independent Multicast Sparse Mode (PIM-SM) to provide multicast services for many users, switches on the network will be overloaded because a lot of forwarding resources are consumed on the switches. To conserve the forwarding resources on the switches, configure Bidir-PIM on this network. The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on the switches. PIM is an intra-domain multicast routing protocol that depends on a unicast routing protocol. It can work only when the unicast routing protocol works normally.

  2. Enable Bidir-PIM on all the switches that need to provide multicast services. Other Bidir-PIM functions can be configured only after Bidir-PIM is enabled.

  3. Enable PIM-SM on all switch interfaces. Bidir-PIM uses the same neighbor discovery mechanism as PIM-SM. PIM-SM must be enabled on interfaces so that neighbor relationships can be set up between the switches.

  4. Enable IGMP on the interfaces connected to network segments of the hosts. Then receiver hosts can send Internet Group Management Protocol (IGMP) messages to join or leave a group. The leaf switches use IGMP to maintain group memberships.

  5. Configure a rendezvous point (RP) and configure it to serve Bidir-PIM. On a Bidir-PIM network, an RP is the transit device for multicast data forwarding. An RP should be deployed on a switch with multiple branches for multicast data forwarding, like SwitchE in Figure 4-29.

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on the switches.

    Configure IP addresses and masks for switch interfaces according to Figure 4-29. Configure Open Shortest Path First (OSPF) on the switches to implement IP interworking between the switches and enable the switches to dynamically update routes.

    # Add interfaces of SwitchA to VLANs. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 50
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 50
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit
    

    # Assign IP addresses to VLANIF interfaces on SwitchA. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 192.168.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 50
    [*SwitchA-Vlanif50] ip address 10.1.1.1 24
    [*SwitchA-Vlanif50] quit
    [*SwitchA] commit

    # Configure a routing protocol on SwitchA. OSPF is used in this example. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Enable Bidir-PIM globally and enable PIM-SM on all interfaces.

    # Enable Bidir-PIM globally on all switches and enable PIM-SM on all interfaces. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] multicast routing-enable
    [*SwitchA] pim
    [*SwitchA-pim] bidir-pim
    [*SwitchA-pim] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 50
    [~SwitchA-Vlanif50] pim sm
    [*SwitchA-Vlanif50] commit
    [~SwitchA-Vlanif50] quit
    

  3. Enable IGMP on interfaces directly connected to network segments of hosts.

    # Enable IGMP on interface of SwitchA connected to the network segment of HostA. The configurations on SwitchB, SwitchC, and SwitchD are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  4. Configure an RP.

    # Configure a candidate rendezvous point (C-RP) and a candidate bootstrap router (C-BSR) on an interface of SwitchE and configure the C-RP to serve Bidir-PIM.

    [~SwitchE] pim
    [~SwitchE-pim] c-bsr vlanif 60 
    [*SwitchE-pim] c-rp vlanif 60 bidir
    [*SwitchE-pim] commit
    [~SwitchE-pim] quit
    

  5. Verify the configuration.

    # Run the display pim bsr-info command on the switches to view BSR information. For example, BSR information on SwitchA and SwitchE is displayed as follows. (The command output on SwitchE also displays C-BSR information.)

    [~SwitchA] display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Accept Preferred
         Scope: Not scoped
         Uptime: 00:05:57
         Expires: 00:01:27
         C-RP Count: 1
    
    
    [~SwitchE] display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped
         Uptime: 00:05:08
         Next BSR message scheduled at: 00:00:06
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped   
         Wait to be BSR: 0

    The preceding information shows that the addresses of the elected BSR and C-BSR are both 10.1.2.2, IP address of VLANIF60 on SwitchE.

    # Run the display pim rp-info command on the switches to check RP information. For example, RP information on SwitchA is as follows:

    [~SwitchA] display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: 224.0.0.0/4
         RP: 10.1.2.2
         Priority: 0
         Uptime: 00:10:49
         Expires: 00:01:41
         BIDIR: Y
    

    The preceding information shows that the address of the elected RP is 10.1.2.2 (IP address of VLANIF60 on SwitchE), and the elected RP serves Bidir-PIM.

    # Run the display pim df-info command on the switches to check DF information. For example, DF information on SwitchA and SwitchE is as follows:

    [~SwitchA] display pim df-info
     VPN-Instance: public net
     Total Number of DF = 2
    
     RP: 10.1.2.2
     Interface           DF-Address               DF-Uptime     Rpf-Interface
     Vlanif10            192.168.1.1(local)       00:25:01      N
     Vlanif50            10.1.1.2                 00:25:01      Y
    [~SwitchE] display pim df-info
     VPN-Instance: public net
     Total Number of DF = 4
    
     RP: 10.1.2.2
     Interface           DF-Address               DF-Uptime     Rpf-Interface
     Vlanif60            -                        -             Y
     Vlanif70            10.1.3.2(local)          00:31:44      N
     Vlanif50            10.1.1.2(local)          00:31:44      N
     Vlanif80            10.1.4.2(local)          00:31:44      N

    # After HostA, HostB, HostC, and HostD join group 225.0.0.1 using IGMP, you can run the display pim routing-table command on the switches to view the PIM routing table. For example, the PIM routing table on SwitchA is as follows:

    [~SwitchA] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.0.0.1)
         RP: 10.1.2.2
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:36:47
         Rpf interface: Vlanif50
             Upstream neighbor: 10.1.1.2
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: igmp, UpTime: 00:36:46, Expires: - 
            2: Vlanif50(RPF)
                 Protocol: bidir-pim, UpTime: 00:36:47, Expires: -

    You can see that the routing entries are generated by Bidir-PIM, and multicast data sent from the hosts (multicast sources) can be forwarded along the bidirectional RPT set up based on the (*, 225.0.0.1) entry.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 50
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif50
     ip address 10.1.1.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif60
     ip address 10.1.2.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 30 70
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif70
     ip address 10.1.3.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 40 80
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif80
     ip address 10.1.4.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    ospf 1
     area 0.0.0.0
      network 10.1.4.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 50 60 70 80
    #
    multicast routing-enable
    #
    interface Vlanif50
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif70
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif80
     ip address 10.1.4.2 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    pim
     c-bsr Vlanif60
     bidir-pim
     c-rp Vlanif60 bidir
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 20688

Downloads: 21

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next