No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Anycast RP Using IPv6 PIM

Example for Configuring Anycast RP Using IPv6 PIM

Networking Requirements

Receiver1 and Receiver2 in Network diagram for configuring Anycast RP using IPv6 PIM receive VoD information in multicast mode. When the network is overloaded or traffic is concentrated on an RP, the RP may be overburdened or fails and the route convergence may be slow. Receiver2 is required to join the closest RP to fast receive the multicast data.

Figure 5-3 Network diagram for configuring Anycast RP using IPv6 PIM

Table 5-25 Device configuration list

Device

VLANIF Interface/Loopback Interface

IPv6 Address

SwitchA

VLANIF10

FC00:0:0:3001::1/64

VLANIF20

FC00:0:0:2001::1/64

SwitchB

VLANIF50

FC00:0:0:2002::1/64

SwitchC

VLANIF20

FC00:0:0:2001::2/64

VLANIF40

FC00:0:0:2003::1/64

Loopback0

FC00:0:0:1::1/128

Loopback1

FC00:0:0:2::2/128

SwitchD

VLANIF40

FC00:0:0:2003::2/64

VLANIF50

FC00:0:0:2002::2/64

VLANIF60

FC00:0:0:3003::1/64

Loopback0

FC00:0:0:1::1/128

Loopback1

FC00:0:0:3::3/128

Configuration Roadmap

Configuring Anycast RP using IPv6 PIM reduces the burden on an RP and hosts can join the closest RP.

  1. Configure IP addresses for interfaces of each switch, and configure Open Shortest Path First version 3 (OSPFv3) to implement IP interworking.

  2. Enable the multicast function and enable IPv6 PIM-SM on each interface.

  3. Enable Multicast Listener Discovery (MLD) on the interfaces that connect switch to hosts.

  4. Configure loopback 0 on SwitchC and SwitchD as candidate rendezvous point (C-RP) and candidate bootstrap router (C-BSR) respectively.

  5. Configure loopback 0 on SwitchC and SwitchD as Anycast RPs.

  6. Configure the addresses of loopback 0 on SwitchC and SwitchD as local addresses of Anycast RPs.

  7. Set an Anycast RP peer relationship between SwitchC and SwitchD.

Procedure

  1. Configure an IP address for each interface and configure the unicast routing protocol.

    # Configure an IP address and mask for each interface according to Figure 5-3. Configure OSPFv3 on each switch to ensure IP connectivity between them, and enable them to dynamically update routing information. The configuration of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned. See the configuration files for the configurations.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:3001::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  2. Enable IPv6 multicast routing on all switches and IPv6 PIM-SM on all interfaces.

    # Enable IPv6 multicast routing on all switches and enable IPv6 PIM-SM on all interfaces. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here. See the configuration files for the configurations.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  3. Enable MLD on the interfaces that connect the switch to hosts.

    # Enable MLD on the interfaces that connect SwitchC and SwitchD to hosts.

    # Configure SwitchC.

    [~SwitchC] interface vlanif 30
    [~SwitchC-Vlanif30] mld enable
    [*SwitchC-Vlanif30] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] interface vlanif 60
    [~SwitchD-Vlanif60] mld enable
    [*SwitchD-Vlanif60] quit
    [*SwitchD] commit

  4. Configure loopback 0 on SwitchC and SwitchD as the C-RP and C-BSR respectively.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [*SwitchC-pim6] c-bsr fc00:0:0:1::1
    [*SwitchC-pim6] c-rp fc00:0:0:1::1
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [*SwitchD-pim6] c-bsr fc00:0:0:1::1
    [*SwitchD-pim6] c-rp fc00:0:0:1::1
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  5. Configure loopback 0 on SwitchC and SwitchD as Anycast RPs.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp fc00:0:0:1::1
    [*SwitchC-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp fc00:0:0:1::1
    [*SwitchD-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  6. Configure the addresses of loopback 0 on SwitchC and SwitchD as local addresses of Anycast RPs.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchC-pim6-anycast-rp-fc00:0:0:1::1] local-address fc00:0:0:2::2
    [*SwitchC-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchD-pim6-anycast-rp-fc00:0:0:1::1] local-address fc00:0:0:3::3
    [*SwitchD-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  7. Set an Anycast RP peer relationship between SwitchC and SwitchD.

    # Configure SwitchC.

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchC-pim6-anycast-rp-fc00:0:0:1::1] peer fc00:0:0:3::3
    [*SwitchC-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # Configure SwitchD.

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchD-pim6-anycast-rp-fc00:0:0:1::1] peer fc00:0:0:2::2
    [*SwitchD-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  8. Verify the configuration.

    # Run the display pim ipv6 rp-info command on SwitchC and SwitchD to check RP information.

    [~SwitchC] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF00::/8
         RP: FC00:0:0:1::1 (local)
         Priority: 192
         Uptime: 00:06:34
         Expires: 00:01:56
    
    [~SwitchD] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF00::/8
         RP: FC00:0:0:1::1 (local)
         Priority: 192
         Uptime: 00:06:34
         Expires: 00:01:56
    

    The command output shows that SwitchC and SwitchD serve as RPs and forward the Register message from the multicast source to each other.

    # Run the display pim ipv6 routing-table command to check PIM entries on each switch. Source (FC00:0:0:3001::2/64) in the PIM-SM domain sends multicast data to multicast group G (ff2e::1). Receiver2 joins G and receives the multicast data sent to G. Source sends a Register message to SwitchC and Receiver2 sends a Join message to SwitchD.

    [~SwitchC] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (FC00:0:0:3001::2, FF2E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:38
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:01:25, Expires: -
    
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:25
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:01:25, Expires: -
    
     (FC00:0:0:3001::2, FF2E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:02
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:00:02, Expires: -
    
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:3001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 30 40
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3002::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port default vlan 30
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:1::1/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface LoopBack1
     ipv6 enable
     ipv6 address FC00:0:0:2::2/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    pim ipv6
     c-bsr FC00:0:0:1::1
     c-rp FC00:0:0:1::1
     anycast-rp FC00:0:0:1::1
      local-address FC00:0:0:2::2
      peer FC00:0:0:3::3
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 40 50 60
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:200FC00:0:0:2::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:3003::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/2
     port default vlan 60
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:1::1/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface LoopBack1
     ipv6 enable
     ipv6 address FC00:0:0:3::3/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    pim ipv6
     c-bsr FC00:0:0:1::1
     c-rp FC00:0:0:1::1
     anycast-rp FC00:0:0:1::1
      local-address FC00:0:0:3::3
      peer FC00:0:0:2::2
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 24666

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next