No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Interface-based Multicast VLAN Replication

Example for Configuring Interface-based Multicast VLAN Replication

Networking Requirements

In Figure 12-4, 10GE1/0/1 of the SwitchA is connected to the Router. 10GE1/0/2 provides services for ISP1, and 10GE1/0/3 provides services for ISP2. ISP1 and ISP2 use multicast VLAN 2 and VLAN 3 respectively to provide multicast services for users. 10GE1/0/2 and 10GE1/0/3 have the same user VLAN (VLAN 10).

To ensure that multicast packets of each ISP are sent only to users of the ISP, interface-based multicast VLAN replication is required. After the configuration is complete, multicast data of an ISP will be sent only to the interface connected to the ISP.

Figure 12-4 Configuring interface-based multicast VLAN replication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable Internet Group Management Protocol (IGMP) snooping in the system view.
  2. Create user VLAN 10 and enable IGMP snooping in the user VLAN.
  3. Create multicast VLANs 2 and 3 and enable IGMP snooping in the multicast VLANs.
  4. Bind user VLAN 10 to multicast VLANs on 10GE1/0/2 and 10GE1/0/3 respectively.
  5. Add the network-side interface and user-side interfaces to the VLANs.

Procedure

  1. Create user VLAN 10 and enable IGMP snooping in the user VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] igmp snooping enable
    [*SwitchA] vlan 10
    [*SwitchA-vlan10] igmp snooping enable
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

  2. Create multicast VLANs 2 and 3 and enable IGMP snooping in the multicast VLANs.

    [~SwitchA] vlan 2
    [*SwitchA-vlan2] igmp snooping enable
    [*SwitchA-vlan2] quit
    [*SwitchA] vlan 3
    [*SwitchA-vlan3] igmp snooping enable
    [*SwitchA-vlan3] commit
    [~SwitchA-vlan3] quit

  3. Bind user VLAN 10 to multicast VLANs on 10GE1/0/2 and 10GE1/0/3 respectively.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] multicast layer-2 bind vlan 10 mvlan 2
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] multicast layer-2 bind vlan 10 mvlan 3
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  4. Add 10GE1/0/1 to the multicast VLANs. Add 10GE1/0/2 and 10GE1/0/3 to the user VLAN.

    # Add 10GE1/0/1 to multicast VLANs 2 and 3 as a trunk interface.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 2 3 
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # Add 10GE1/0/2 and 10GE1/0/3 respectively to user VLAN 10 as trunk interfaces.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  5. Verify the configuration.

    Run the display multicast layer-2 bind command on SwitchA to view binding between the user VLAN and multicast VLANs.

    [~SwitchA] display multicast layer-2 bind
     ------------------------------------------------------------------- 
     Port                          Startvlan        Endvlan        Mvlan
     ------------------------------------------------------------------- 
     10GE1/0/2                           10             --            2
     10GE1/0/3                           10             --            3
     ------------------------------------------------------------------- 
     Total Table(s) : 2

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 2 to 3 10
    #
    igmp snooping enable
    #
    vlan 2
     igmp snooping enable
    #
    vlan 3
     igmp snooping enable
    #
    vlan 10
     igmp snooping enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     multicast layer-2 bind vlan 10 mvlan 2
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
     multicast layer-2 bind vlan 10 mvlan 3
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 20723

Downloads: 21

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next