No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IPv6 Bidir-PIM Functions

Example for Configuring Basic IPv6 Bidir-PIM Functions

Networking Requirements

Figure 5-4 shows the IPv6 campus network of an enterprise. A multicast protocol is required on the network to allow multi-party video conferences among users connected to the network.

Figure 5-4 Networking diagram for basic IPv6 Bidir-PIM configurations

Table 5-26 Device configuration list

Device

VLANIF Interface

IPv6 Address

SwitchA

VLANIF10 FC00:0:0:3001::1/64
VLANIF50 FC00:0:0:2001::1/64

SwitchB

VLANIF20 FC00:0:0:3002::1/64
VLANIF60 FC00:0:0:2002::1/64

SwitchC

VLANIF30 FC00:0:0:3003::1/64
VLANIF70 FC00:0:0:2003::1/64

SwitchD

VLANIF40 FC00:0:0:3004::1/64
VLANIF80 FC00:0:0:2004::1/64

SwitchE

VLANIF50 FC00:0:0:2001::2/64
VLANIF60 FC00:0:0:2002::2/64
VLANIF70 FC00:0:0:2003::2/64
VLANIF80 FC00:0:0:2004::2/64

Configuration Roadmap

If a multi-party video conferencing network runs IPv6 PIM-SM to provide multicast services for many users, switches on the network will be overloaded because a lot of forwarding resources are consumed on the switches. To conserve the forwarding resources on the switches, configure IPv6 Bidir-PIM on this network. The configuration roadmap is as follows:

  1. Assign IPv6 addresses to interfaces and configure an IPv6 unicast routing protocol on the switches. Ensure that the IPv6 unicast routing protocol works normally.

  2. Enable IPv6 Bidir-PIM on all the switches that need to provide multicast services. Other IPv6 Bidir-PIM functions can be configured only after IPv6 Bidir-PIM is enabled.

  3. Enable IPv6 PIM-SM on all switch interfaces. IPv6 Bidir-PIM uses the same neighbor discovery mechanism as IPv6 PIM-SM. IPv6 PIM-SM must be enabled on interfaces so that neighbor relationships can be set up between the switches.

  4. Enable Multicast Listener Discovery (MLD) on the interfaces connected to network segments of the hosts. Ensure that the receiver hosts can access the multicast network.

  5. Configure SwitchE as a rendezvous point (RP) and configure it to serve IPv6 Bidir-PIM. An RP is usually deployed on a device with multiple branches for multicast data forwarding.

Procedure

  1. Assign IPv6 addresses to interfaces and configure an IPv6 unicast routing protocol on the switches.

    # Configure IPv6 addresses and masks for switch interfaces according to Figure 5-4. Configure Open Shortest Path First version 3 (OSPFv3) on the switches to implement IPv6 interworking between the switches and enable the switches to dynamically update routes. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    # Add interfaces of SwitchA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 50
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 50
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit
    

    # Assign IPv6 addresses to VLANIF interfaces on SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:3001::1 64
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 50
    [*SwitchA-Vlanif50] ipv6 enable
    [*SwitchA-Vlanif50] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif50] quit
    [*SwitchA] commit

    # Configure a routing protocol on SwitchA. OSPFv3 is used in this example.

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 10.1.1.1
    [*SwitchA-ospfv3-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ospfv3 1 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 50
    [*SwitchA-Vlanif50] ospfv3 1 area 0
    [*SwitchA-Vlanif50] quit
    [*SwitchA] commit

  2. Enable IPv6 Bidir-PIM globally and enable IPv6 PIM-SM on all interfaces.

    # Enable IPv6 Bidir-PIM globally on all switches and enable IPv6 PIM-SM on all interfaces. The configurations on SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] bidir-pim
    [*SwitchA-pim6] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 50
    [~SwitchA-Vlanif50] pim ipv6 sm
    [*SwitchA-Vlanif50] commit
    [~SwitchA-Vlanif50] quit
    

  3. Enable MLD on interfaces directly connected to network segments of hosts.

    # Enable MLD on interface of SwitchA connected to the network segment of HostA. The configurations on SwitchB, SwitchC, and SwitchD are similar to the configuration on SwitchA, and are not mentioned here.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] mld enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  4. Configure an RP.

    # Configure VLANIF 60 (with IPv6 address FC00:0:0:2002::2) on the SwitchE as a candidate rendezvous point (C-RP) and candidate bootstrap router (C-BSR) interface, and configure the C-RP to serve IPv6 Bidir-PIM.

    [~SwitchE] pim ipv6
    [*SwitchE-pim6] c-bsr fc00:0:0:2002::2 
    [*SwitchE-pim6] c-rp fc00:0:0:2002::2 bidir
    [*SwitchE-pim6] commit
    [~SwitchE-pim6] quit
    

  5. Verify the configuration.

    # Run the display pim ipv6 bsr-info command on the switches to view BSR information. For example, BSR information on SwitchA and SwitchE is displayed as follows. (The command output on SwitchE also displays C-BSR information.)

    [~SwitchA] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2002::2
         Priority: 0
         Hash mask length: 126
         State: Accept Preferred
         Uptime: 01:40:40
         Expires: 00:01:42
         C-RP Count: 1
    
    
    [~SwitchE] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2002::2
         Priority: 0
         Hash mask length: 126
         State: Elected
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: FC00:0:0:2002::2
         Priority: 0
         Hash mask length: 126
         State:Elected
         Wait to be BSR: 0

    The preceding information shows that the addresses of the elected BSR and C-BSR are both FC00:0:0:2002::2, IPv6 address of VLANIF60 on SwitchE.

    # Run the display pim ipv6 rp-info command on the switches to check RP information. For example, RP information on SwitchA is as follows:

    [~SwitchA] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number: 1
     Group/MaskLen: FF00::/8
         RP: FC00:0:0:2002::2
         Priority: 192
         Uptime: 00:45:13
         Expires: 00:02:17
         BIDIR: Y
    

    The preceding information shows that the address of the elected RP is FC00:0:0:2002::2 (IPv6 address of VLANIF60 on SwitchE), and the elected RP serves IPv6 Bidir-PIM.

    # Run the display pim ipv6 df-info command on the switches to check DF information. For example, DF information on SwitchA and SwitchE is as follows:

    [~SwitchA] display pim ipv6 df-info
     VPN-Instance: public net
     Total Number of DF = 2
    
     RP: FC00:0:0:2002::2
     Interface           DF-Address                            DF-Uptime     Rpf-Interface
     Vlanif10            FE80::225:9E00:C895:7C21(local)       22:25:01      N
     Vlanif50            FE80::2E0:3FFF:FE27:AE05              22:25:01      Y
    [~SwitchE] display pim ipv6 df-info
     VPN-Instance: public net
     Total Number of DF = 4
    
     RP: FC00:0:0:2002::2
     Interface           DF-Address                                DF-Uptime     Rpf-Interface
     Vlanif50            FE80::2E0:3FFF:FE27:AE05(local)           22:31:44      N
     Vlanif60            -                                         -             Y
     Vlanif70            FE80::1E2:4CFD:FE23:BC01(local)           22:31:44      N
     Vlanif80            FE80::324:2D23:DF18:2F3D(local)           22:31:44      N

    # After HostA, HostB, HostC, and HostD join group FF1E::1 using MLD, you can run the display pim ipv6 routing-table command on the switches to view the IPv6 PIM routing table. For example, the IPv6 PIM routing table on SwitchA is as follows:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:2002::2
         Protocol: bidir-pim, Flag: WC
         UpTime: 22:36:47
         Rpf interface: Vlanif50
             Upstream neighbor: FE80::2E0:3FFF:FE27:AE05
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: mld, UpTime: 22:36:46, Expires: - 
            2: Vlanif50(RPF)
                 Protocol: bidir-pim, UpTime: 22:36:47, Expires: -

    You can see that the routing entries are generated by IPv6 Bidir-PIM, and multicast data sent from the hosts (multicast sources) can be forwarded along the bidirectional RPT set up based on the (*, FF1E::1) entry.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:3001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:3002::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 30 70
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3003::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 40 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:3004::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:2004::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 50 60 70 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.5.5.5
     area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2002::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address FC00:0:0:2003::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:2004::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    pim ipv6
     c-bsr FC00:0:0:2002::2
     bidir-pim
     c-rp FC00:0:0:2002::2 bidir
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075361

Views: 25196

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next