No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, NETCONF, OpenFlow, LLDP, NQA, Mirroring, Packet Capture, Packet Trace, Path and Connectivity Detection Configuration, NetStream, sFlow, and iPCA.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an ICMP Test Instance

Example for Configuring an ICMP Test Instance

Networking Requirements

In Figure 8-11, SwitchA, SwitchB, and SwitchC communicate at Layer 3 using VLANIF interfaces.

SwitchA functions as an NQA client to test whether SwitchB is reachable.

Figure 8-11 Networking diagram for configuring an ICMP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an NQA ICMP test instance to test whether the route between the local device (SwitchA) and the specified destination device (SwitchB) is reachable and check the RTT of a test packet.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 10
    [*SwitchB-vlan10] quit
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] commit
    [~SwitchB-10GE1/0/1] quit

  2. Create VLANIF interfaces and assign IP addresses to the VLANIF interfaces.

    # Configure SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.1.1.1 24
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 10.1.1.2 24
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit

  3. Enable the NQA client and create an ICMP NQA test instance.

    [~SwitchA] nqa test-instance admin icmp
    [*SwitchA-nqa-admin-icmp] test-type icmp
    [*SwitchA-nqa-admin-icmp] destination-address ipv4 10.1.1.2
    [*SwitchA-nqa-admin-icmp] commit

  4. Start the test instance immediately.

    [~SwitchA-nqa-admin-icmp] start now
    [*SwitchA-nqa-admin-icmp] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-icmp] display nqa results test-instance admin icmp
                                                                                    
    NQA entry(admin, icmp): test flag is active,test type is ICMP                   
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3                Receive response times: 3             
       Completion:success                     RTD over thresholds number:0           
       Attempts number:1                      Drop operation number:0               
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT Status errors number:0             
       Destination IP address:10.1.1.2                                             
       Min/Max/Average completion time: 2/5/3                                       
       Sum/Square-Sum  completion time: 9/33                                        
       Last response packet receiving time: 2012-08-08 15:53:08.4                                  
       Lost packet ratio: 0 %                                       

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    nqa test-instance admin icmp
     test-type icmp
     destination-address ipv4 10.1.1.2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075365

Views: 37179

Downloads: 125

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next