No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, NETCONF, OpenFlow, LLDP, NQA, Mirroring, Packet Capture, Packet Trace, Path and Connectivity Detection Configuration, NetStream, sFlow, and iPCA.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LLDP on a Network with Link Aggregation Configured

Example for Configuring LLDP on a Network with Link Aggregation Configured

Networking Requirements

As shown in Figure 7-9, SwitchA and SwitchB are connected through an Eth-Trunk. Routes between the NMS and switches are reachable, and SNMP is configured.

A network administrator wants to obtain Layer 2 information about SwitchA and SwitchB to know the detailed network topology and configuration conflicts.

Figure 7-9 Network with link aggregation configured

Configuration Roadmap

The LLDP function can meet the network administrator's requirement. The configuration roadmap is as follows:
  1. Add the physical interfaces on SwitchA and SwitchB to the Eth-Trunk.
  2. Enable global LLDP on SwitchA and SwitchB.
  3. Configure management IP addresses for SwitchA and SwitchB.

Procedure

  1. Add the physical interfaces on SwitchA and SwitchB to the Eth-Trunk.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100
    [*SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchB-Eth-Trunk1] port link-type trunk
    [*SwitchB-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  2. Enable global LLDP on SwitchA and SwitchB.

    # Configure SwitchA.
    [~SwitchA] lldp enable
    [*SwitchA] commit
    # Configure SwitchB.
    [~SwitchB] lldp enable
    [*SwitchB] commit

  3. Configure management IP addresses for SwitchA and SwitchB.

    NOTE:

    The specified IP address must exist on the device. For detailed configurations, see the configuration files.

    # Configure SwitchA.
    [~SwitchA] lldp management-address 10.10.10.1
    [*SwitchA] commit
    # Configure SwitchB.
    [~SwitchB] lldp management-address 10.10.10.2
    [*SwitchB] commit

  4. Verify the configurations.

    • Check the SwitchA configuration.

      # Check whether the physical interfaces have been added to Eth-Trunk1.

      [~SwitchA] display eth-trunk 1
      Eth-Trunk1's state information is:
      WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP
      Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 16
      Operate status: up          Number Of Up Ports In Trunk: 3
      --------------------------------------------------------------------------------
      PortName                Status      Weight
      10GE1/0/1               Up          1
      10GE1/0/2               Up          1
      10GE1/0/3               Up          1                                           

      # Check neighbor information for SwitchA.

      [~SwitchA] display lldp neighbor brief
      Local Interface         Exptime(s) Neighbor Interface      Neighbor Device      
      ------------------------------------------------------------------------------- 
      10GE1/0/1                      115 10GE1/0/1               SwitchB
      10GE1/0/2                      115 10GE1/0/2               SwitchB
      10GE1/0/3                      115 10GE1/0/3               SwitchB
      
    • Check the SwitchB configuration.

      Refer to the steps for checking SwitchA.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
     vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.1 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/1
     eth-trunk 1
    #
    interface 10GE1/0/2
     eth-trunk 1
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    lldp enable
    #
    lldp management-address 10.10.10.1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
     vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.2 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/1
     eth-trunk 1
    #
    interface 10GE1/0/2
     eth-trunk 1
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    lldp enable
    #
    lldp management-address 10.10.10.2
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075365

Views: 35256

Downloads: 123

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next