No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, NETCONF, OpenFlow, LLDP, NQA, Mirroring, Packet Capture, Packet Trace, Path and Connectivity Detection Configuration, NetStream, sFlow, and iPCA.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IOAM

Example for Configuring IOAM

Networking Requirements

In Figure 17-7, there are multiple forwarding paths between Server1 and Server2 on a network. A user wants to monitor the forwarding path of traffic sent from Server1 to Server2 and the forwarding status.

Figure 17-7 Networking diagram for configuring IOAM
Table 17-5 IP addresses of interfaces

Device

Interface

IP Address

SwitchA

100GE1/0/1 192.168.10.1/24
100GE1/0/2 192.168.20.1/24
100GE1/0/3 192.168.30.1/24

SwitchB

100GE1/0/1 192.168.40.1/24
100GE1/0/2 192.168.20.2/24
100GE1/0/3 192.168.50.2/24

SwitchC

100GE1/0/1 192.168.40.2/24
100GE1/0/2 192.168.60.2/24
100GE1/0/3 192.168.30.2/24

SwitchD

100GE1/0/1 192.168.70.1/24
100GE1/0/2 192.168.50.1/24
100GE1/0/3 192.168.60.1/24
100GE1/0/4 192.168.80.1/24

Configuration Roadmap

The configuration roadmap is as follows:
  1. Assign IP addresses to interfaces and configure routing protocols to implement connectivity between nodes.
  2. Configure SwitchA as the ingress node to collect and copy the service traffic sent from Server1 to Server2.
  3. Configure SwitchB and SwitchC as transit nodes to transmit IOAM packets.
  4. Configure SwitchD as the egress node to send IOAM packets to the analyzer.

Procedure

  1. Assign IP addresses to interfaces and configure routing protocols to implement connectivity between nodes. For details, see Configuration Files.
  2. Configure SwitchA as the ingress node to collect and copy the service traffic sent from Server1 to Server2.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] acl 3001
    [*SwitchA-acl4-advance-3001] rule 5 permit ip source 192.168.10.10 24 destination 192.168.70.10 24
    [*SwitchA-acl4-advance-3001] quit
    [*SwitchA] traffic classifier c1
    [*SwitchA-classifier-c1] if-match acl 3001
    [*SwitchA-classifier-c1] quit
    [*SwitchA] traffic behavior b1
    [*SwitchA-behavior-b1] ioam enable sampling-rate 10
    [*SwitchA-behavior-b1] quit
    [*SwitchA] traffic policy p1
    [*SwitchA-trafficpolicy-p1] classifier c1 behavior b1
    [*SwitchA-trafficpolicy-p1] quit
    [*SwitchA] interface 100ge 1/0/1
    [*SwitchA-100GE1/0/1] traffic-policy p1 inbound
    [*SwitchA-100GE1/0/1] quit
    [*SwitchA] commit
    [~SwitchA] ioam device-id 1 add-metadata
    [*SwitchA] commit
    

  3. Configure SwitchB and SwitchC as transit nodes to transmit IOAM packets.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] ioam device-id 2 add-metadata
    [*SwitchB] commit
    
    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] ioam device-id 3 add-metadata
    [*SwitchC] commit
    

  4. Configure SwitchD as the egress node to send IOAM packets to the analyzer.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchD
    [*HUAWEI] commit
    [~SwitchD] ioam device-id 4 termination 192.168.80.10 5000
    [*SwitchD] commit
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    acl number 3001
     rule 5 permit ip source 192.168.10.0 0.0.0.255 destination 192.168.70.0 0.0.0.255
    #
    traffic classifier c1 type or
     if-match acl 3001
    #
    traffic behavior b1
     ioam enable sampling-rate 10
    #
    traffic policy p1
     classifier c1 behavior b1 precedence 5
    #
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
    #
    interface 100GE1/0/1
     port default vlan 10
     traffic-policy p1 inbound
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.20.1 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.30.1 255.255.255.0
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 1 add-metadata
    #
    ospf 1
     area 0.0.0.0
      network 192.168.10.0 0.0.0.255
      network 192.168.20.0 0.0.0.255
      network 192.168.30.0 0.0.0.255
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    interface 100GE1/0/1
     undo portswitch
     ip address 192.168.40.1 255.255.255.0
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.20.2 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.50.2 255.255.255.0
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 2 add-metadata
    #
    ospf 1
     area 0.0.0.0
      network 192.168.20.0 0.0.0.255
      network 192.168.40.0 0.0.0.255
      network 192.168.50.0 0.0.0.255
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    interface 100GE1/0/1
     undo portswitch
     ip address 192.168.40.2 255.255.255.0
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.60.2 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.30.2 255.255.255.0
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 3 add-metadata
    #
    ospf 1
     area 0.0.0.0
      network 192.168.30.0 0.0.0.255
      network 192.168.40.0 0.0.0.255
      network 192.168.60.0 0.0.0.255
    #
    return
    
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 192.168.70.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.80.1 255.255.255.0
    #
    interface 100GE1/0/1
     port default vlan 20
    #
    interface 100GE1/0/2
     undo portswitch
     ip address 192.168.50.1 255.255.255.0
    #
    interface 100GE1/0/3
     undo portswitch
     ip address 192.168.60.1 255.255.255.0
    #
    interface 100GE1/0/4
     port default vlan 30
    #
    ioam header 0xaaaaaaaabbbbbbbb device-id 4 termination 192.168.80.10 5000
    #
    ospf 1
     area 0.0.0.0
      network 192.168.50.0 0.0.0.255
      network 192.168.60.0 0.0.0.255
      network 192.168.70.0 0.0.0.255
      network 192.168.80.0 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075365

Views: 34823

Downloads: 123

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next