No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, NETCONF, OpenFlow, LLDP, NQA, Mirroring, Packet Capture, Packet Trace, Path and Connectivity Detection Configuration, NetStream, sFlow, and iPCA.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a UDP Jitter Test Instance

Example for Configuring a UDP Jitter Test Instance

Networking Requirements

The NQA jitter test instance is used to obtain the jitter time of transmitting a packet from SwitchA to SwitchC, as shown in Figure 8-15.

Figure 8-15 Networking diagram for configuring a UDP Jitter test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client and SwtichC as an NQA server.

  2. Configure the monitoring IP address and port number on the NQA server, and configure a jitter test instance on the NQA client.

Procedure

  1. Configure each interface and ensure reachable routes between Switches, as shown in Figure 8-15.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] quit
    [*SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    [*SwitchA] commit

  2. Configure the NQA server on SwitchC.

    # Configure the IP address and port number for monitoring UDP services on the NQA server.

    <SwitchC> system-view
    [~SwitchC] nqa server udpecho 10.2.1.2 9000
    [*SwitchC] commit

  3. Configure SwitchA.

    # Enable the NQA client and create an NQA jitter test instance.

    [~SwitchA] nqa test-instance admin jitter
    [*SwitchA-nqa-admin-jitter] test-type jitter
    [*SwitchA-nqa-admin-jitter] destination-address ipv4 10.2.1.2
    [*SwitchA-nqa-admin-jitter] destination-port 9000 
    [*SwitchA-nqa-admin-jitter] commit 

  4. Start the test instance.

    [~SwitchA-nqa-admin-jitter] start now
    [*SwitchA-nqa-admin-jitter] commit

  5. Verify the configuration.

    [~SwitchA-nqa-admin-jitter] display nqa results test-instance admin jitter
    
    NQA entry(admin, jitter): test flag is inactive, test type is JITTER
      1 . Test 1 result   The test is finished
       SendProbe: 60                          ResponseProbe: 60                     
       Completion: success                    RTD over thresholds number: 0         
       OWD over thresholds SD number: 0       OWD over thresholds DS number: 0      
       Min/Max/Avg/Sum RTT: 2/77/7/401        RTT square sum: 11877                 
       Num of RTT: 60                         Drop operation number: 0              
       Operation sequence errors number: 0    RTT Status errors number: 0           
       System busy operation number: 0        Operation timeout number: 0           
       Min positive SD: 1                     Min positive DS: 1                    
       Max positive SD: 10                    Max positive DS: 2                    
       Positive SD number: 7                  Positive DS number: 14                
       Positive SD sum: 16                    Positive DS sum: 16                   
       Positive SD square sum: 106            Positive DS square sum: 20            
       Min negative SD: 1                     Min negative DS: 1                    
       Max negative SD: 10                    Max negative DS: 21                   
       Negative SD number: 9                  Negative DS number: 18                
       Negative SD sum: 18                    Negative DS sum: 88                   
       Negative SD square sum: 108            Negative DS square sum: 1368          
       Min delay SD: 1                        Min delay DS: 0                       
       Avg delay SD: 3                        Avg delay DS: 2                       
       Max delay SD: 38                       Max delay DS: 38                      
       Delay SD square sum: 2858              Delay DS square sum: 2723             
       Packet loss SD: 0                      Packet loss DS: 0                     
       Packet loss unknown: 0                 Average of jitter: 2                  
       Average of jitter SD: 2                Average of jitter DS: 3               
       Jitter out value: 0.4763590            Jitter in value: 1.5859300            
       Number of OWD: 60                      Packet loss ratio: 0 %                
       OWD SD sum: 184                        OWD DS sum: 157                       
       ICPIF value: 0                         MOS-CQ value: 0                       
       TimeStamp unit: ms

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
     ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin jitter
     test-type jitter
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
     nqa server udpecho 10.2.1.2 9000
    #
     ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100075365

Views: 40031

Downloads: 127

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next