No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Single-Hop BFD to Detect Faults on a Layer 2 Link

Example for Configuring Single-Hop BFD to Detect Faults on a Layer 2 Link

Networking Requirements

In Figure 2-24, SwitchA and SwitchB are connected through a Layer 2 interface. Faults on the link between SwitchA and SwitchB need to be quickly detected.

Figure 2-24 Networking diagram for configuring single-hop BFD to detect faults on a Layer 2 link

Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on SwitchA and SwitchB to detect faults on the link between them.

Procedure

  1. Configure interfaces that connect SwitchA and SwitchB to ensure transmission of packets at Layer 2.

    # Configure SwitchA. The configuration of SwitchB is similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    

  2. Configure single-hop BFD on SwitchA.

    # Enable BFD on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit

    # Create a BFD session on SwitchA.

    [*SwitchA] bfd atob bind peer-ip default-ip interface 10ge 1/0/1
    [*SwitchA-bfd-session-atob] discriminator local 1
    [*SwitchA-bfd-session-atob] discriminator remote 2
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit
    

  3. Configure single-hop BFD on SwitchB.

    # Enable BFD on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit

    # Create a BFD session on SwitchB.

    [*SwitchB] bfd btoa bind peer-ip default-ip interface 10ge 1/0/1
    [*SwitchB-bfd-session-btoa] discriminator local 2
    [*SwitchB-bfd-session-btoa] discriminator remote 1
    [*SwitchB-bfd-session-btoa] commit
    [~SwitchB-bfd-session-btoa] quit

  4. Verify the configuration.

    Run the display bfd session all verbose command on SwitchA and SwitchB.

    The output on SwitchA is used as an example and shows that a single-hop BFD session is set up and is in Up state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up                           
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/0/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/0/1                                            
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                       
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on 10GE1/0/1 of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that a single-hop BFD session is set up and is in Down state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Down                         
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/0/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/0/1                                            
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 4331             Actual Rx Interval (ms): 4331       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    bfd
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd atob bind peer-ip default-ip interface 10GE1/0/1
     discriminator local 1
     discriminator remote 2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    bfd
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd btoa bind peer-ip default-ip interface 10GE1/0/1
     discriminator local 2
     discriminator remote 1
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 14957

Downloads: 36

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next