No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring CC Based on the Interface Number and VLAN ID

Example for Configuring CC Based on the Interface Number and VLAN ID

Networking Requirements

As networks develop quickly, IP networks carry multiple services such as voice and video services increasingly. The services pose high requirements on network reliability. Networks need to provide fast fault detection and processing.

In Figure 7-21, link connectivity needs to be detected.

Figure 7-21 Configuring CC based on the interface number and VLAN ID

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Layer 2 connectivity on SwitchA, SwitchB, and SwitchC.

  2. Configure CC on SwitchA and SwitchC to detect link connectivity.

  3. Configure association between CFM and an interface on SwitchA and configure SwitchA to disable and enable the associated interface when CFM detects a fault.

Procedure

  1. Configure VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 10
    [*SwitchB-vlan10] quit
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] commit

    # Configure SwitchC.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] vlan 10
    [*SwitchC-vlan10] quit
    [*SwitchC] interface 10ge 1/0/1
    [*SwitchC-10GE1/0/1] port link-type trunk
    [*SwitchC-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchC-10GE1/0/1] quit
    [*SwitchC] commit

  2. Configure CC.

    # Enable global CFM on SwitchA.

    [~SwitchA] cfm enable
    Info: Succeeded in enabling CFM.
    [*SwitchA] commit

    # Enable global CFM on SwitchC.

    [~SwitchC] cfm enable
    Info: Succeeded in enabling CFM.
    [*SwitchC] commit

    # Enable CC on SwitchA.

    [~SwitchA] cfm md md1
    [*SwitchA-md-md1] ma ma1
    [*SwitchA-md-md1-ma-ma1] map vlan 10
    [*SwitchA-md-md1-ma-ma1] mep mep-id 1 interface 10ge 1/0/1 outward
    [*SwitchA-md-md1-ma-ma1] mep ccm-send mep-id 1 enable
    [*SwitchA-md-md1-ma-ma1] remote-mep mep-id 2
    [*SwitchA-md-md1-ma-ma1] remote-mep ccm-receive mep-id 2 enable
    [*SwitchA-md-md1-ma-ma1] quit
    [*SwitchA-md-md1] quit
    [*SwitchA] commit

    # Enable CC on SwitchC.

    [~SwitchC] cfm md md1
    [*SwitchC-md-md1] ma ma1
    [*SwitchC-md-md1-ma-ma1] map vlan 10
    [*SwitchC-md-md1-ma-ma1] mep mep-id 2 interface 10ge 1/0/1 outward
    [*SwitchC-md-md1-ma-ma1] mep ccm-send mep-id 2 enable
    [*SwitchC-md-md1-ma-ma1] remote-mep mep-id 1
    [*SwitchC-md-md1-ma-ma1] remote-mep ccm-receive mep-id 1 enable
    [*SwitchC-md-md1-ma-ma1] quit
    [*SwitchC-md-md1] quit
    [*SwitchC] commit

    # Verify the configuration.

    After the configuration is complete, run the display cfm remote-mep command on SwitchA and SwitchC. You can see that the CFM status is up.

    [~SwitchA] display cfm remote-mep
    The total number of RMEPs is : 1                                                                                                    
    The status of RMEPs : 1 up, 0 down, 0 disable                                                                                       
    --------------------------------------------------                                                                                  
     MD Name            : md1                                                                                                           
     Level              : 0                                                                                                             
     MA Name            : ma1                                                                                                           
     RMEP ID            : 2                                                                                                             
     VLAN ID            : 10                                                                                                            
     MAC                : 200b-c739-1301                                                                                                
     CCM Receive        : enabled                                                                                                       
     Trigger-If-Down    : disabled                                                                                                      
     Trigger-If-Link    : disabled                                                                                                      
     CFM Status         : up                                                                                                            
     Alarm Status       : none                    
    [~SwitchC] display cfm remote-mep
    The total number of RMEPs is : 1                                                                                                    
    The status of RMEPs : 1 up, 0 down, 0 disable                                                                                       
    --------------------------------------------------                                                                                  
     MD Name            : md1                                                                                                           
     Level              : 0                                                                                                             
     MA Name            : ma1                                                                                                           
     RMEP ID            : 1                                                                                                             
     VLAN ID            : 10                                                                                                            
     MAC                : 749d-8f4c-dad1                                                                                                
     CCM Receive        : enabled                                                                                                       
     Trigger-If-Down    : disabled                                                                                                      
     Trigger-If-Link    : disabled                                                                                                      
     CFM Status         : up                                                                                                            
     Alarm Status       : none                    

  3. Configure association between CFM and an interface on SwitchA and configure SwitchA to disable and enable the associated interface when CFM detects a fault.

    # Configure association between CFM and an interface on SwitchA.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] cfm md md1 ma ma1 remote-mep mep-id 2 trigger if-down
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # Verify the configuration.

    After the configuration is complete, run the display cfm remote-mep command on SwitchA. You can see that the value of Trigger-If-Down is enabled.

    [~SwitchA] display cfm remote-mep
    The total number of RMEPs is : 1                                                                                                    
    The status of RMEPs : 1 up, 0 down, 0 disable                                                                                       
    --------------------------------------------------                                                                                  
     MD Name            : md1                                                                                                           
     Level              : 0                                                                                                             
     MA Name            : ma1                                                                                                           
     RMEP ID            : 2                                                                                                             
     VLAN ID            : 10                                                                                                            
     MAC                : 200b-c739-1301                                                                                                
     CCM Receive        : enabled                                                                                                       
     Trigger-If-Down    : enabled                                                                                                      
     Trigger-If-Link    : disabled                                                                                                      
     CFM Status         : up                                                                                                            
     Alarm Status       : none                    

    After the configuration is complete, run the shutdown command on 10GE1/0/2 of SwitchB to simulate a link fault so that the remote device cannot receive CFM packets.

    [~SwitchB] interface 10ge 1/0/2
    [~SwitchB-10GE1/0/2] shutdown
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] commit

    You can see that the value of current state is TRIGGER DOWN (1AG auto recover) on 10GE1/0/1 of SwitchA.

    [~SwitchA] display interface 10ge 1/0/1
    10GE1/0/1 current state : TRIGGER DOWN (1AG auto recover) (ifindex: 276)                                                           
    Line protocol current state : DOWN  
    ...
    NOTE:

    The key information of the display interface 10ge 1/0/1 command output is displayed here, and "..." indicates that some information is omitted.

    Several seconds later, you can see that the value of Line protocol current state is DOWN (CFM down) on 10GE1/0/1 of SwitchA.

    [~SwitchA] display interface 10ge 1/0/1
    10GE1/0/1 current state : UP (ifindex: 276)                                                                                        
    Line protocol current state : UP
    ...
    NOTE:

    The key information of the display interface 10ge 1/0/1 command output is displayed here, and "..." indicates that some information is omitted.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    cfm enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     cfm md md1 ma ma1 remote-mep mep-id 2 trigger if-down
    #
    cfm md md1
     ma ma1
      vlan 10
      mep mep-id 1 interface 10GE1/0/1 outward
      mep ccm-send mep-id 1 enable
      remote-mep mep-id 2
      remote-mep ccm-receive mep-id 2 enable
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    cfm enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md1
     ma ma1
      vlan 10
      mep mep-id 2 interface 10GE1/0/1 outward
      mep ccm-send mep-id 2 enable
      remote-mep mep-id 1
      remote-mep ccm-receive mep-id 1 enable
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 14864

Downloads: 36

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next