No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between VRRP and VRID-based Dynamic BFD to Implement a Rapid Active/Standby Switchover

Example for Configuring Association Between VRRP and VRID-based Dynamic BFD to Implement a Rapid Active/Standby Switchover

Networking Requirements

In Figure 3-22, hosts on a LAN are dual-homed to SwitchA and SwitchB through the switch. A VRRP group is established on SwitchA and SwitchB, and SwitchA is the master.

When SwitchA or the link between SwitchA and the Switch is faulty, the switchover period is within 1s. This reduces the impact of the fault on service transmission.

Figure 3-22 Networking diagram for configuring association between VRRP and VRID-based dynamic BFD to implement a rapid active/standby switchover

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.
  2. Configure a VRRP group on SwitchA and SwitchB, set the priority of SwitchA to 120 and the preemption delay to 20s so that SwitchA functions as the master, and set the default priority for SwitchB so that SwitchB functions as the backup.
  3. Configure association between VRRP and VRID-based dynamic BFD on SwitchA and SwitchB to implement a rapid active/standby switchover if the link is faulty.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface and configure a routing protocol. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] quit
    [*SwitchA-ospf-1] quit
    [*SwitchA] commit

  2. Configure VRRP groups.

    # Configure VRRP group 1 on SwitchA, and set the priority of SwitchA to 120 and the preemption delay to 20s.

    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.3
    [*SwitchA-Vlanif100] vrrp vrid 1 priority 120
    [*SwitchA-Vlanif100] vrrp vrid 1 preempt timer delay 20
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

    # Configure VRRP group 1 on SwitchB, and set the default priority of 100 for SwitchB.

    [~SwitchB] interface vlanif 100
    [~SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.3
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit

  3. Enable global BFD.

    # Enable BFD on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] commit

    # Enable BFD on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit
    [*SwitchB] commit

  4. Configure association between VRRP and VRID-based dynamic BFD.

    # Configure association between VRRP and VRID-based dynamic BFD on SwitchA.

    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] vrrp vrid 1 bfd peer-ip 10.1.1.2
    [*SwitchA-Vlanif100] vrrp vrid 1 bfd min-rx-interval 300 min-tx-interval 300 detect-multiplier 5
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

    # Configure association between VRRP and VRID-based dynamic BFD on SwitchB.

    [~SwitchB] interface vlanif 100
    [~SwitchB-Vlanif100] vrrp vrid 1 bfd peer-ip 10.1.1.1
    [*SwitchB-Vlanif100] vrrp vrid 1 bfd min-rx-interval 300 min-tx-interval 300 detect-multiplier 5
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit

    Run the display vrrp bfd session command on SwitchA and SwitchB. You can see that the BFD session is Up. The display on SwitchA is used as an example.

    [~SwitchA] display vrrp bfd session all
    Total BFD session(s) for VRRP: 1                                                
    ----------------------------------------------------------------                
    Interface                : Vlanif100                                            
    TXInterval(milliseconds) : 300  / 300  (Config / Running)                       
    RXInterval(milliseconds) : 300  / 300  (Config / Running)                       
    DetectMultiplier         : 5    / 5    (Config / Running)                       
    LocalIP                  : 10.1.1.1                                             
    PeerIP                   : 10.1.1.2                                             
    BFD State                : UP

  5. Verify the configuration.

    # Run the display vrrp command on SwitchA and SwitchB. SwitchA is the master, SwitchB is the backup, and the associated BFD session is in Up state.

    [~SwitchA] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Master
    Virtual IP     : 10.1.1.3
    Master IP      : 10.1.1.1
    PriorityRun    : 120
    PriorityConfig : 120
    MasterPriority : 120
    Preempt        : YES   Delay Time : 20s   Remain : --
    TimerRun       : 1s 
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Normal
    BFD-session State : UP               Type:Dynamic
    Create Time       : 2012-05-22 17:32:56
    Last Change Time  : 2012-05-22 17:33:00
    [~SwitchB] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Backup
    Virtual IP     : 10.1.1.3
    Master IP      : 10.1.1.1
    PriorityRun    : 100
    PriorityConfig : 100
    MasterPriority : 120
    Preempt        : YES   Delay Time : 0s   Remain : --
    TimerRun       : 1s 
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Normal
    BFD-session State : UP               Type:Dynamic
    Create Time       : 2012-05-22 17:33:00
    Last Change Time  : 2012-05-22 17:33:04

    # Run the shutdown command on 10GE1/0/1 of SwitchA to simulate a link fault. Then run the display vrrp command on SwitchA and SwitchB. You can see that SwitchA is in Initialize state, SwitchB becomes the master, and the associated BFD session goes Down.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    [~SwitchA] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Initialize
    Virtual IP     : 10.1.1.3
    Master IP      : 0.0.0.0
    PriorityRun    : 120
    PriorityConfig : 120
    MasterPriority : 0
    Preempt        : YES   Delay Time : 20s   Remain : --
    TimerRun       : 1s 
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Normal
    BFD-session State : DOWN             Type:Dynamic
    Create Time       : 2012-05-22 17:32:56
    Last Change Time  : 2012-05-22 17:33:06
    [~SwitchB] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Master
    Virtual IP     : 10.1.1.3
    Master IP      : 10.1.1.2
    PriorityRun    : 100
    PriorityConfig : 100
    MasterPriority : 100
    Preempt        : YES   Delay Time : 0s   Remain : --
    TimerRun       : 1s 
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Normal
    BFD-session State : DOWN             Type:Dynamic 
    Create Time       : 2012-05-22 17:33:00
    Last change Time  : 2012-05-22 17:33:06

    # Run the undo shutdown command on 10GE1/0/1 of SwitchA. After 20s, run the display vrrp command on SwitchA and SwitchB. You can see that SwitchA is the master, SwitchB is the backup, and the associated BFD session is in Up state.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] undo shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    [~SwitchA] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Master
    Virtual IP     : 10.1.1.3
    Master IP      : 10.1.1.1
    PriorityRun    : 120
    PriorityConfig : 120
    MasterPriority : 120
    Preempt        : YES   Delay Time : 20s   Remain : --
    TimerRun       : 1s 
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Normal
    BFD-session State : UP               Type:Dynamic
    Create Time       : 2012-05-22 17:32:56
    Last Change Time  : 2012-05-22 17:33:50
    [~SwitchB] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Backup
    Virtual IP     : 10.1.1.3
    Master IP      : 10.1.1.1
    PriorityRun    : 100
    PriorityConfig : 100
    MasterPriority : 120
    Preempt        : YES   Delay Time : 0s   Remain : --
    TimerRun       : 1s 
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Normal
    BFD-session State : UP               Type:Dynamic
    Create Time       : 2012-05-22 17:33:00
    Last Change Time  : 2012-05-22 17:33:50

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt timer delay 20
     vrrp vrid 1 bfd peer-ip 10.1.1.2
     vrrp vrid 1 bfd min-tx-interval 300 min-rx-interval 300 detect-multiplier 5 
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 bfd peer-ip 10.1.1.1
     vrrp vrid 1 bfd min-tx-interval 300 min-rx-interval 300 detect-multiplier 5
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 21677

Downloads: 64

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next