No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Single-Hop BFD for IPv6

Example for Configuring Single-Hop BFD for IPv6

Networking Requirements

In Figure 2-31, SwitchA connects to SwitchB through the VLANIF interface. Faults on the link between SwitchA and SwitchB need to be quickly detected.

Figure 2-31 Networking diagram for configuring single-hop BFD for IPv6

Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on SwitchA and SwitchB.

Procedure

  1. On SwitchA and SwitchB, create VLANs and add 10GE1/0/1 interfaces to VLANs.

    # Configure SwitchA. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    The configuration of SwitchB is similar to the configuration of SwitchA. See the configuration file for details.

  2. Configure IPv6 addresses for VLANIF interfaces so that SwitchA and SwitchB can communicate at Layer 3.

    # Configure SwitchA. The configuration of SwitchB is similar to the configuration of SwitchA.

    [~SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

  3. Configure single-hop BFD.

    # Enable BFD and create a BFD session on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] bfd atob bind peer-ipv6 fc00:0:0:2001::2 interface vlanif 100
    [*SwitchA-bfd-session-atob] discriminator local 1
    [*SwitchA-bfd-session-atob] discriminator remote 2
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit
    

    # Enable BFD and create a BFD session on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit
    [*SwitchB] bfd btoa bind peer-ipv6 fc00:0:0:2001::1 interface vlanif 100
    [*SwitchB-bfd-session-btoa] discriminator local 2
    [*SwitchB-bfd-session-btoa] discriminator remote 1
    [*SwitchB-bfd-session-btoa] commit
    [~SwitchB-bfd-session-btoa] quit
    

  4. Verify the configuration.

    Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that a single-hop BFD session is set up and is in Up state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                    (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : FC00:0:0:2001::2         
      Bind Interface         : Vlanif100
      FSM Board ID           : 1                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on the 10GE1/0/1 interface of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that a single-hop BFD session is set up and is in Down state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                    (Single Hops)   State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : FC00:0:0:2001::2         
      Bind Interface         : Vlanif100
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 10093            Actual Rx Interval (ms): 10093      
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    bfd atob bind peer-ipv6 FC00:0:0:2001::2 interface Vlanif100
     discriminator local 1
     discriminator remote 2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    bfd btoa bind peer-ipv6 FC00:0:0:2001::1 interface Vlanif100
     discriminator local 2
     discriminator remote 1
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 15075

Downloads: 37

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next